aboutsummaryrefslogtreecommitdiff
path: root/japanese/expect
diff options
context:
space:
mode:
authorSteve Price <steve@FreeBSD.org>1998-10-10 04:09:05 +0000
committerSteve Price <steve@FreeBSD.org>1998-10-10 04:09:05 +0000
commit861a2822efa3d658c19b1c6cb96c73ca9539bb49 (patch)
treed0e11d77cafd5c86de6d6b72cd278cecf576bfe8 /japanese/expect
parent40e26efbb595c90b5081bedbc388483ae062511a (diff)
downloadports-861a2822efa3d658c19b1c6cb96c73ca9539bb49.tar.gz
ports-861a2822efa3d658c19b1c6cb96c73ca9539bb49.zip
Update to version 5.28.
PR: 8182 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=13824
Diffstat (limited to 'japanese/expect')
-rw-r--r--japanese/expect/Makefile8
-rw-r--r--japanese/expect/distinfo2
-rw-r--r--japanese/expect/files/patch-aa56
-rw-r--r--japanese/expect/files/patch-ab16
-rw-r--r--japanese/expect/pkg-plist22
5 files changed, 56 insertions, 48 deletions
diff --git a/japanese/expect/Makefile b/japanese/expect/Makefile
index 286a33ac6b2d..f1ea81110472 100644
--- a/japanese/expect/Makefile
+++ b/japanese/expect/Makefile
@@ -3,11 +3,11 @@
# Date created: 17 Oct 1997
# Whom: taguchi
#
-# $Id: Makefile,v 1.10 1998/07/27 00:12:13 steve Exp $
+# $Id: Makefile,v 1.11 1998/09/28 15:15:04 kuriyama Exp $
#
-DISTNAME= expect-5.26
-PKGNAME= ja-expect-5.26
+DISTNAME= expect-5.28
+PKGNAME= ja-expect-5.28
CATEGORIES= japanese lang tk80
MASTER_SITES= ftp://peloton.physics.montana.edu/pub/distfiles/
@@ -27,7 +27,7 @@ NO_MAN_INSTALL= yes
post-install:
${SETENV} OBJFORMAT=${PORTOBJFORMAT} ${LDCONFIG} -m ${PREFIX}/lib
if [ "${PORTOBJFORMAT}" = "aout" ]; then \
- ${LN} -sf libexpect526jp.so.1.2 ${PREFIX}/lib/libexpect526jp.so; \
+ ${LN} -sf libexpect528jp.so.1.2 ${PREFIX}/lib/libexpect528jp.so; \
fi
.include <bsd.port.mk>
diff --git a/japanese/expect/distinfo b/japanese/expect/distinfo
index e2a57b930d66..b2c89a95cd3d 100644
--- a/japanese/expect/distinfo
+++ b/japanese/expect/distinfo
@@ -1 +1 @@
-MD5 (expect-5.26.tar.gz) = e3be881aa610f130f77158e12b515844
+MD5 (expect-5.28.tar.gz) = 4fd07ed06049da86f63f8b0aa188367a
diff --git a/japanese/expect/files/patch-aa b/japanese/expect/files/patch-aa
index dffab0d1aa72..5d763ec82c20 100644
--- a/japanese/expect/files/patch-aa
+++ b/japanese/expect/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.in.ORIG Fri Sep 25 15:07:28 1998
-+++ Makefile.in Fri Sep 25 15:31:01 1998
-@@ -30,7 +30,7 @@
+--- Makefile.in.ORIG Wed Oct 7 14:07:34 1998
++++ Makefile.in Wed Oct 7 14:11:25 1998
+@@ -24,7 +24,7 @@
TCL_LIBRARY = @TCL_LIBRARY@
# Tcl library uninstalled. Should be something like -ltcl or ../tcl/libtcl.a
@@ -9,7 +9,7 @@
# Tcl library installed. Should be something like -ltcl or ../tcl/libtcl.a
TCLLIB_INSTALLED = @TCL_LIB_SPEC@
-@@ -38,7 +38,7 @@
+@@ -32,7 +32,7 @@
# Tk include files
TKHDIRDASHI = @TKHDIRDASHI@
# Tk library
@@ -18,7 +18,7 @@
TKLIB_INSTALLED = @TK_LIB_SPEC@
# X11 include files and other flags to compiler
X11_CFLAGS = @TK_XINCLUDES@
-@@ -63,7 +63,7 @@
+@@ -57,7 +57,7 @@
# your Expect scripts.
# Note: On Linux systems which only have dynamic X libraries, the -g prevents
# the linker from using them. So do not use -g on such systems.
@@ -27,7 +27,7 @@
#XCFLAGS = @CFLAGS@ @EXP_CFLAGS@ @EXP_SHLIB_CFLAGS@
XCFLAGS = @CFLAGS@ @EXP_CFLAGS@
-@@ -174,7 +174,7 @@
+@@ -171,7 +171,7 @@
man1dir = $(mandir)/man1
man3dir = $(mandir)/man3
infodir = @infodir@
@@ -36,7 +36,7 @@
# Expect's utility script directories - arch-independent and arch-non-
# independent. These correspond to the variables "exp_library" and
-@@ -186,12 +186,13 @@
+@@ -183,12 +183,13 @@
INSTALL = @INSTALL@
INSTALL_PROGRAM = @INSTALL_PROGRAM@
@@ -51,7 +51,7 @@
# These definitions are used by the "subdirs_do" target to pass
# the compile flags down recursively.
-@@ -202,6 +203,7 @@
+@@ -199,6 +200,7 @@
"HDEFS=$(HDEFS)" \
"INSTALL=$(INSTALL)" \
"INSTALL_DATA=$(INSTALL_DATA)" \
@@ -59,7 +59,7 @@
"INSTALL_PROGRAM=$(INSTALL_PROGRAM)" \
"LDFLAGS=$(LDFLAGS)" \
"RUNTEST=$(RUNTEST)" \
-@@ -217,9 +219,9 @@
+@@ -214,9 +216,9 @@
# These let the DejaGnu test suite run when DejaGnu isn't
# installed yet, so run it from the srcdir and objdir.
EXPECT = ` \
@@ -72,7 +72,7 @@
RUNTESTFLAGS =
RUNTEST = ` \
-@@ -319,16 +321,16 @@
+@@ -316,16 +318,16 @@
$(CC) -c $(CFLAGS_INT) @EXP_SHLIB_CFLAGS@ $(STTY) $(HDEFS) $< -o shared/$@ ; \
fi
@@ -93,7 +93,7 @@
# install Expect library
# This is done before the install target because the libraries have to be
-@@ -341,21 +343,25 @@
+@@ -338,21 +340,25 @@
# Local copy is pkgIndex rather than pkgIndex.tcl because pkgIndex.tcl.in
# is too long for some filesystems, sigh.
install_shared_lib: $(EXP_LIB_FILES)
@@ -128,7 +128,7 @@
# Build Expect with TestCenter
expect.tc: exp_main_exp.o $(OFILES)
-@@ -368,13 +374,13 @@
+@@ -365,13 +371,13 @@
# together. I could fix it by testing all the libraries (again, in Expect's
# configure) separately for Expectk, but as far as I know, it doesn't hurt
# anything here, so I'm not worrying about it.
@@ -149,7 +149,7 @@
# Build Expectk with TestCenter
expectk.tc: exp_main_tk.o $(OFILES)
-@@ -392,24 +398,24 @@
+@@ -389,24 +395,24 @@
# rule out for each file, sigh).
$(EXP_SHARED_LIB_FILE): $(OFILES)
-rm -f $(EXP_SHARED_LIB_FILE)
@@ -184,7 +184,14 @@
# install Expect's public include files
# $(INSTALL_DATA) expect_cf.h $(includedir)
$(INSTALL_DATA) $(srcdir)/expect.h $(includedir)
-@@ -430,15 +432,10 @@
+@@ -421,21 +427,16 @@
+ TCL_LIBRARY=$(TCL_LIBRARY) ; \
+ export TCL_LIBRARY ; \
+ if $(LOCAL_EXPECT) $(srcdir)/fixcat ; then \
+- $(INSTALL_DATA) $(srcdir)/fixcat $(EXECSCRIPTDIR)/cat-buffers ; \
++ $(INSTALL_DATA) $(srcdir)/fixcat $(EXECSCRIPTDIR)/cat-buffers-jp ; \
+ else true; fi
+ # install standalone scripts and their man pages, if requested
${srcdir}/mkinstalldirs $(bindir_arch_indep) $(man1dir) $(SCRIPTDIR) $(EXECSCRIPTDIR)
-for i in $(SCRIPT_LIST) ; do \
if [ -f $$i ] ; then \
@@ -201,25 +208,26 @@
$(SCRIPT_LIST):
TCL_LIBRARY=$(TCL_LIBRARY) ; \
-@@ -448,14 +445,11 @@
+@@ -445,27 +446,21 @@
# Delete all the installed files that the `install' target creates
# (but not the noninstalled files such as `make all' creates)
uninstall:
- -rm -f $(bindir)/expectk \
- $(man1dir)/expect.1 \
- $(man1dir)/expectk.1 \
-- $(libdir)/$(EXP_SHARED_LIB_FILE) \
+ -rm -f $(bindir)/expectkjp \
-+ $(tcl_libdir)/$(EXP_SHARED_LIB_FILE) \
+ $(libdir)/$(EXP_SHARED_LIB_FILE) \
$(tcl_libdir)/$(EXP_SHARED_LIB_FILE) \
-- $(libdir)/$(EXP_UNSHARED_LIB_FILE) \
+ $(libdir)/$(EXP_UNSHARED_LIB_FILE) \
$(tcl_libdir)/$(EXP_UNSHARED_LIB_FILE) \
+ $(libdir)/pkgIndex.tcl \
- $(man3dir)/libexpect.3 \
-+ $(tcl_libdir)/$(EXP_UNSHARED_LIB_FILE) \
$(includedir)/expect_cf.h \
$(includedir)/expect.h \
$(includedir)/expect_tcl.h \
-@@ -464,10 +458,7 @@
+ $(includedir)/expect_comm.h \
+- $(EXECSCRIPTDIR)/cat-buffers
++ $(EXECSCRIPTDIR)/cat-buffers-jp
# debugger is not removed, since other things could depend on it
# remove standalone scripts and man pages
-for i in $(SCRIPT_LIST) ; do \
@@ -231,7 +239,7 @@
done
###################################
-@@ -514,7 +505,7 @@
+@@ -516,7 +511,7 @@
# delete all files from current directory that are created by "make"
clean:
-rm -rf *~ *.o shared core \
@@ -240,7 +248,7 @@
dumb exho devtty \
$(EXP_UNSHARED_LIB_FILE) $(EXP_SHARED_LIB_FILE) \
$(SCRIPT_LIST)
-@@ -530,7 +521,7 @@
+@@ -532,7 +527,7 @@
# because most people don't have to worry about them
mostlyclean:
-rm -rf *~ *.o shared core \
@@ -249,7 +257,7 @@
$(EXP_UNSHARED_LIB_FILE) $(EXP_SHARED_LIB_FILE)
@$(MAKE) subdir_do DO=$@ $(FLAGS_TO_PASS)
-@@ -680,7 +671,7 @@
+@@ -684,7 +679,7 @@
expect-$(VERSION).tar.gz: expect-$(VERSION).tar
gzip -fc expect-$(VERSION).tar > $@
@@ -258,7 +266,7 @@
rm -f .tmp
echo "set objdir" `pwd` > .tmp
if [ "$(srcdir)" = "." ] ; then \
-@@ -690,7 +681,7 @@
+@@ -694,7 +689,7 @@
echo "source all" >> .tmp
rootme=`pwd`; export rootme; \
srcdir=${srcdir} ; export srcdir ; \
diff --git a/japanese/expect/files/patch-ab b/japanese/expect/files/patch-ab
index efc794f654c5..ac53296680f2 100644
--- a/japanese/expect/files/patch-ab
+++ b/japanese/expect/files/patch-ab
@@ -1,14 +1,14 @@
---- configure.in.ORIG Tue Jul 21 09:43:58 1998
-+++ configure.in Tue Jul 21 09:45:12 1998
+--- configure.in.ORIG Wed Oct 7 14:12:36 1998
++++ configure.in Wed Oct 7 14:13:44 1998
@@ -10,11 +10,14 @@
# note when updating version numbers here, also update pkgIndex.in (see
# comments in Makefile)
EXP_MAJOR_VERSION=5
--EXP_MINOR_VERSION=26
-+EXP_MINOR_VERSION_PREFIX=26
+-EXP_MINOR_VERSION=28
++EXP_MINOR_VERSION_PREFIX=28
+EXP_MINOR_VERSION_L10N=jp
+EXP_MINOR_VERSION=$EXP_MINOR_VERSION_PREFIX$EXP_MINOR_VERSION_L10N
- EXP_MICRO_VERSION=0
+ EXP_MICRO_VERSION=1
EXP_VERSION=$EXP_MAJOR_VERSION.$EXP_MINOR_VERSION
EXP_VERSION_NODOTS=$EXP_MAJOR_VERSION$EXP_MINOR_VERSION
EXP_VERSION_FULL=$EXP_VERSION.$EXP_MICRO_VERSION
@@ -16,7 +16,7 @@
# Tcl's handling of shared_lib_suffix requires this symbol exist
VERSION=$EXP_MAJOR_VERSION.$EXP_MINOR_VERSION
-@@ -1002,9 +1005,9 @@
+@@ -1003,9 +1006,9 @@
if test x"$no_tk" != x"true" ; then
# libexpectk no longer exists
# X_PROGS="expectk \$(LIBEXPECTK)"
@@ -28,7 +28,7 @@
else
X_PROGS="# no X support on this system"
AC_MSG_WARN([No X based programs will be built])
-@@ -1125,6 +1128,7 @@
+@@ -1126,6 +1129,7 @@
AC_SUBST(EXP_MINOR_VERSION)
AC_SUBST(EXP_MICRO_VERSION)
AC_SUBST(EXP_VERSION_FULL)
@@ -36,7 +36,7 @@
AC_SUBST(EXP_VERSION)
AC_SUBST(CC)
AC_SUBST(EXP_CONFIG_SHELL)
-@@ -1148,4 +1152,5 @@
+@@ -1149,4 +1153,5 @@
AC_SUBST(SETUID)
AC_SUBST(UNSHARED_RANLIB)
AC_SUBST(DEFAULT_STTY_ARGS)
diff --git a/japanese/expect/pkg-plist b/japanese/expect/pkg-plist
index 08952c639c9f..96077da37a2d 100644
--- a/japanese/expect/pkg-plist
+++ b/japanese/expect/pkg-plist
@@ -20,16 +20,16 @@ bin/unbuffer-jp
bin/weather-jp
bin/xkibitz-jp
bin/xpstat-jp
-include/expect5.26jp/Dbg.h
-include/expect5.26jp/tclRegexp.h
-include/expect5.26jp/expect.h
-include/expect5.26jp/expect_comm.h
-include/expect5.26jp/expect_tcl.h
-@dirrm include/expect5.26jp
-lib/expect5.26jp/pkgIndex.tcl
-@dirrm lib/expect5.26jp
-lib/libexpect526jp.a
-lib/libexpect526jp.so.1.2
-lib/libexpect526jp.so
+include/expect5.28jp/tclRegexp.h
+include/expect5.28jp/expect.h
+include/expect5.28jp/expect_comm.h
+include/expect5.28jp/expect_tcl.h
+include/expect5.28jp/tcldbg.h
+@dirrm include/expect5.28jp
+lib/expect5.28jp/pkgIndex.tcl
+@dirrm lib/expect5.28jp
+lib/libexpect528jp.a
+lib/libexpect528jp.so.1.2
+lib/libexpect528jp.so
@exec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -m %B
@unexec /usr/bin/env OBJFORMAT=%%PORTOBJFORMAT%% /sbin/ldconfig -R