aboutsummaryrefslogtreecommitdiff
path: root/japanese/gnomelibs
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2003-12-22 01:54:59 +0000
committerMark Linimon <linimon@FreeBSD.org>2003-12-22 01:54:59 +0000
commit94d00176f64785cc7db495e5c522d2a22963e648 (patch)
tree6c304924f6958f9979e8ec0d0f53cf3dcabbcc69 /japanese/gnomelibs
parentb3da4ab501d9fcac2cd9501a68086408f0d7a5a0 (diff)
downloadports-94d00176f64785cc7db495e5c522d2a22963e648.tar.gz
ports-94d00176f64785cc7db495e5c522d2a22963e648.zip
Mark as broken on 5.x due to gcc3.3 multiline string handling.
For whatever reason, this does not seem to affect the master port. Some terrible hackery has to be done to slave port Makefiles to conditionally mark them broken, and I have flagged the hackery apologetically. For an example errorlog, see http://bento.freebsd.org/errorlogs/i386-5-full/ja-gnomelibs-1.4.2_1.log.
Notes
Notes: svn path=/head/; revision=96395
Diffstat (limited to 'japanese/gnomelibs')
-rw-r--r--japanese/gnomelibs/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/japanese/gnomelibs/Makefile b/japanese/gnomelibs/Makefile
index 5d1a79943085..9df28b199b6e 100644
--- a/japanese/gnomelibs/Makefile
+++ b/japanese/gnomelibs/Makefile
@@ -25,4 +25,16 @@ post-install:
${TOUCH} ${PREFIX}/bin/gnome-libs-jp
${CHMOD} 755 ${PREFIX}/bin/gnome-libs-jp
+# The following hackery is only necessary so that we can mark this
+# slave port, but not the master port, as broken on 5.x. Once that
+# is fixed, everything past this point except the line '.include
+# "${MASTERDIR}/Makefile' should be removed.
+BEFOREPORTMK= yes
.include "${MASTERDIR}/Makefile"
+.undef BEFOREPORTMK
+
+.if ${OSVERSION} >= 500113
+BROKEN= "Does not compile on FreeBSD ${OSVERSION}"
+.endif
+
+.include <bsd.port.post.mk>