aboutsummaryrefslogtreecommitdiff
path: root/japanese/gskk
diff options
context:
space:
mode:
authorHajimu UMEMOTO <ume@FreeBSD.org>2005-03-07 12:28:39 +0000
committerHajimu UMEMOTO <ume@FreeBSD.org>2005-03-07 12:28:39 +0000
commit413879deb9fb57e219196ec648de34eda46c9982 (patch)
treebce011deb704e63f5c3877ce092df3af6a84887c /japanese/gskk
parent699916ef367c6d70cfcba98aab1ccd3a59f8b891 (diff)
downloadports-413879deb9fb57e219196ec648de34eda46c9982.tar.gz
ports-413879deb9fb57e219196ec648de34eda46c9982.zip
Add new port -- SKK's dictionary for Canna.
Notes
Notes: svn path=/head/; revision=130525
Diffstat (limited to 'japanese/gskk')
-rw-r--r--japanese/gskk/Makefile57
-rw-r--r--japanese/gskk/distinfo2
-rw-r--r--japanese/gskk/files/README.FreeBSD.in44
-rw-r--r--japanese/gskk/files/dics.dir.gskk2
-rw-r--r--japanese/gskk/files/pkg-message.in3
-rw-r--r--japanese/gskk/pkg-descr3
6 files changed, 111 insertions, 0 deletions
diff --git a/japanese/gskk/Makefile b/japanese/gskk/Makefile
new file mode 100644
index 000000000000..600ac7acec8c
--- /dev/null
+++ b/japanese/gskk/Makefile
@@ -0,0 +1,57 @@
+# New ports collection makefile for: gskk
+# Date created: 7 Mar 2005
+# Whom: Hajimu UMEMOTO <ume@FreeBSD.org>
+
+#
+# $FreeBSD$
+#
+
+PORTNAME= gskk
+PORTVERSION= 20041208
+CATEGORIES= japanese
+MASTER_SITES= http://www.ohnolab.org/~kimoto/
+DISTNAME= ${PORTNAME}-${PORTVERSION}.t
+EXTRACT_SUFX= .gz
+
+MAINTAINER= ume@FreeBSD.org
+COMMENT= SKK's dictionary for Canna
+
+RUN_DEPENDS= ${LOCALBASE}/sbin/cannaserver:${PORTSDIR}/japanese/Canna
+BUILD_DEPENDS= mkbindic:${PORTSDIR}/japanese/Canna
+
+NO_WRKSUBDIR= yes
+
+EXTRACT_AFTER_ARGS= > ${PORTNAME}.t
+
+PLIST_FILES= share/canna/dic/canna/dics.dir.${PORTNAME} \
+ share/canna/dic/canna/${PORTNAME}.cbd \
+ share/canna/dic/canna/${PORTNAME}.cld
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README.FreeBSD
+.endif
+
+SUB_FILES= README.FreeBSD pkg-message
+SUB_LIST+= DICDIR=${DICDIR} PORTNAME=${PORTNAME}
+
+PKGMESSAGE= ${WRKDIR}/pkg-message
+
+DICS= ${PORTNAME}.cbd ${PORTNAME}.cld
+DICSFILE= dics.dir.${PORTNAME}
+DICDIR= ${PREFIX}/share/canna/dic/canna
+
+do-build:
+ cd ${WRKDIR} && mkbindic ${PORTNAME}.t
+
+do-install:
+ cd ${WRKSRC} && ${INSTALL_DATA} ${DICS} ${DICDIR}
+ ${INSTALL_DATA} ${FILESDIR}/${DICSFILE} ${DICDIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKDIR}/README.FreeBSD ${DOCSDIR}
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/japanese/gskk/distinfo b/japanese/gskk/distinfo
new file mode 100644
index 000000000000..a35b1b5004bb
--- /dev/null
+++ b/japanese/gskk/distinfo
@@ -0,0 +1,2 @@
+MD5 (gskk-20041208.t.gz) = c7d1a20e54b862c8bf99a3eee8c8293b
+SIZE (gskk-20041208.t.gz) = 760867
diff --git a/japanese/gskk/files/README.FreeBSD.in b/japanese/gskk/files/README.FreeBSD.in
new file mode 100644
index 000000000000..51f424e8e9f8
--- /dev/null
+++ b/japanese/gskk/files/README.FreeBSD.in
@@ -0,0 +1,44 @@
+かんな辞書 FreeBSD ports インストールマニュアル
+
+このマニュアルは,かんな辞書を FreeBSD ports でインストールする場合に,
+手動で行わなければならないことを,かんな辞書のマニュアルから抜粋したものです.
+
+
+1) 辞書登録ファイルの %%DICDIR%%/dics.dir に、
+ %%DICDIR%%/dics.dir.%%PORTNAME%% の内容を追加します。
+
+# cd %%DICDIR%%
+# cp dics.dir dics.dir.orig
+# cat dics.dir.%%PORTNAME%% >> dics.dir
+
+2) cannaserver を停止,起動します。
+
+(かんなサーバ停止)
+# %%PREFIX%%/etc/rc.d/canna.sh stop
+
+(cannaserverが停止していることを確認してください。停止していなければ
+ killコマンドでプロセスを停止させてください)
+
+(かんなサーバ起動)
+# %%PREFIX%%/etc/rc.d/canna.sh start
+
+3) ユーザ権限に戻って、ホームディレクトリに存在する各ユーザの .canna の
+ (use-dictionary ...) の部分に "%%PORTNAME%%" の一行を付け足して
+ ください。抜粋するとこんな感じです。
+
+(use-dictionary
+ "iroha"
+ "%%PORTNAME%%" ← これを追加
+ "fuzokugo"
+ "hojomwd"
+ "hojoswd"
+ :bushu "bushu"
+ :user "user"
+ )
+
+4) 最後に頻度辞書を作成します。既に同名のユーザ辞書がインストールされている
+ 場合、辞書を上書きするかどうか質問されます。必ず yes を選択してください。
+
+$ mkdic -fq %%PORTNAME%%
+Personal learning file of dictionary "%%PORTNAME%%" exists. Do you overwrite it ? (y/n)
+
diff --git a/japanese/gskk/files/dics.dir.gskk b/japanese/gskk/files/dics.dir.gskk
new file mode 100644
index 000000000000..4f71104320d8
--- /dev/null
+++ b/japanese/gskk/files/dics.dir.gskk
@@ -0,0 +1,2 @@
+gskk.cbd(gskk.mwd) -gskk---
+gskk.cld(gskk.mwd) -gskk---
diff --git a/japanese/gskk/files/pkg-message.in b/japanese/gskk/files/pkg-message.in
new file mode 100644
index 000000000000..9ebf026e842b
--- /dev/null
+++ b/japanese/gskk/files/pkg-message.in
@@ -0,0 +1,3 @@
+
+You should do set up after the installation.
+See %%DOCSDIR%%/README.FreeBSD
diff --git a/japanese/gskk/pkg-descr b/japanese/gskk/pkg-descr
new file mode 100644
index 000000000000..cf5f92458d13
--- /dev/null
+++ b/japanese/gskk/pkg-descr
@@ -0,0 +1,3 @@
+SKK's dictionary for Canna.
+
+WWW: http://www.ohnolab.org/~kimoto/canna.html (Japanese)