aboutsummaryrefslogtreecommitdiff
path: root/japanese/guesswork-classic
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2005-10-11 12:55:54 +0000
committerPav Lucistnik <pav@FreeBSD.org>2005-10-11 12:55:54 +0000
commit4bc95d9771cab2161338fb9703d1d8009ef2e010 (patch)
tree78ed0f25c84f31bfa8d8140f0c6078098e2ba37a /japanese/guesswork-classic
parent20a8433d67cdfbb50df719911fd46a4be7a0e164 (diff)
downloadports-4bc95d9771cab2161338fb9703d1d8009ef2e010.tar.gz
ports-4bc95d9771cab2161338fb9703d1d8009ef2e010.zip
The guesswork classic is a lightweight framework for PHP. It allows
developers to build web applications without writing any configuration files and being forced to use fixed directory structures and file names. PR: ports/82218 Submitted by: Shinsuke Matsui <smatsui@karashi.org>
Notes
Notes: svn path=/head/; revision=144935
Diffstat (limited to 'japanese/guesswork-classic')
-rw-r--r--japanese/guesswork-classic/Makefile49
-rw-r--r--japanese/guesswork-classic/distinfo2
-rw-r--r--japanese/guesswork-classic/files/pkg-message.in4
-rw-r--r--japanese/guesswork-classic/pkg-descr6
-rw-r--r--japanese/guesswork-classic/pkg-plist42
5 files changed, 103 insertions, 0 deletions
diff --git a/japanese/guesswork-classic/Makefile b/japanese/guesswork-classic/Makefile
new file mode 100644
index 000000000000..84ce498cc53f
--- /dev/null
+++ b/japanese/guesswork-classic/Makefile
@@ -0,0 +1,49 @@
+# New ports collection makefile for: ja-guesswork-classic
+# Date created: 10 Oct 2005
+# Whom: Shinsuke Matsui (<smatsui@karashi.org>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= guesswork-classic
+PORTVERSION= 0.0.3
+CATEGORIES= japanese devel
+MASTER_SITES= http://classic.guesswork.jp/download/files/
+
+MAINTAINER= smatsui@karashi.org
+COMMENT= A PHP lightweight framework
+
+RUN_DEPENDS= ${LOCALBASE}/share/smarty/Smarty.class.php:${PORTSDIR}/www/smarty
+
+NO_BUILD= yes
+USE_PHP= yes
+WANT_PHP_WEB= yes
+
+SUB_FILES= pkg-message
+
+PORTDOCS= ChangeLog README LICENSE
+
+post-extract:
+ @${FIND} ${WRKSRC} -name '.cvsignore' -delete
+
+do-install:
+ ${MKDIR} ${DATADIR}
+.for DIR in lib test
+ ${CP} -Rp ${WRKSRC}/${DIR} ${DATADIR}
+ ${FIND} ${DATADIR} -type f | ${XARGS} ${CHMOD} ${SHAREMODE}
+.endfor
+ ${MKDIR} ${EXAMPLESDIR}
+.for DIR in examples public_html smarty
+ ${CP} -Rp ${WRKSRC}/${DIR} ${EXAMPLESDIR}
+.endfor
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/$f ${DOCSDIR}
+.endfor
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/japanese/guesswork-classic/distinfo b/japanese/guesswork-classic/distinfo
new file mode 100644
index 000000000000..70de5344979a
--- /dev/null
+++ b/japanese/guesswork-classic/distinfo
@@ -0,0 +1,2 @@
+MD5 (guesswork-classic-0.0.3.tar.gz) = ba567c9457d99f55a9b1dd310fc44bd5
+SIZE (guesswork-classic-0.0.3.tar.gz) = 15921
diff --git a/japanese/guesswork-classic/files/pkg-message.in b/japanese/guesswork-classic/files/pkg-message.in
new file mode 100644
index 000000000000..956cf4285d15
--- /dev/null
+++ b/japanese/guesswork-classic/files/pkg-message.in
@@ -0,0 +1,4 @@
+You need to adjust php's include_path to contain `%%DATADIR%%/lib'!
+For example, insert
+ include_path = ".:%%DATADIR%%/lib"
+into `%%LOCALBASE%%/etc/php.ini'.
diff --git a/japanese/guesswork-classic/pkg-descr b/japanese/guesswork-classic/pkg-descr
new file mode 100644
index 000000000000..b6256284f713
--- /dev/null
+++ b/japanese/guesswork-classic/pkg-descr
@@ -0,0 +1,6 @@
+The guesswork classic is a lightweight framework for PHP. It allows
+developers to build web applications without writing any configuration
+files and being forced to use fixed directory structures and file names.
+
+Author: OGURA Junya
+WWW: http://classic.guesswork.jp/
diff --git a/japanese/guesswork-classic/pkg-plist b/japanese/guesswork-classic/pkg-plist
new file mode 100644
index 000000000000..d6dcdc863f39
--- /dev/null
+++ b/japanese/guesswork-classic/pkg-plist
@@ -0,0 +1,42 @@
+%%EXAMPLESDIR%%/examples/mailform/MailFormValidator.class.php
+%%EXAMPLESDIR%%/public_html/mailform/mailform.css
+%%EXAMPLESDIR%%/public_html/mailform/mailform.php
+%%EXAMPLESDIR%%/smarty/templates/mailform/confirm.html
+%%EXAMPLESDIR%%/smarty/templates/mailform/input.html
+%%EXAMPLESDIR%%/smarty/templates/mailform/result.html
+%%EXAMPLESDIR%%/smarty/templates_c/DUMMY
+%%DATADIR%%/lib/Guesswork/AbstractView.php
+%%DATADIR%%/lib/Guesswork/Controller.php
+%%DATADIR%%/lib/Guesswork/DefaultView.php
+%%DATADIR%%/lib/Guesswork/ExpressionUtil.php
+%%DATADIR%%/lib/Guesswork/Logger.php
+%%DATADIR%%/lib/Guesswork/plugins/function.error.php
+%%DATADIR%%/lib/Guesswork/plugins/function.hidden_field.php
+%%DATADIR%%/lib/Guesswork/plugins/function.link_to.php
+%%DATADIR%%/lib/Guesswork/plugins/function.text_field.php
+%%DATADIR%%/lib/Guesswork/plugins/function.url_for.php
+%%DATADIR%%/lib/Guesswork/Request.php
+%%DATADIR%%/lib/Guesswork/SmartyView.php
+%%DATADIR%%/lib/Guesswork/templates/eval.tpl
+%%DATADIR%%/lib/Guesswork/UploadFile.php
+%%DATADIR%%/lib/Guesswork/Utils.php
+%%DATADIR%%/lib/Guesswork/Validator.php
+%%DATADIR%%/lib/Guesswork.php
+%%DATADIR%%/test/AllTests.php
+%%DATADIR%%/test/ControllerTest.php
+%%DATADIR%%/test/ValidatorTest.php
+@dirrm %%EXAMPLESDIR%%/examples/mailform
+@dirrm %%EXAMPLESDIR%%/examples
+@dirrm %%EXAMPLESDIR%%/public_html/mailform
+@dirrm %%EXAMPLESDIR%%/public_html
+@dirrm %%EXAMPLESDIR%%/smarty/templates/mailform
+@dirrm %%EXAMPLESDIR%%/smarty/templates
+@dirrm %%EXAMPLESDIR%%/smarty/templates_c
+@dirrm %%EXAMPLESDIR%%/smarty
+@dirrm %%DATADIR%%/lib/Guesswork/plugins
+@dirrm %%DATADIR%%/lib/Guesswork/templates
+@dirrm %%DATADIR%%/lib/Guesswork
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/test
+@dirrm %%EXAMPLESDIR%%
+@dirrm %%DATADIR%%