aboutsummaryrefslogtreecommitdiff
path: root/japanese/kinput2
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-06-27 12:49:27 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-06-27 12:49:27 +0000
commitaab778826208d2e63c1d9f2bfcea9b3252e355f2 (patch)
tree1f173eaf4304b068142038a0a4071acb137cc9e8 /japanese/kinput2
parentbeca8087f8b128efb8e33c66bc9b5724205de351 (diff)
downloadports-aab778826208d2e63c1d9f2bfcea9b3252e355f2.tar.gz
ports-aab778826208d2e63c1d9f2bfcea9b3252e355f2.zip
Input server of Japanese text (Wnn4)
Submitted by: Satoshi Taoka <taoka@infonets.hiroshima-u.ac.jp> PR: ports/6028 (part of)
Notes
Notes: svn path=/head/; revision=11559
Diffstat (limited to 'japanese/kinput2')
-rw-r--r--japanese/kinput2/Makefile68
-rw-r--r--japanese/kinput2/distinfo1
-rw-r--r--japanese/kinput2/pkg-comment1
-rw-r--r--japanese/kinput2/pkg-descr16
-rw-r--r--japanese/kinput2/pkg-message7
-rw-r--r--japanese/kinput2/pkg-plist17
6 files changed, 110 insertions, 0 deletions
diff --git a/japanese/kinput2/Makefile b/japanese/kinput2/Makefile
new file mode 100644
index 000000000000..78c31fdabfa5
--- /dev/null
+++ b/japanese/kinput2/Makefile
@@ -0,0 +1,68 @@
+# New ports collection makefile for: kinput2-wnn4
+# Version required: 2.0p4
+# Date created: 19 Dec 1997
+# Whom: Satoshi TAOKA <taoka@infonets.hiroshima-u.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= kinput2-v2-fix4
+PKGNAME?= ja-kinput2-wnn4-2.0.4
+CATEGORIES= japanese x11
+MASTER_SITES= ftp://ftp.sra.co.jp/pub/x11/kinput2/
+
+MAINTAINER= taoka@infonets.hiroshima-u.ac.jp
+
+LIB_DEPENDS= ${LIB_INPUT_METHOD}
+BUILD_DEPENDS= ${BUILD_INPUT_METHOD}
+
+PATCHDIR= ${.CURDIR}/../kinput2-wnn4/patches
+FILESDIR= ${.CURDIR}/../kinput2-wnn4/files
+NO_WRKSUBDIR= yes
+USE_IMAKE= yes
+
+.if !defined(CANNA) && !defined(SJ3) && !defined(WNN4) && !defined(WNN6)
+# For this port
+WNN4= yes
+.endif
+#
+# Specifying a velue INPUT_METHOD, and seting values BUILD_DEPENDS,
+# LIB_DEPENDS, etc.
+.if defined(CANNA)
+INPUT_METHOD+= canna
+LIB_INPUT_METHOD+= canna\\.1\\.:${PORTSDIR}/japanese/Canna
+KINPUT2_DEF+= -DUseCanna
+.endif
+.if defined(SJ3)
+INPUT_METHOD+= sj3
+BUILD_INPUT_METHOD+= sj3serv:${PORTSDIR}/japanese/sj3
+KINPUT2_DEF+= -DUseSj3
+.endif
+.if defined(WNN4)
+INPUT_METHOD+= wnn4
+BUILD_INPUT_METHOD+= ${LOCALBASE}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
+KINPUT2_DEF+= -DUseWnn
+.elif defined(WNN6)
+INPUT_METHOD+= wnn6
+BUILD_INPUT_METHOD+= ${LOCALBASE}/bin/Wnn4/jserver:${PORTSDIR}/japanese/Wnn
+KINPUT2_DEF+= -DUseWnn -DWnnLibDir=${LOCALBASE}/lib/wnn6
+.endif
+#
+# Make a value of INPUT_METHOD
+.if defined(INPUT_METHOD)
+INPUT_METHOD!= echo ${INPUT_METHOD} | sed -e 's/^/-/' -e 's/ /+/g'
+.endif
+#
+# Redefine $(IMAKE_CMD) with $(PORT_IMAKE_DEFINES) in ${WRKSRC}/Kinput2.conf
+MAKE_ENV+= PORT_IMAKE_DEFINES='${KINPUT2_DEF}'
+
+do-configure:
+ cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${XMKMF}
+
+post-install:
+# For Wnn4 or Wnn6
+ @if [ -e ${PKGDIR}/MESSAGE ]; then \
+ ${CAT} ${PKGDIR}/MESSAGE; \
+ fi
+
+.include <bsd.port.mk>
diff --git a/japanese/kinput2/distinfo b/japanese/kinput2/distinfo
new file mode 100644
index 000000000000..46d611bc72a0
--- /dev/null
+++ b/japanese/kinput2/distinfo
@@ -0,0 +1 @@
+MD5 (kinput2-v2-fix4.tar.gz) = cbee9108f6915b2d9609c380b3ca3720
diff --git a/japanese/kinput2/pkg-comment b/japanese/kinput2/pkg-comment
new file mode 100644
index 000000000000..9c81bc542076
--- /dev/null
+++ b/japanese/kinput2/pkg-comment
@@ -0,0 +1 @@
+Input server of Japanese text (Wnn4)
diff --git a/japanese/kinput2/pkg-descr b/japanese/kinput2/pkg-descr
new file mode 100644
index 000000000000..fcd16ff362b8
--- /dev/null
+++ b/japanese/kinput2/pkg-descr
@@ -0,0 +1,16 @@
+Kinput2 is an input server for X11 applications that want Japanese
+text input.
+
+A client that wants kana-kanji conversion service for Japanese text
+sends a request to kinput2. Kinput2 receives the request, does
+kana-kanji conversion, and sends the converted text back to the
+client.
+
+The port supports Wnn4. Egg key binding is avairable,
+if you run
+
+kinput2 -ccdef ccdef.kinput2.egg
+
+-- S. Taoka
+<taoka@infonets.hiroshima-u.ac.jp>
+
diff --git a/japanese/kinput2/pkg-message b/japanese/kinput2/pkg-message
new file mode 100644
index 000000000000..97668d99055e
--- /dev/null
+++ b/japanese/kinput2/pkg-message
@@ -0,0 +1,7 @@
+############################################################
+If you want to use Egg key binding on kinput2, then
+you should run
+
+kinput2 -ccdef ccdef.kinput2.egg
+
+############################################################"
diff --git a/japanese/kinput2/pkg-plist b/japanese/kinput2/pkg-plist
new file mode 100644
index 000000000000..6443168f92e5
--- /dev/null
+++ b/japanese/kinput2/pkg-plist
@@ -0,0 +1,17 @@
+bin/kinput2
+lib/X11/app-defaults/Kinput2
+lib/X11/ccdef/ccdef.kinput2
+lib/X11/ccdef/rule.eggfunc
+lib/X11/ccdef/rule.func
+lib/X11/ccdef/rule.greek
+lib/X11/ccdef/rule.kana
+lib/X11/ccdef/rule.kana2
+lib/X11/ccdef/rule.roma
+lib/X11/ccdef/rule.wnnroma
+lib/X11/ccdef/rule.zascii
+lib/X11/ccdef/ccdef.kinput2.egg
+lib/X11/ccdef/rule.hiragana.egg
+lib/X11/ccdef/rule.katakana.egg
+lib/X11/ccdef/rule.kigou.egg
+@dirrm lib/X11/ccdef
+man/man1/kinput2.1.gz