aboutsummaryrefslogtreecommitdiff
path: root/japanese/kterm16c/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-04-11 14:15:53 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-04-11 14:15:53 +0000
commitedcf8b3594b5df6440713253552b675fb0234474 (patch)
treecb86ff29b6c34e6d077c56ce53ca461f9623f343 /japanese/kterm16c/Makefile
parent7b4b0c4f33915abb1f15e37f30ce951ba7aa94e6 (diff)
downloadports-edcf8b3594b5df6440713253552b675fb0234474.tar.gz
ports-edcf8b3594b5df6440713253552b675fb0234474.zip
Update with the new PORT{NAME,VERSION}/PKGNAME{PRE,SUF}FIX variables.
Now try to use those variables everywhere around DIST* and PATCH* definitions as far as possible, for ease of the future updates and the neatness. Okay, 60% of `japanese' ports have been done. :)
Notes
Notes: svn path=/head/; revision=27449
Diffstat (limited to 'japanese/kterm16c/Makefile')
-rw-r--r--japanese/kterm16c/Makefile16
1 files changed, 9 insertions, 7 deletions
diff --git a/japanese/kterm16c/Makefile b/japanese/kterm16c/Makefile
index b31bf9393cce..cbc65266bcd9 100644
--- a/japanese/kterm16c/Makefile
+++ b/japanese/kterm16c/Makefile
@@ -1,19 +1,19 @@
# New ports collection makefile for: kterm of 16 colors
-# Version required: 6.2
# Date created: 18 November 1994
# Whom: asami
#
# $FreeBSD$
#
-DISTNAME= kterm-6.2.0
-PKGNAME= ja-kterm16c-6.2.0
+PORTNAME= kterm16c
+PORTVERSION= 6.2.0
CATEGORIES= japanese x11
MASTER_SITES= ${MASTER_SITE_XCONTRIB} \
ftp://ftp.interface-business.de/pub/outgoing/ \
ftp://ftp.cs.bris.ac.uk/pub/users/hedley/
-DISTFILES= kterm-6.2.0.tar.gz pcemu1.01alpha.tar.gz
-EXTRACT_ONLY= kterm-6.2.0.tar.gz
+DISTNAME= kterm-${PORTVERSION}
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ pcemu1.01alpha.tar.gz
MASTER_SITE_SUBDIR= applications
@@ -22,10 +22,12 @@ MAINTAINER= kiri@pis.toba-cmt.ac.jp
BUILD_DEPENDS= nkf:${PORTSDIR}/japanese/nkf
LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+DIST_SUBDIR= kterm
PATCH_SITES= ftp://ftp.sra.co.jp/pub/x11/kterm/ \
http://karin.ip.titech.ac.jp/~takagi/kterm/
-PATCHFILES= kterm-6.2.0.NFS-xauth.patch \
- kterm-6.2.0-wpr1.patch.gz
+PATCHFILES= ${DISTNAME}.NFS-xauth.patch \
+ ${DISTNAME}-wpr1.patch.gz
PATCH_DIST_STRIP= -p1
USE_IMAKE= yes