aboutsummaryrefslogtreecommitdiff
path: root/japanese/latex2html/Makefile
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-02-12 02:27:50 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-02-12 02:27:50 +0000
commitf974509c30e31781f9d341921539f37926fd0242 (patch)
treeaaac0dbe6d5b372daf9c696011a038012732b397 /japanese/latex2html/Makefile
parent27850e59e0e55c8d82d327dd69f98fde78e8a78f (diff)
downloadports-f974509c30e31781f9d341921539f37926fd0242.tar.gz
ports-f974509c30e31781f9d341921539f37926fd0242.zip
Update to 2002-2-1+jp2.0.
PR: 47812 Submitted by: Sadahiro SUGIMOTO <ixtl@utmc.or.jp>
Notes
Notes: svn path=/head/; revision=75333
Diffstat (limited to 'japanese/latex2html/Makefile')
-rw-r--r--japanese/latex2html/Makefile66
1 files changed, 23 insertions, 43 deletions
diff --git a/japanese/latex2html/Makefile b/japanese/latex2html/Makefile
index 02292b37b865..94d08eb11731 100644
--- a/japanese/latex2html/Makefile
+++ b/japanese/latex2html/Makefile
@@ -4,17 +4,16 @@
#
# $FreeBSD$
#
-# Default image format is PNG.
-# If you prefer GIF to PNG, define WITH_GIF (`make -DWITH_GIF`).
PORTNAME= latex2html
PORTVERSION= ${VERSION}j${JP_VERSION}
CATEGORIES= japanese textproc
-MASTER_SITES= http://www.topstudio.co.jp/~kmuto/debian/private/dists/stable/contrib/source/
-DISTNAME= jlatex2html_${VERSION}+${JP_VERSION}.orig
+MASTER_SITES= ${MASTER_SITE_TEX_CTAN}
+MASTER_SITE_SUBDIR= support/${PORTNAME}
+DISTNAME= ${PORTNAME}-${VERSION:S/./-/g}
-PATCH_SITES= http://www.topstudio.co.jp/~kmuto/software/latex2html/patch/99-1/
-PATCHFILES= jlatex2html-${VERSION}+${JP_VERSION}.dif.gz
+PATCH_SITES= http://takeno.iee.niit.ac.jp/~shige/TeX/latex2html/data/
+PATCHFILES= l2h-2002-2-1+jp${JP_VERSION}.patch.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= ixtl@utmc.or.jp
@@ -22,47 +21,28 @@ MAINTAINER= ixtl@utmc.or.jp
RUN_DEPENDS= platex:${PORTSDIR}/japanese/ptex-euc \
dvips:${PORTSDIR}/japanese/dvipsk-vflib \
gs:${PORTSDIR}/japanese/ghostscript-gnu-jpnfont \
- anytopnm:${PORTSDIR}/graphics/netpbm \
- nkf:${PORTSDIR}/japanese/nkf
+ anytopnm:${PORTSDIR}/graphics/netpbm
-VERSION= 99.1
-JP_VERSION= 3.01
+VERSION= 2002.2.1
+JP_VERSION= 2.0
-WRKSRC= ${WRKDIR}/latex2html
USE_PERL5= yes
-NO_BUILD= yes
-
-L2HDIR= ${PREFIX}/share/latex2html
-
-post-patch:
-.for f in configure-pstoimg install-test latex2html makemap \
- ps2img-n pstoimg pstoimg_nopipes texexpand
- ${PERL} -e "s:^\#!/usr/local/bin/perl:\#!${PERL}:" \
- -pi ${WRKSRC}/$f
-.endfor
-
-do-install:
- ${MKDIR} ${L2HDIR}
-.for dir in IndicTeX-HTML XyMTeX-HTML cweb2html docs/changebar \
- docs/hthtml docs/psfiles docs example foilhtml icon-dos icons.gif \
- icons.png makeseg styles tests texinputs versions
- ${CP} -R ${WRKSRC}/${dir} ${L2HDIR}
-.endfor
-.for prog in Override.pm configure-pstoimg install-test latex2html \
- makemap ps2img-n pstoimg pstoimg_nopipes texexpand
- ${INSTALL_SCRIPT} ${WRKSRC}/${prog} ${L2HDIR}
-.endfor
-.for file in .dvipsrc Changes FAQ MANIFEST README README.dvips \
- README.patch TODO dot.latex2html-init latex2html.config readme.hthtml
- ${INSTALL_DATA} ${WRKSRC}/${file} ${L2HDIR}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --shlibdir=${DATADIR} \
+ --disable-gif \
+ --with-perl=${PERL} \
+ --with-texpath=${PREFIX}/share/texmf/tex/latex/html
+
+DOC_FILES= FAQ INSTALL LICENSE README README.patch-2002jp \
+ README.patch-99.1jp
+
+post-install:
+ (cd ${WRKSRC}; csh mkwrapper ${PREFIX})
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in ${DOC_FILES}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
.endfor
- ${MKDIR} ${PREFIX}/share/texmf/tex/latex/latex2html
- ${INSTALL_DATA} ${WRKSRC}/texinputs/* ${PREFIX}/share/texmf/tex/latex/latex2html
-.ifdef WITH_GIF
- cd ${L2HDIR}; ${CAT} ${FILESDIR}/answer-gif | ${PERL} install-test
-.else
- cd ${L2HDIR}; ${CAT} ${FILESDIR}/answer-png | ${PERL} install-test
.endif
- ${INSTALL_SCRIPT} ${L2HDIR}/latex2html ${PREFIX}/bin
.include <bsd.port.mk>