aboutsummaryrefslogtreecommitdiff
path: root/japanese/lynx
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-08-10 16:03:26 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-08-10 16:03:26 +0000
commit0b8296580bae3705c91c35d10839a7fd7b1c5494 (patch)
tree467d434dca41a7e664d719b8514b621e4e3f0405 /japanese/lynx
parent0555335f0436f158039540a02fae36ada2fb9659 (diff)
downloadports-0b8296580bae3705c91c35d10839a7fd7b1c5494.tar.gz
ports-0b8296580bae3705c91c35d10839a7fd7b1c5494.zip
A terminal-based World-Wide Web Client with multi-byte modifications.
PR: ports/6413 Submitted by: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
Notes
Notes: svn path=/head/; revision=12434
Diffstat (limited to 'japanese/lynx')
-rw-r--r--japanese/lynx/Makefile26
-rw-r--r--japanese/lynx/distinfo1
-rw-r--r--japanese/lynx/files/patch-aa19
-rw-r--r--japanese/lynx/files/patch-ad55
-rw-r--r--japanese/lynx/pkg-comment1
-rw-r--r--japanese/lynx/pkg-descr9
-rw-r--r--japanese/lynx/pkg-plist47
7 files changed, 158 insertions, 0 deletions
diff --git a/japanese/lynx/Makefile b/japanese/lynx/Makefile
new file mode 100644
index 000000000000..c0bdd12f8421
--- /dev/null
+++ b/japanese/lynx/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: ja-lynx
+# Version required: 2.8rel.3
+# Date created: 25 April 1998
+# Whom: Shigeyuki FUKUSHIMA <shige@kuis.kyoto-u.ac.jp>
+#
+# $Id$
+#
+
+DISTNAME= lynx2.8rel.3
+PKGNAME= ja-lynx-2.8.0.3
+CATEGORIES= japanese www
+MASTER_SITES= ftp://sol.slcc.edu/pub/lynx/current/
+
+MAINTAINER= shige@kuis.kyoto-u.ac.jp
+
+WRKSRC= ${WRKDIR}/lynx2-8
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --with-screen=ncurses --with-zlib --libdir="${PREFIX}/etc"
+MAKEFILE= makefile
+INSTALL_TARGET= install install-help
+MAN1= lynx.1
+
+post-install:
+ chown -R ${SHAREOWN}:${SHAREGRP} ${PREFIX}/lib/lynx_help
+
+.include <bsd.port.mk>
diff --git a/japanese/lynx/distinfo b/japanese/lynx/distinfo
new file mode 100644
index 000000000000..ff1b7d9d94e4
--- /dev/null
+++ b/japanese/lynx/distinfo
@@ -0,0 +1 @@
+MD5 (lynx2.8rel.3.tar.gz) = bedd556e0c1048d8754e258eca5450a6
diff --git a/japanese/lynx/files/patch-aa b/japanese/lynx/files/patch-aa
new file mode 100644
index 000000000000..5a9ece363aa4
--- /dev/null
+++ b/japanese/lynx/files/patch-aa
@@ -0,0 +1,19 @@
+--- makefile.in.orig Fri Jul 31 18:34:41 1998
++++ makefile.in Mon Aug 10 02:12:53 1998
+@@ -37,7 +37,7 @@
+ libdir= @libdir@
+
+ ## Where you want the help-files installed
+-helpdir= @libdir@/lynx_help
++helpdir= $(prefix)/lib/lynx_help
+
+ ##set the relative location of the WWW library Implementation directory,
+ ##from this directory
+@@ -257,6 +257,7 @@
+ (cd $(srcdir)/lynx_help && tar cf - . ) | ( cd $(helpdir) && tar xf - )
+ (cd $(srcdir) && tar cf - C[HO]* PROBLEMS README samples test ) | \
+ ( cd $(helpdir) && tar xf - )
++ cp $(srcdir)/lynx.cfg $(helpdir)/samples/lynx.cfg
+ -rm -f $(libdir)/lynx.tmp
+ sh -c 'if test -f $(libdir)/lynx.cfg ; then \
+ mv $(libdir)/lynx.cfg $(libdir)/lynx.tmp ; \
diff --git a/japanese/lynx/files/patch-ad b/japanese/lynx/files/patch-ad
new file mode 100644
index 000000000000..b61e1b1ec678
--- /dev/null
+++ b/japanese/lynx/files/patch-ad
@@ -0,0 +1,55 @@
+--- src/LYHistory.c.orig Thu Apr 23 21:35:21 1998
++++ src/LYHistory.c Sun Apr 26 00:13:01 1998
+@@ -22,6 +22,10 @@
+
+ #include "LYexit.h"
+ #include "LYLeaks.h"
++
++#include "HTCJK.h"
++extern HTCJKlang HTCJK;
++extern HTkcode kanji_code;
+
+ #define FREE(x) if (x) {free(x); x = NULL;}
+
+@@ -433,6 +437,20 @@
+ } else {
+ StrAllocCopy(Title, "(no title)");
+ }
++ if (HTCJK == JAPANESE) {
++ char *tmp;
++
++ if ((tmp = (char *)calloc(strlen(Title)*2, sizeof(char *))) == NULL)
++ outofmem(__FILE__, "showhistory");
++ *tmp = '\0';
++ if (kanji_code == EUC) {
++ TO_EUC(Title, tmp);
++ } else if (kanji_code == SJIS) {
++ TO_SJIS(Title, tmp);
++ }
++ if (*tmp) StrAllocCopy(Title, tmp);
++ FREE(tmp);
++ }
+ fprintf(fp0,
+ "%s<em>%d</em>. <tab id=t%d><a href=\"LYNXHIST:%d\">%s</a>\n",
+ (x > 99 ? "" : x < 10 ? " " : " "),
+@@ -601,6 +619,20 @@
+ LYEntify(&Title, TRUE);
+ } else {
+ StrAllocCopy(Title , "(no title)");
++ }
++ if (HTCJK == JAPANESE) {
++ char *tmp;
++
++ if ((tmp = (char *)calloc(strlen(Title)*2, sizeof(char *))) == NULL)
++ outofmem(__FILE__, "LYShowVisitedLinks");
++ *tmp = '\0';
++ if (kanji_code == EUC) {
++ TO_EUC(Title, tmp);
++ } else if (kanji_code == SJIS) {
++ TO_SJIS(Title, tmp);
++ }
++ if (*tmp) StrAllocCopy(Title, tmp);
++ FREE(tmp);
+ }
+ if (vl->address != NULL && *vl->address != '\0') {
+ StrAllocCopy(Address, vl->address);
diff --git a/japanese/lynx/pkg-comment b/japanese/lynx/pkg-comment
new file mode 100644
index 000000000000..45e92f29f12e
--- /dev/null
+++ b/japanese/lynx/pkg-comment
@@ -0,0 +1 @@
+A terminal-based World-Wide Web Client with multi-byte modifications.
diff --git a/japanese/lynx/pkg-descr b/japanese/lynx/pkg-descr
new file mode 100644
index 000000000000..82611de18cad
--- /dev/null
+++ b/japanese/lynx/pkg-descr
@@ -0,0 +1,9 @@
+lynx is a program which allows a user to access World-Wide Web servers
+and other information servers. It uses only ascii representation so
+that it can be used from ascii-terminals and dialin-lines.
+
+And this package is modified for multi-byte.
+Modified point is following:
+ . History and VisitedLinks
+ . Editing to FORM TEXTFIELD and TEXTAREA
+ . Bookmark
diff --git a/japanese/lynx/pkg-plist b/japanese/lynx/pkg-plist
new file mode 100644
index 000000000000..ded18e8ce06f
--- /dev/null
+++ b/japanese/lynx/pkg-plist
@@ -0,0 +1,47 @@
+bin/lynx
+etc/lynx.cfg
+man/man1/lynx.1.gz
+lib/lynx_help/about_lynx.html
+lib/lynx_help/lynx_url_support.html
+lib/lynx_help/Lynx_users_guide.html
+lib/lynx_help/lynx_help_main.html
+lib/lynx_help/keystrokes/cookie_help.html
+lib/lynx_help/keystrokes/visited_help.html
+lib/lynx_help/keystrokes/edit_help.html
+lib/lynx_help/keystrokes/dired_help.html
+lib/lynx_help/keystrokes/xterm_help.html
+lib/lynx_help/keystrokes/scrolling_help.html
+lib/lynx_help/keystrokes/print_help.html
+lib/lynx_help/keystrokes/other_help.html
+lib/lynx_help/keystrokes/option_help.html
+lib/lynx_help/keystrokes/movement_help.html
+lib/lynx_help/keystrokes/history_help.html
+lib/lynx_help/keystrokes/gopher_types_help.html
+lib/lynx_help/keystrokes/bookmark_help.html
+lib/lynx_help/keystrokes/keystroke_help.html
+lib/lynx_help/keystrokes/follow_help.html
+@dirrm lib/lynx_help/keystrokes
+lib/lynx_help/lynx-dev.html
+lib/lynx_help/COPYHEADER
+lib/lynx_help/COPYING
+lib/lynx_help/PROBLEMS
+lib/lynx_help/README
+lib/lynx_help/samples/jumpsVMS.html
+lib/lynx_help/samples/jumpsUnix.html
+lib/lynx_help/samples/mime.types
+lib/lynx_help/samples/lynx.com
+lib/lynx_help/samples/mailcap
+lib/lynx_help/samples/lynx.cfg
+lib/lynx_help/samples/lynx.lss
+@dirrm lib/lynx_help/samples
+lib/lynx_help/test/tabtest.html
+lib/lynx_help/test/iso8859-1.html
+lib/lynx_help/test/TestComment.html
+lib/lynx_help/test/ISO_LATIN1_test.html
+lib/lynx_help/test/README.txt
+lib/lynx_help/test/iso88592.html
+lib/lynx_help/test/ALT88592.html
+lib/lynx_help/test/sgml.html
+lib/lynx_help/test/unicode.html
+@dirrm lib/lynx_help/test
+@dirrm lib/lynx_help