aboutsummaryrefslogtreecommitdiff
path: root/japanese/mimekit
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-05-07 23:40:59 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-05-07 23:40:59 +0000
commit1294f54fbb0f66870eed0f5eb64754b652b9deec (patch)
treeb7a9e96d75316fdf8409e161248b891fcf306887 /japanese/mimekit
parent20be0d2f577411a8538aaf35814fde48c67d6940 (diff)
downloadports-1294f54fbb0f66870eed0f5eb64754b652b9deec.tar.gz
ports-1294f54fbb0f66870eed0f5eb64754b652b9deec.zip
Upgrade, 1.1 -> 1.6.
Notes
Notes: svn path=/head/; revision=6432
Diffstat (limited to 'japanese/mimekit')
-rw-r--r--japanese/mimekit/Makefile17
-rw-r--r--japanese/mimekit/distinfo2
-rw-r--r--japanese/mimekit/files/patch-aa47
3 files changed, 36 insertions, 30 deletions
diff --git a/japanese/mimekit/Makefile b/japanese/mimekit/Makefile
index 00c3e9059e5c..9a2bc153fab3 100644
--- a/japanese/mimekit/Makefile
+++ b/japanese/mimekit/Makefile
@@ -1,19 +1,24 @@
# New ports collection makefile for: mimekit
-# Version required: 1.1
+# Version required: 1.6
# Date created: 9 April 1996
# Whom: Masafumi NAKANE <max@FreeBSD.ORG>
#
-# $Id: Makefile,v 1.3 1996/09/18 12:36:49 max Exp $
+# $Id: Makefile,v 1.4 1996/11/11 10:12:26 max Exp $
#
-DISTNAME= mimekit1.1
-PKGNAME= jp-mimekit-1.1
-CATEGORIES= japanese mail
+DISTNAME= mimekit1.6
+PKGNAME= jp-mimekit-1.6
+CATEGORIES= japanese devel mail
MASTER_SITES= ftp://etlport.etl.go.jp/pub/ccipr/DeleGate/ \
ftp://ftp.iij.ad.jp/pub/mail/mime/
MAINTAINER= max@FreeBSD.ORG
-NO_WRKSUBDIR= yes
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/mimekit
+ ${INSTALL_DATA} ${WRKSRC}/README.LIB ${PREFIX}/share/doc/mimekit
+ ${INSTALL_DATA} ${WRKSRC}/README.PGP ${PREFIX}/share/doc/mimekit
+.endif
.include <bsd.port.mk>
diff --git a/japanese/mimekit/distinfo b/japanese/mimekit/distinfo
index 3b66da48a1fc..9d82cf4d8c16 100644
--- a/japanese/mimekit/distinfo
+++ b/japanese/mimekit/distinfo
@@ -1 +1 @@
-MD5 (mimekit1.1.tar.gz) = a0e945e65f9d2108c7e86d212dafc2bf
+MD5 (mimekit1.6.tar.gz) = 1f3a560a56d4c63a137dfce9e014533f
diff --git a/japanese/mimekit/files/patch-aa b/japanese/mimekit/files/patch-aa
index 4173fedb8244..40741675d24c 100644
--- a/japanese/mimekit/files/patch-aa
+++ b/japanese/mimekit/files/patch-aa
@@ -1,33 +1,34 @@
---- ./Makefile.org Fri Dec 1 23:55:07 1995
-+++ ./Makefile Fri Apr 26 01:15:07 1996
-@@ -12,7 +12,7 @@
+--- Makefile.orig Mon Feb 17 03:41:03 1997
++++ Makefile Thu May 8 08:30:17 1997
+@@ -15,7 +15,7 @@
+
+ LIBFILE = libmimekit.a
+
+-CFLAGS = -O
++CFLAGS += -O
+ TARGET = all
+ target: $(TARGET)
+ libx: Makefile.go
+@@ -51,7 +51,8 @@
+
MMDIR = ../../../src
MMSDIR = ../
- DGDIR = ../src
-INSTDIR = /usr/local/lib
++PREFIX ?= /usr/local
+INSTDIR = ${PREFIX}/lib
LOCALFILES = README \
- README.jp \
-@@ -52,7 +52,7 @@
- ALL = toMime fromMime enMime deMime test.out bench
-
- CC = cc
--CFLAGS = -O
-+CFLAGS += -O
- RM = rm -f
- RANLIB = `./mkranlib`
- TAR = tar
-@@ -98,9 +98,9 @@
- enMime deMime bench.o test.out
+ README.LIB \
+@@ -147,9 +148,9 @@
+ enMime deMime bench.o test.out sample.out
- install: fromMime toMime $(LIBMKIT)
+ install: fromMime toMime $(LIBFILE)
- install -o bin -g bin -m 755 fromMime $(INSTDIR)
- install -o bin -g bin -m 755 toMime $(INSTDIR)
-- install -o root -g staff -m 644 $(LIBMKIT) $(INSTDIR)
-+ install -cs -o bin -g bin -m 755 fromMime $(INSTDIR)
-+ install -cs -o bin -g bin -m 755 toMime $(INSTDIR)
-+ install -o bin -g bin -m 644 $(LIBMKIT) $(INSTDIR)
- $(RANLIB) $(INSTDIR)/$(LIBMKIT)
+- install -o root -g staff -m 644 $(LIBFILE) $(INSTDIR)
++ install -s -c -o bin -g bin -m 755 fromMime $(INSTDIR)
++ install -s -c -o bin -g bin -m 755 toMime $(INSTDIR)
++ install -c -o bin -g bin -m 644 $(LIBFILE) $(INSTDIR)
+ -$(RANLIB) $(INSTDIR)/$(LIBFILE)
- config.h:; ln -s $(MMDIR)/config.h .
+ config.h:; $(LKFILE) $(MMDIR)/config.h .