aboutsummaryrefslogtreecommitdiff
path: root/japanese/mule-wnn7
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1994-11-22 23:59:14 +0000
committerSatoshi Asami <asami@FreeBSD.org>1994-11-22 23:59:14 +0000
commitda9473c95cb16af93ba474629ae539238e04f6f5 (patch)
tree166244e36e111e10945fdd10903ab7e9647e61b9 /japanese/mule-wnn7
parentee16c5319402ae94b29b47cf038ed66e822aedde (diff)
downloadports-da9473c95cb16af93ba474629ae539238e04f6f5.tar.gz
ports-da9473c95cb16af93ba474629ae539238e04f6f5.zip
mule, multilingual extension to emacs (based on 19.27)
Notes
Notes: svn path=/head/; revision=467
Diffstat (limited to 'japanese/mule-wnn7')
-rw-r--r--japanese/mule-wnn7/Makefile45
-rw-r--r--japanese/mule-wnn7/pkg-comment1
-rw-r--r--japanese/mule-wnn7/pkg-descr19
3 files changed, 65 insertions, 0 deletions
diff --git a/japanese/mule-wnn7/Makefile b/japanese/mule-wnn7/Makefile
new file mode 100644
index 000000000000..613504736343
--- /dev/null
+++ b/japanese/mule-wnn7/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: mule
+# Version required: 2.1
+# Date created: 22 November 1994
+# Whom: Satoshi Asami (asami)
+#
+# $Id: $
+#
+
+DISTNAME= mule-2.1
+DISTFILES= emacs-19.27.tar.gz
+MASTER_SITES= ftp://prep.ai.mit.edu/pub/gnu/
+USE_GMAKE= yes
+HAS_CONFIGURE= yes
+CONFIGURE_ARGS= i386--freebsd --prefix=${PREFIX} --with-x-toolkit \
+ --wnn --wnn-libraries=/usr/X11R6/lib \
+ --wnn-includes=/usr/X11R6/include/wnn --terminal-face
+WRKSRC= ${WRKDIR}/emacs-19.27
+PATCHFILES= diff-19.27-2.1.gz
+PATCHSITE= sh.wide.ad.jp:/JAPAN/mule/
+DEPENDS= ${PORTSDIR}/utils/Wnn
+
+pre-fetch:
+ @if [ ! -d ${DISTDIR} ]; then mkdir -p ${DISTDIR}; fi
+ @for file in ${PATCHFILES}; do \
+ if [ ! -f ${DISTDIR}/$$file ]; then \
+ echo ">> Fetching patch $$file from remote site..."; \
+ ${NCFTP} ${NCFTPFLAGS} ${PATCHSITE}$$file \
+ && mv $$file ${DISTDIR}; \
+ fi \
+ done
+
+pre-patch:
+ /bin/rm -f ${WRKSRC}/src/unexsunos4.c ${WRKSRC}/src/s/freebsd.h
+# I took these two files from emacs-19.28 and added -lcrypt
+ cp ${FILESDIR}/unexsunos4.c ${WRKSRC}/src
+ cp ${FILESDIR}/freebsd.h ${WRKSRC}/src/s
+ @echo "===> Applying emacs -> mule patch"
+ @for file in ${PATCHFILES}; do \
+ gzip -c -d ${DISTDIR}/$$file | patch -d ${WRKSRC} -p1 -s; \
+ done
+
+pre-build:
+ find ${WRKSRC} -name \*.orig -exec /bin/rm -f \{} \;
+
+.include <bsd.port.mk>
diff --git a/japanese/mule-wnn7/pkg-comment b/japanese/mule-wnn7/pkg-comment
new file mode 100644
index 000000000000..a5e877d4bcae
--- /dev/null
+++ b/japanese/mule-wnn7/pkg-comment
@@ -0,0 +1 @@
+mule-2.1, a multilingual emacs
diff --git a/japanese/mule-wnn7/pkg-descr b/japanese/mule-wnn7/pkg-descr
new file mode 100644
index 000000000000..31dcabd5deb9
--- /dev/null
+++ b/japanese/mule-wnn7/pkg-descr
@@ -0,0 +1,19 @@
+This is mule-2.1, a multilingual editor based on emacs-19.27.
+
+This package is built with Japanese support, using Wnn, as default. I
+don't use other language/input methods. People are welcome to test
+other configurations and report their results.
+
+This package is designed *not* to clobber any existing emacs
+installation. In particular, the executables and man pages of
+etags/ctags are not installed, and the info pages that come with the
+original emacs don't get installed too. Remove the file
+patches/patch-ab if you want this package to stand on its own.
+
+A "dir" file is supplied in the files/ subdirectory of the ports
+package. Copy it into your /usr/local/info to read mule info pages,
+but also make sure you also add everything that may have been added to
+that file!
+
+- Satoshi
+asami@cs.berkeley.edu