aboutsummaryrefslogtreecommitdiff
path: root/japanese/netscape48-communicator/Makefile
diff options
context:
space:
mode:
authorSADA Kenji <sada@FreeBSD.org>1998-11-16 19:52:58 +0000
committerSADA Kenji <sada@FreeBSD.org>1998-11-16 19:52:58 +0000
commit31aa8fb80ee3b1b93bf89989d4d30aa7e325ff30 (patch)
tree80d2657b87459a8df120dd0412e1c686d3351c42 /japanese/netscape48-communicator/Makefile
parent57be9661c27ff52a1b35cbae560f014bae866478 (diff)
downloadports-31aa8fb80ee3b1b93bf89989d4d30aa7e325ff30.tar.gz
ports-31aa8fb80ee3b1b93bf89989d4d30aa7e325ff30.zip
* Expand ``nethelp-v406.nif''.
* Remove obsolete environment variables. * Change the default message fonts 16dots -> 14dots. A user could change the work by setting up the environment ``USE_16DOT_FONT''. * Change the calling way for the SED script. * Enable to switch the locale function of ``LD_PRELOAD'' method instead of ``PATH LOCALE'' one, by the environment ``JA_NETSCAPE_USE_LD_PRELOAD''. * Follow up the distribution resource file's update and change the md5. PR: ports/8529 Submitted by: myself Obtained from: sada's local machine
Notes
Notes: svn path=/head/; revision=14573
Diffstat (limited to 'japanese/netscape48-communicator/Makefile')
-rw-r--r--japanese/netscape48-communicator/Makefile33
1 files changed, 20 insertions, 13 deletions
diff --git a/japanese/netscape48-communicator/Makefile b/japanese/netscape48-communicator/Makefile
index ec52a6fee541..e84b0078b783 100644
--- a/japanese/netscape48-communicator/Makefile
+++ b/japanese/netscape48-communicator/Makefile
@@ -3,19 +3,19 @@
# Date created: 13 Mar 1998
# Whom: sada
#
-# $Id: Makefile,v 1.5 1998/10/09 04:22:17 asami Exp $
+# $Id: Makefile,v 1.6 1998/10/09 22:27:47 asami Exp $
#
DISTNAME= ja-netscape-${BROWSER}
CATEGORIES= japanese www
MASTER_SITES= http://www.bres.tsukuba.ac.jp/~yohta/netscape/
-DISTFILES= communicator-ja-euc-v407-export.generic-generic-generic.tar.gz
+DISTFILES?= communicator-ja-euc-v407-export.generic-generic-generic.tar.gz
-MAINTAINER?= sada@e-mail.ne.jp
+MAINTAINER= sada@e-mail.ne.jp
-RUN_DEPENDS= \
+RUN_DEPENDS?= \
${PREFIX}/bin/${BROWSER}:${PORTSDIR}/www/netscape4-${BROWSER_NAME} \
- ${PKG_DBDIR}/ja-netscape-fonts-1.0:${PORTSDIR}/japanese/netscape-fonts
+ ${FONT_DEPEND}
MAN1= ja-${BROWSER_NAME}.1
MANLANG= ja
@@ -23,11 +23,13 @@ NO_BUILD= yes
STRIP=
WRKSRC= ${WRKDIR}/netscape-ja_euc
-BROWSER= ${BROWSER_NAME}-${BROWSER_VER}
+BROWSER= ${BROWSER_NAME}-${BROWSER_VERSION}
BROWSER_NAME?= communicator
-BROWSER_VER= 4.07
+BROWSER_VER= 4
+BROWSER_VERSION?= 4.07
LANG= ja_JP.EUC
-NDIR= ${PREFIX}/lib/netscape
+NDIR= ${PREFIX}/${NSUBDIR}
+NSUBDIR?= lib/netscape
MAKESCRIPT= ${SED} -e "s;@X11BASE@;${X11BASE};g" \
-e "s;@PREFIX@;${PREFIX};g" \
-e "s;@NDIR@;${NDIR};g" \
@@ -36,16 +38,19 @@ MAKESCRIPT= ${SED} -e "s;@X11BASE@;${X11BASE};g" \
-e "s;@LANG@;${LANG};g"
MANDIR= ${MANPREFIX}/man/${MANLANG}
MANFILE?= ${FILESDIR}/${MAN1}
+PLIST_SUB= NSUBDIR=${NSUBDIR} BROWSER=${BROWSER} LANG=${LANG}
+FONT_DEPEND= \
+ ${PKG_DBDIR}/ja-netscape-fonts-1.0:${PORTSDIR}/japanese/netscape-fonts
.SILENT:
do-configure:
${MAKESCRIPT} ${FILESDIR}/start.sh.in >${WRKDIR}/start.sh
-.if defined(USE_14DOT_FONT)
- ${MAKESCRIPT} ${WRKSRC}/Netscape.ad-ja_euc \
- |${FILESDIR}/14dot.sed >${WRKSRC}/Netscape
-.else
+.if defined(USE_16DOT_FONT)
${MAKESCRIPT} ${WRKSRC}/Netscape.ad-ja_euc >${WRKSRC}/Netscape
+.else
+ ${MAKESCRIPT} ${WRKSRC}/Netscape.ad-ja_euc \
+ | ${SED} -f ${FILESDIR}/14dot.sed >${WRKSRC}/Netscape
.endif
do-install:
@@ -53,9 +58,11 @@ do-install:
${MKDIR} ${NDIR}/locale
${LN} -sf /usr/share/locale/en_US.ISO_8859-1 ${NDIR}/locale/${LANG}
${MKDIR} ${NDIR}/${LANG}
-.for f in Netscape about mail.msg nethelp-v406.nif netscape.cfg plugins splash
+.for f in Netscape about mail.msg netscape.cfg plugins splash
${INSTALL_DATA} ${WRKSRC}/$f ${NDIR}/${LANG}/
.endfor
+ ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} ${WRKSRC}/nethelp-v406.nif \
+ -C ${NDIR}/${LANG}
${INSTALL_SCRIPT} ${WRKDIR}/start.sh ${PREFIX}/bin/ja-${BROWSER}
${LN} -sf ja-${BROWSER} ${PREFIX}/bin/netscape
${MKDIR} ${MANDIR}/man1