aboutsummaryrefslogtreecommitdiff
path: root/japanese/onew-freewnn
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>2001-08-27 01:20:24 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>2001-08-27 01:20:24 +0000
commit7b117d21671d6f9038809eb4a27e9f198fb9bbf6 (patch)
tree66c5fec50129c6628a27c1324ece64daf50596c9 /japanese/onew-freewnn
parenta16fefc81e5449a692a199a5d460b746bbb7d930 (diff)
downloadports-7b117d21671d6f9038809eb4a27e9f198fb9bbf6.tar.gz
ports-7b117d21671d6f9038809eb4a27e9f198fb9bbf6.zip
* Add Wnn7's clients (jvim, jvim3, kinput2, mule) and a library for
Wnn7 clients (Wnn7-lib). Notice the latter is modified from Wnn6-lib by me and is not released from the Product company of Wnn7 (Omron Software Co., Ltd). * Modify master ports of the above ports according to adding these. * [ports/editors/mule/pkg-descr] My English in pkg-descr was corrected Submitted by: imp
Notes
Notes: svn path=/head/; revision=46945
Diffstat (limited to 'japanese/onew-freewnn')
-rw-r--r--japanese/onew-freewnn/Makefile19
-rw-r--r--japanese/onew-freewnn/files/ONEW_CONF-for-canna+wnn712
-rw-r--r--japanese/onew-freewnn/files/ONEW_CONF-for-wnn78
-rw-r--r--japanese/onew-freewnn/pkg-comment2
-rw-r--r--japanese/onew-freewnn/pkg-descr6
5 files changed, 37 insertions, 10 deletions
diff --git a/japanese/onew-freewnn/Makefile b/japanese/onew-freewnn/Makefile
index 0a854f5c97a2..c7f3436bc536 100644
--- a/japanese/onew-freewnn/Makefile
+++ b/japanese/onew-freewnn/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: ONEW for FreeWnn
+o# New ports collection makefile for: ONEW for FreeWnn
# Date created: 5 Sep 1997
# Whom: Satoshi TAOKA <taoka@FreeBSD.org>
#
@@ -19,7 +19,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
# A value 'all' must not be set to TARGET.
ALL_TARGET=
-.if !defined(CANNA) && !defined(FREEWNN) && !defined(WNN6)
+.if !defined(CANNA) && !defined(FREEWNN) && !defined(WNN6) && !defined(WNN7)
# For this port
FREEWNN= yes
.endif
@@ -40,6 +40,13 @@ INPUT_METHOD+= wnn6
BUILD_DEPENDS+= ${LOCALBASE}/lib/libjd.a:${PORTSDIR}/japanese/FreeWnn-lib
JPLIB+= -ljd -lcrypt
JPDEF+= -DWNN_ISDIR
+RK_DIR= ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn6
+.elif defined(WNN7)
+INPUT_METHOD+= wnn7
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libjd.a:${PORTSDIR}/japanese/FreeWnn-lib
+JPLIB+= -ljd -lcrypt
+JPDEF+= -DWNN_ISDIR
+RK_DIR= ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn7
.endif
#
# Make a value of INPUT_METHOD
@@ -64,18 +71,18 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/README.ONEW ${PORT_DOCDIR}
.endif
.endif
-.if defined(WNN6)
- ${MKDIR} ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn6
+.if defined(WNN6) || defined(WNN7)
+ ${MKDIR} ${RK_DIR}
for file in 1B_TOUPPER 1B_ZENHIRA 1B_ZENKATA 1B_newTOUPPER \
2A_CTRL 2B_DAKUTEN 2B_JIS 2B_ROMKANA 2_TCODE \
3B_HANKATA 3B_KATAKANA 3B_ZENKAKU autork \
mode mode.hankata mode.nohankata; do \
${INSTALL_DATA} ${LOCALBASE}/lib/wnn/ja_JP/rk/$${file} \
- ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn6; \
+ ${RK_DIR}; \
done
@${ECHO} "############################################################"
@${ECHO} "We install all files in ${LOCALBASE}/lib/wnn/ja_JP/rk/"
- @${ECHO} " into new directory ${LOCALBASE}/lib/wnn/ja_JP/rk.wnn6/"
+ @${ECHO} " into a new directory ${RK_DIR}"
@${ECHO} "############################################################"
.endif
diff --git a/japanese/onew-freewnn/files/ONEW_CONF-for-canna+wnn7 b/japanese/onew-freewnn/files/ONEW_CONF-for-canna+wnn7
new file mode 100644
index 000000000000..82a00e4bf650
--- /dev/null
+++ b/japanese/onew-freewnn/files/ONEW_CONF-for-canna+wnn7
@@ -0,0 +1,12 @@
+WNNINC = -I%LOCALBASE%/include/wnn
+WNNLIB = -L%LOCALBASE%/lib -ljd
+WNN_RKPATH = '"./rk:$$ONEW_WNN_ROMKAND:$$ONEW_ROMKAND:$$HOME/.rk:%LOCALBASE%/lib/wnn/ja_JP/rk.wnn7:%LOCALBASE%/lib/wnn/ja_JP/rk:/tmp/onew_rktabs/wnn"'
+WNN_DICLIST = '"kihon tankan zip symbol tankan2 tel usr/$$USER/ud=10 usr/$$USER/private=10"'
+WNN_DICDIRS = '"system/%s.dic;usr/$$USER/%s.h"'
+CANNAINC = -I%LOCALBASE%/include
+CANNAOBJ = Canna.o CannaRk.o
+CANNALIB = -L%LOCALBASE%/lib -lcanna
+CANNA_RKPATH = '".:$$HOME:%LOCALBASE%/lib/canna/dic:/tmp/onew_rktabs/canna"'
+RKKLIBS = $(WNNLIB) $(CANNALIB)
+RKKOBJS = $(WNNOBJ) $(CANNAOBJ)
+MISCLIB = -lcrypt
diff --git a/japanese/onew-freewnn/files/ONEW_CONF-for-wnn7 b/japanese/onew-freewnn/files/ONEW_CONF-for-wnn7
new file mode 100644
index 000000000000..a1ea6b4dbb25
--- /dev/null
+++ b/japanese/onew-freewnn/files/ONEW_CONF-for-wnn7
@@ -0,0 +1,8 @@
+WNNINC = -I%LOCALBASE%/include/wnn
+WNNLIB = -L%LOCALBASE%/lib -ljd
+WNN_RKPATH = '"./rk:$$ONEW_WNN_ROMKAND:$$ONEW_ROMKAND:$$HOME/.rk:%LOCALBASE%/lib/wnn/ja_JP/rk.wnn7:%LOCALBASE%/lib/wnn/ja_JP/rk:/tmp/onew_rktabs/wnn"'
+WNN_DICLIST = '"kihon tankan zip symbol tankan2 tel usr/$$USER/ud=10 usr/$$USER/private=10"'
+WNN_DICDIRS = '"system/%s.dic;usr/$$USER/%s.h"'
+RKKLIBS = $(WNNLIB)
+RKKOBJS = $(WNNOBJ)
+MISCLIB = -lcrypt
diff --git a/japanese/onew-freewnn/pkg-comment b/japanese/onew-freewnn/pkg-comment
index fde919fb212d..eaa92c5431fb 100644
--- a/japanese/onew-freewnn/pkg-comment
+++ b/japanese/onew-freewnn/pkg-comment
@@ -1 +1 @@
-A library for Japanese Input Method FreeWnn
+A library for a Japanese Input Method: FreeWnn
diff --git a/japanese/onew-freewnn/pkg-descr b/japanese/onew-freewnn/pkg-descr
index ddd5d708242e..4b60b13e8488 100644
--- a/japanese/onew-freewnn/pkg-descr
+++ b/japanese/onew-freewnn/pkg-descr
@@ -1,7 +1,7 @@
-ONEW is a library for using Japanese Input Method Canna, FreeWnn, or
-Wnn6.
+ONEW is a library for using Japanese Input Methods: Canna, FreeWnn,
+Wnn6 or Wnn7.
-This is for FreeWnn.
+This port supports FreeWnn.
-- S. Taoka
<taoka@FreeBSD.org>