aboutsummaryrefslogtreecommitdiff
path: root/japanese/perl5/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-04-12 14:38:12 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-04-12 14:38:12 +0000
commit8e270816f992e4a25aaab762d962f7267d72f84b (patch)
treed4e36e838185404904fc906c77ad6ebbaf6ef1bc /japanese/perl5/Makefile
parenta989b83d8875de9cba6caf81919b68e80dfa6534 (diff)
downloadports-8e270816f992e4a25aaab762d962f7267d72f84b.tar.gz
ports-8e270816f992e4a25aaab762d962f7267d72f84b.zip
Update the japanese/[o-t]* ports with the new
PORT{NAME,VERSION}/PKGNAME{PRE,SUF}FIX variables.
Notes
Notes: svn path=/head/; revision=27463
Diffstat (limited to 'japanese/perl5/Makefile')
-rw-r--r--japanese/perl5/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/japanese/perl5/Makefile b/japanese/perl5/Makefile
index ba825666e07b..2e6e9cbc283e 100644
--- a/japanese/perl5/Makefile
+++ b/japanese/perl5/Makefile
@@ -1,13 +1,12 @@
# New ports collection makefile for: ja-perl5
-# Version required: 5.005_03
# Date created: 7 January 1997
# Whom: Yoshiro MIHIRA
#
# $FreeBSD$
#
-DISTNAME= perl5.005_03
-PKGNAME= ja-perl-5.005.03
+PORTNAME= perl
+PORTVERSION= ${JPERL_VER}.${JPERL_VER_PL}
CATEGORIES= japanese perl5
MASTER_SITES= ftp://ftp.cpan.org/CPAN/src/5.0/ \
ftp://ftp.funet.fi/pub/languages/perl/CPAN/src/5.0/ \
@@ -21,6 +20,7 @@ MASTER_SITES= ftp://ftp.cpan.org/CPAN/src/5.0/ \
ftp://ftp.cis.ufl.edu/pub/perl/CPAN/src/5.0/ \
ftp://ftp.delphi.com/pub/mirrors/packages/perl/CPAN/src/5.0/ \
ftp://uiarchive.cso.uiuc.edu/pub/lang/perl/CPAN/src/5.0/
+DISTNAME= ${PORTNAME}${JPERL_VER}_${JPERL_VER_PL}
PATCH_SITES= ftp://ftp.cpan.org/CPAN/authors/id/WATANABE/ \
ftp://ftp.funet.fi/pub/languages/perl/CPAN/authors/id/WATANABE/ \
@@ -34,7 +34,7 @@ PATCH_SITES= ftp://ftp.cpan.org/CPAN/authors/id/WATANABE/ \
ftp://ftp.cis.ufl.edu/pub/perl/CPAN/authors/id/WATANABE/ \
ftp://ftp.delphi.com/pub/mirrors/packages/perl/CPAN/authors/id/WATANABE/ \
ftp://uiarchive.cso.uiuc.edu/pub/lang/perl/CPAN/authors/id/WATANABE/
-PATCHFILES= jperl5.005_03-990822.pat.gz
+PATCHFILES= j${DISTNAME}-990822.pat.gz
PATCH_DIST_STRIP= -p1
MAINTAINER= shige@FreeBSD.org
@@ -46,8 +46,9 @@ CONFIGURE_SCRIPT= Configure
CONFIGURE_ARGS= -sde -Dprefix=${PREFIX} -Duseshrplib \
-Dlibperl=libperl.so.${PERL_SHLIBVER}
-JPERL_VERSION= 5.00503
JPERL_VER= 5.005
+JPERL_VER_PL= 03
+JPERL_VERSION= ${JPERL_VER}${JPERL_VER_PL}
.if ${PORTOBJFORMAT} == "aout"
PERL_SHLIBVER= 1.0
.else