aboutsummaryrefslogtreecommitdiff
path: root/japanese/postgresql-tcltk
diff options
context:
space:
mode:
authorJun Kuriyama <kuriyama@FreeBSD.org>1998-09-08 15:30:19 +0000
committerJun Kuriyama <kuriyama@FreeBSD.org>1998-09-08 15:30:19 +0000
commit165d5d4db9561857e3c183949f54c39262f12386 (patch)
tree1d5281afe149d6e07a9d35a11418ce823f483cd2 /japanese/postgresql-tcltk
parenta1f0638e054f8fb09ed67cb820402ae2238a2f42 (diff)
downloadports-165d5d4db9561857e3c183949f54c39262f12386.tar.gz
ports-165d5d4db9561857e3c183949f54c39262f12386.zip
a robust, next generation, object-relational DBMS plus Multibyte-patch
Submitted by: Ichiro Fukuhara <ichiro@ichiro.org>
Notes
Notes: svn path=/head/; revision=13049
Diffstat (limited to 'japanese/postgresql-tcltk')
-rw-r--r--japanese/postgresql-tcltk/Makefile140
-rw-r--r--japanese/postgresql-tcltk/distinfo2
-rw-r--r--japanese/postgresql-tcltk/files/patch-ad14
-rw-r--r--japanese/postgresql-tcltk/files/pgsql.sh.tmpl25
-rw-r--r--japanese/postgresql-tcltk/files/post-install-notes24
-rw-r--r--japanese/postgresql-tcltk/pkg-comment1
-rw-r--r--japanese/postgresql-tcltk/pkg-descr24
-rw-r--r--japanese/postgresql-tcltk/pkg-plist210
-rw-r--r--japanese/postgresql-tcltk/pkg-plist.tcl216
9 files changed, 656 insertions, 0 deletions
diff --git a/japanese/postgresql-tcltk/Makefile b/japanese/postgresql-tcltk/Makefile
new file mode 100644
index 000000000000..20dcae11e8cd
--- /dev/null
+++ b/japanese/postgresql-tcltk/Makefile
@@ -0,0 +1,140 @@
+# New ports collection makefile for: PostgreSQL-j
+# Version required: 6.3.2+Multibyte-patch
+# Date created: 20 Aug 1998
+# Whom: Ichiro Fukuhara <ichiro@ichiro.org>
+#
+# $Id$
+#
+
+DISTNAME= postgresql-6.3.2
+PKGNAME= ja-postgresql-6.3.2
+CATEGORIES= japanese databases
+MASTER_SITES= ftp://ftp.postgresql.org/pub/ \
+ ftp://ftp.jaist.ac.jp/pub/dbms/PostgreSQL/ \
+ ftp://ftp.sra.co.jp/pub/cmd/postgres/6.3.2/
+
+PATCH_SITES= ftp://ftp.sra.co.jp/pub/cmd/postgres/6.3.2/patches/FreeBSD/
+PATCHFILES= jumbo.patch.gz
+
+MAINTAINER= ichiro@ichiro.org
+
+WRKSRC= ${WRKDIR}/${DISTNAME}/src
+PATCH_DIST_ARGS= -d ${WRKDIR}/${DISTNAME} --forward --quiet -E -p1
+
+# if you want to use the tcl/tk frontend pgaccess, then you need to build
+# postgresql with tcl support by typing: make USE_TCL=yes
+.if defined(USE_TCL)
+MAKE_ENV= USE_TCL=true TCL_INCDIR=${PREFIX}/include/tcl7.6
+LIB_DEPENDS= tcl76jp\\.1\\.:${PORTSDIR}/japanese/tcl76 \
+ tk42jp\\.1\\.:${PORTSDIR}/japanese/tk42
+WITH_TCL= --with-tcl
+PLIST= ${PKGDIR}/PLIST.tcl
+.endif
+
+NO_PACKAGE= "Requires ${PGSQL_UID} uid"
+
+USE_GMAKE= YES
+MAKEFILE= GNUmakefile
+HAS_CONFIGURE= YES
+CONFIGURE_ARGS= --prefix=${PREFIX}/${INSTALL_DIR} \
+ --with-template=`uname -s | ${TR} '[A-Z]' '[a-z]'` \
+ --with-includes=${PREFIX}/include ${WITH_TCL} \
+ --with-libraries=${PREFIX}/lib --with-mb=EUC_JP
+
+MAN1= cleardbdir.1 createdb.1 createuser.1 destroydb.1 \
+ destroyuser.1 ecpg.1 initdb.1 ipcclean.1 initlocation.1 \
+ pg_dump.1 pg_dumpall.1 pg_passwd.1 pgintro.1 postgres.1 \
+ postmaster.1 psql.1
+MAN3= catalogs.3 large_objects.3 libpq.3 oracle_compat.3 pgbuiltin.3
+MAN5= bki.5 page.5 pg_hba.conf.5
+MANL= abort.l alter_table.l alter_user.l begin.l close.l cluster.l \
+ commit.l copy.l create_aggregate.l create_database.l \
+ create_function.l create_index.l create_language.l \
+ create_operator.l create_rule.l create_sequence.l \
+ create_table.l create_trigger.l create_type.l create_user.l \
+ create_version.l create_view.l declare.l delete.l drop.l \
+ drop_aggregate.l drop_database.l drop_function.l drop_index.l \
+ drop_language.l drop_operator.l drop_rule.l drop_sequence.l \
+ drop_table.l drop_trigger.l drop_type.l drop_user.l \
+ drop_view.l end.l explain.l fetch.l grant.l insert.l listen.l \
+ load.l lock.l move.l notify.l reset.l revoke.l \
+ rollback.l select.l set.l show.l sql.l update.l vacuum.l
+
+MANPREFIX= ${PREFIX}/${INSTALL_DIR}
+
+PLIST_SUB= INSTALL_DIR=${INSTALL_DIR}
+
+# These values are easily overridable like as
+# "make PGQL_UID=postgresql PGSQL_GID=postgresql install"
+INSTALL_DIR= pgsql
+PGSQL_UID= pgsql
+PGSQL_GID= pgsql
+
+pre-fetch:
+.if !defined(USE_TCL)
+ @${ECHO_MSG} "To build the \"PostgreSQL to Tcl interface library\", libpgtcl, type:"
+ @${ECHO_MSG} " make USE_TCL=yes"
+.else
+ @${ECHO_MSG} "Building PostgreSQL with \"libpgtcl\"."
+.endif
+
+post-patch:
+ find ${WRKDIR} -name '*.orig' -exec ${RM} {} \;
+
+post-build:
+ @ ${ECHO} "------------------------------------------------------------"
+ @ ${ECHO} "Dump existing databases, before installing new db version !!"
+ @ ${ECHO} "Detailed instructions, see INSTALL file under ${WRKDIR}... "
+ @ ${ECHO} "------------------------------------------------------------"
+
+pre-install:
+.if defined(PACKAGE_BUILDING)
+ ${RM} -rf ${PREFIX}/${INSTALL_DIR}
+.endif
+ @ ${MKDIR} ${PREFIX}/${INSTALL_DIR}
+ @ ${SED} "s=PGSQL_UID=${PGSQL_UID}=g ; s=PGSQL_GID=${PGSQL_GID}=g ; \
+ s=INSTALL_DIR=${INSTALL_DIR}=g" < ${SCRIPTDIR}/createuser.tmpl \
+ > ${WRKDIR}/createuser
+ @ ${SETENV} ${MAKE_ENV} perl ${WRKDIR}/createuser
+
+post-install:
+ @ if [ ! -f ${PREFIX}/${INSTALL_DIR}/.profile ]; then \
+ ${ECHO} "PATH=${PATH}:${PREFIX}/${INSTALL_DIR}/bin" \
+ > ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "MANPATH=${MANPATH}:${PREFIX}/${INSTALL_DIR}/bin" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "PGLIB=${PREFIX}/${INSTALL_DIR}/lib" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "# note: PGDATA overwrites the -D startup option" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "PGDATA=${PREFIX}/${INSTALL_DIR}/data" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "DISPLAY=:0" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "export PATH MANPATH PGLIB PGDATA DISPLAY" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "# if you want to make regression tests use this TZ" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "#TZ=PST8PDT" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ ${ECHO} "#export TZ" \
+ >> ${PREFIX}/${INSTALL_DIR}/.profile; \
+ fi
+ @ chown -R ${PGSQL_UID}:${PGSQL_GID} ${PREFIX}/${INSTALL_DIR}
+ @ ${ECHO} 'Initializing PostgreSQL Databases - this may take a few minutes...'
+ @ ${LDCONFIG} -m ${PREFIX}/${INSTALL_DIR}/lib
+ @ su -l ${PGSQL_UID} -c '${PREFIX}/${INSTALL_DIR}/bin/initdb --pglib=${PREFIX}/${INSTALL_DIR}/lib --pgdata=${PREFIX}/${INSTALL_DIR}/data'
+ @ ${SED} "s=!!PG_PATH!!=${PREFIX}/${INSTALL_DIR}=g ; s=!!PGSQL_UID!!=${PGSQL_UID}=g" \
+ < ${FILESDIR}/pgsql.sh.tmpl > ${PREFIX}/etc/rc.d/pgsql.sh
+ @ chmod 554 ${PREFIX}/etc/rc.d/pgsql.sh
+ @ chown root.${PGSQL_GID} ${PREFIX}/etc/rc.d/pgsql.sh
+ @ ${INSTALL_DATA} ${FILESDIR}/post-install-notes ${PREFIX}/${INSTALL_DIR}
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${INSTALL_DIR}
+ ${CP} -r ${WRKDIR}/${DISTNAME}/doc/* ${PREFIX}/share/doc/${INSTALL_DIR}
+.endif
+.if !defined(BATCH)
+ @ more -e ${FILESDIR}/post-install-notes
+.endif
+
+.include <bsd.port.mk>
diff --git a/japanese/postgresql-tcltk/distinfo b/japanese/postgresql-tcltk/distinfo
new file mode 100644
index 000000000000..b48d21f2a5d9
--- /dev/null
+++ b/japanese/postgresql-tcltk/distinfo
@@ -0,0 +1,2 @@
+MD5 (postgresql-6.3.2.tar.gz) = 8902842461c9a42854ba9883bee56a4c
+MD5 (jumbo.patch.gz) = 4c116013e4185648986c7590611aadb4
diff --git a/japanese/postgresql-tcltk/files/patch-ad b/japanese/postgresql-tcltk/files/patch-ad
new file mode 100644
index 000000000000..3529936565aa
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/patch-ad
@@ -0,0 +1,14 @@
+--- template/freebsd.orig Sat Jun 14 20:12:51 1997
++++ template/freebsd Sat Jun 14 20:13:06 1997
+@@ -1,9 +1,9 @@
+ AROPT:cq
+ SHARED_LIB:-fpic -DPIC
+-CFLAGS:-O2 -m486 -pipe
++CFLAGS:-pipe -O2
+ SRCH_INC:/usr/local/include
+ SRCH_LIB:/usr/local/lib
+-USE_LOCALE:no
++USE_LOCALE:yes
+ DLSUFFIX:.so
+ YFLAGS:-d
+ YACC:bison -y
diff --git a/japanese/postgresql-tcltk/files/pgsql.sh.tmpl b/japanese/postgresql-tcltk/files/pgsql.sh.tmpl
new file mode 100644
index 000000000000..e62e65dd64b9
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/pgsql.sh.tmpl
@@ -0,0 +1,25 @@
+#!/bin/sh
+
+# $Id: $
+
+# pgsql.sh - postgresql startup file for FreeBSD and possibly *BSD (untested)
+
+# Changes:
+# - renamed startup script to be in sync with INSTALL file
+# - merged ldconfig start sequence from former postgrsql.sh script (andreas)
+# - modified the postmaster startup sequence as suggested in the
+# INSTALL file which was given as example for FreeBSD 2.2 (andreas)
+# - removed the commandline option
+# -D!!PG_PATH!!/data \
+# because the postmaster process, which starts up under the
+# environment of the pgsql user, sets this with the PGDATA
+# environment variable in !!PG_PATH!!/.profile
+#
+
+[ -d !!PG_PATH!!/lib ] && /sbin/ldconfig -m !!PG_PATH!!/lib
+
+[ -x !!PG_PATH!!/bin/postmaster ] && {
+ su -l !!PGSQL_UID!! -c 'exec !!PG_PATH!!/bin/postmaster -i -S -o -F \
+ -D!!PG_PATH!!/data > !!PG_PATH!!/errlog'
+ echo -n ' PostgreSQL'
+}
diff --git a/japanese/postgresql-tcltk/files/post-install-notes b/japanese/postgresql-tcltk/files/post-install-notes
new file mode 100644
index 000000000000..4e6e8df02c33
--- /dev/null
+++ b/japanese/postgresql-tcltk/files/post-install-notes
@@ -0,0 +1,24 @@
+
+Now that PostgreSQL-j was installed, you should read the documentation and
+implementation guides. These can be found at:
+
+ http://www.PostgreSQL.org/docs
+
+Documentations for the Multibyte-extention can be found at:
+
+ doc/README.mb (English)
+ doc/README.mb.jp (Japanese)
+
+You may wish to subscribe to the PostgreSQL user-support mailing list.
+Send an e-mail to pgsql-questions-request@postgresql.org with the
+text "subscribe" in the message body.
+
+If you understand Japanese, you might want to visit:
+
+ http://www.sra.co.jp/people/t-ishii/PostgreSQL
+
+to subscribe a local mailing list for Japanese speakers.
+
+If you build PostgreSQL with TCL support, then you can use the
+TCL/TK based database frontend "pgaccess" for database operations.
+
diff --git a/japanese/postgresql-tcltk/pkg-comment b/japanese/postgresql-tcltk/pkg-comment
new file mode 100644
index 000000000000..6bcbc8801123
--- /dev/null
+++ b/japanese/postgresql-tcltk/pkg-comment
@@ -0,0 +1 @@
+a robust, next generation, object-relational DBMS plus Multibyte-patch
diff --git a/japanese/postgresql-tcltk/pkg-descr b/japanese/postgresql-tcltk/pkg-descr
new file mode 100644
index 000000000000..f0283be0cd64
--- /dev/null
+++ b/japanese/postgresql-tcltk/pkg-descr
@@ -0,0 +1,24 @@
+PostgreSQL is a robust, next-generation, Object-Relational DBMS (ORDBMS),
+derived from the Berkeley Postgres database management system. While
+PostgreSQL retains the powerful object-relational data model, rich data types
+and easy extensibility of Postgres, it replaces the PostQuel query language
+with an extended subset of SQL.
+
+The original Postgres code was the effort of many graduate students,
+undergraduate students, and staff programmers working under the direction of
+Professor Michael Stonebraker at the University of California, Berkeley. In
+1995, Andrew Yu and Jolly Chen took on the task of converting the DBMS query
+language to SQL and created a new database system which came to known as
+Postgres95. Many others contributed to the porting, testing, debugging and
+enhancement of the Postgres95 code. As the code improved, and 1995 faded into
+memory, PostgreSQL was born.
+
+PostgreSQL development is presently being performed by a team of Internet
+developers who are now responsible for all current and future development. The
+development team coordinator is Marc G. Fournier (scrappy@PostgreSQL.ORG).
+Support is available from the PostgreSQL developer/user community through the
+support mailing list (questions@PostgreSQL.ORG).
+
+PostgreSQL is free and the complete source is available.
+
+More information and documentation, visit: http://www.PostgreSQL.ORG/
diff --git a/japanese/postgresql-tcltk/pkg-plist b/japanese/postgresql-tcltk/pkg-plist
new file mode 100644
index 000000000000..7bb058674f8c
--- /dev/null
+++ b/japanese/postgresql-tcltk/pkg-plist
@@ -0,0 +1,210 @@
+etc/rc.d/pgsql.sh
+%%INSTALL_DIR%%/.profile
+%%INSTALL_DIR%%/bin/cleardbdir
+%%INSTALL_DIR%%/bin/createdb
+%%INSTALL_DIR%%/bin/createuser
+%%INSTALL_DIR%%/bin/destroydb
+%%INSTALL_DIR%%/bin/destroyuser
+%%INSTALL_DIR%%/bin/ecpg
+%%INSTALL_DIR%%/bin/initdb
+%%INSTALL_DIR%%/bin/initlocation
+%%INSTALL_DIR%%/bin/ipcclean
+%%INSTALL_DIR%%/bin/pg_dump
+%%INSTALL_DIR%%/bin/pg_dumpall
+%%INSTALL_DIR%%/bin/pg_id
+%%INSTALL_DIR%%/bin/pg_passwd
+%%INSTALL_DIR%%/bin/pg_version
+%%INSTALL_DIR%%/bin/postgres
+%%INSTALL_DIR%%/bin/postmaster
+%%INSTALL_DIR%%/bin/psql
+%%INSTALL_DIR%%/data/PG_VERSION
+%%INSTALL_DIR%%/data/base/template1/PG_VERSION
+%%INSTALL_DIR%%/data/base/template1/pg_aggregate
+%%INSTALL_DIR%%/data/base/template1/pg_am
+%%INSTALL_DIR%%/data/base/template1/pg_amop
+%%INSTALL_DIR%%/data/base/template1/pg_amproc
+%%INSTALL_DIR%%/data/base/template1/pg_attrdef
+%%INSTALL_DIR%%/data/base/template1/pg_attrdef_adrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_attrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_relid_attnam_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_relid_attnum_index
+%%INSTALL_DIR%%/data/base/template1/pg_class
+%%INSTALL_DIR%%/data/base/template1/pg_class_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_class_relname_index
+%%INSTALL_DIR%%/data/base/template1/pg_description
+%%INSTALL_DIR%%/data/base/template1/pg_description_objoid_index
+%%INSTALL_DIR%%/data/base/template1/pg_index
+%%INSTALL_DIR%%/data/base/template1/pg_inheritproc
+%%INSTALL_DIR%%/data/base/template1/pg_inherits
+%%INSTALL_DIR%%/data/base/template1/pg_internal.init
+%%INSTALL_DIR%%/data/base/template1/pg_ipl
+%%INSTALL_DIR%%/data/base/template1/pg_language
+%%INSTALL_DIR%%/data/base/template1/pg_listener
+%%INSTALL_DIR%%/data/base/template1/pg_opclass
+%%INSTALL_DIR%%/data/base/template1/pg_operator
+%%INSTALL_DIR%%/data/base/template1/pg_parg
+%%INSTALL_DIR%%/data/base/template1/pg_proc
+%%INSTALL_DIR%%/data/base/template1/pg_proc_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_proc_proname_index
+%%INSTALL_DIR%%/data/base/template1/pg_proc_prosrc_index
+%%INSTALL_DIR%%/data/base/template1/pg_relcheck
+%%INSTALL_DIR%%/data/base/template1/pg_relcheck_rcrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_rewrite
+%%INSTALL_DIR%%/data/base/template1/pg_statistic
+%%INSTALL_DIR%%/data/base/template1/pg_trigger
+%%INSTALL_DIR%%/data/base/template1/pg_trigger_tgrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_type
+%%INSTALL_DIR%%/data/base/template1/pg_type_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_type_typname_index
+%%INSTALL_DIR%%/data/base/template1/pg_user
+%%INSTALL_DIR%%/data/base/template1/pg_version
+%%INSTALL_DIR%%/data/pg_database
+%%INSTALL_DIR%%/data/pg_geqo.sample
+%%INSTALL_DIR%%/data/pg_group
+%%INSTALL_DIR%%/data/pg_hba.conf
+%%INSTALL_DIR%%/data/pg_log
+%%INSTALL_DIR%%/data/pg_pwd
+%%INSTALL_DIR%%/data/pg_shadow
+%%INSTALL_DIR%%/data/pg_variable
+%%INSTALL_DIR%%/include/access/attnum.h
+%%INSTALL_DIR%%/include/c.h
+%%INSTALL_DIR%%/include/commands/trigger.h
+%%INSTALL_DIR%%/include/config.h
+%%INSTALL_DIR%%/include/ecpglib.h
+%%INSTALL_DIR%%/include/ecpgtype.h
+%%INSTALL_DIR%%/include/executor/spi.h
+%%INSTALL_DIR%%/include/fmgr.h
+%%INSTALL_DIR%%/include/lib/dllist.h
+%%INSTALL_DIR%%/include/libpq-fe.h
+%%INSTALL_DIR%%/include/libpq/libpq-fs.h
+%%INSTALL_DIR%%/include/libpq/pqcomm.h
+%%INSTALL_DIR%%/include/os.h
+%%INSTALL_DIR%%/include/postgres.h
+%%INSTALL_DIR%%/include/postgres_ext.h
+%%INSTALL_DIR%%/include/sqlca.h
+%%INSTALL_DIR%%/include/utils/elog.h
+%%INSTALL_DIR%%/include/utils/geo_decls.h
+%%INSTALL_DIR%%/include/utils/palloc.h
+%%INSTALL_DIR%%/lib/global1.bki.source
+%%INSTALL_DIR%%/lib/global1.description
+%%INSTALL_DIR%%/lib/libecpg.a
+%%INSTALL_DIR%%/lib/libecpg.so
+%%INSTALL_DIR%%/lib/libecpg.so.1.1
+%%INSTALL_DIR%%/lib/libpq.a
+%%INSTALL_DIR%%/lib/libpq.so
+%%INSTALL_DIR%%/lib/libpq.so.1.1
+%%INSTALL_DIR%%/lib/local1_template1.bki.source
+%%INSTALL_DIR%%/lib/local1_template1.description
+%%INSTALL_DIR%%/lib/pg_geqo.sample
+%%INSTALL_DIR%%/lib/pg_hba.conf.sample
+%%INSTALL_DIR%%/post-install-notes
+share/doc/%%INSTALL_DIR%%/FAQ
+share/doc/%%INSTALL_DIR%%/FAQ_FreeBSD
+share/doc/%%INSTALL_DIR%%/FAQ_Irix
+share/doc/%%INSTALL_DIR%%/FAQ_Linux
+share/doc/%%INSTALL_DIR%%/Makefile
+share/doc/%%INSTALL_DIR%%/README.GEQO
+share/doc/%%INSTALL_DIR%%/README.fsync
+share/doc/%%INSTALL_DIR%%/README.mb
+share/doc/%%INSTALL_DIR%%/README.mb.jp
+share/doc/%%INSTALL_DIR%%/README.support
+share/doc/%%INSTALL_DIR%%/TODO
+share/doc/%%INSTALL_DIR%%/TODO.GEQO
+share/doc/%%INSTALL_DIR%%/admin.ps.gz
+share/doc/%%INSTALL_DIR%%/admin.tar.gz
+share/doc/%%INSTALL_DIR%%/bug.template
+share/doc/%%INSTALL_DIR%%/postgres.tar.gz
+share/doc/%%INSTALL_DIR%%/programmer.ps.gz
+share/doc/%%INSTALL_DIR%%/programmer.tar.gz
+share/doc/%%INSTALL_DIR%%/src/Makefile
+share/doc/%%INSTALL_DIR%%/src/graphics/catalogs.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/clientserver.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/clientserver.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/connections.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/connections.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/layout.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/layout.gif
+share/doc/%%INSTALL_DIR%%/src/sgml/Makefile
+share/doc/%%INSTALL_DIR%%/src/sgml/admin.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/advanced.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch-dev.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch-pg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/array.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/biblio.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/compiler.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/contacts.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/datatype.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/dfunc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/docguide.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/ecpg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/environ.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/extend.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/func-ref.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/geqo.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/gist.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/inherit.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/install.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/intro-pg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/intro.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/jdbc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/libpgtcl.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/libpq.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/lobj.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/manage.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/odbc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/pgaccess.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/ports.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/postgres.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/programmer.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/protocol.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/psql.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/query-ug.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/query.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/recovery.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/regress.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/release.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/rules.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/spi.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/start-ag.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/start.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/storage.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/trigger.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/tutorial.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/user.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xaggr.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xfunc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xindex.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xoper.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xtypes.sgml
+share/doc/%%INSTALL_DIR%%/tutorial.ps.gz
+share/doc/%%INSTALL_DIR%%/tutorial.tar.gz
+share/doc/%%INSTALL_DIR%%/user.ps.gz
+share/doc/%%INSTALL_DIR%%/user.tar.gz
+share/doc/%%INSTALL_DIR%%/userguide.ps
+@dirrm share/doc/%%INSTALL_DIR%%/src/graphics
+@dirrm share/doc/%%INSTALL_DIR%%/src/sgml
+@dirrm share/doc/%%INSTALL_DIR%%/src
+@dirrm share/doc/%%INSTALL_DIR%%
+@dirrm %%INSTALL_DIR%%/bin
+@dirrm %%INSTALL_DIR%%/data/base/template1
+@dirrm %%INSTALL_DIR%%/data/base
+@dirrm %%INSTALL_DIR%%/data
+@dirrm %%INSTALL_DIR%%/include/access
+@dirrm %%INSTALL_DIR%%/include/commands
+@dirrm %%INSTALL_DIR%%/include/executor
+@dirrm %%INSTALL_DIR%%/include/include
+@dirrm %%INSTALL_DIR%%/include/lib
+@dirrm %%INSTALL_DIR%%/include/libpq
+@dirrm %%INSTALL_DIR%%/include/port/bsd
+@dirrm %%INSTALL_DIR%%/include/port
+@dirrm %%INSTALL_DIR%%/include/utils
+@dirrm %%INSTALL_DIR%%/include
+@dirrm %%INSTALL_DIR%%/lib
+@dirrm %%INSTALL_DIR%%/man/man1
+@dirrm %%INSTALL_DIR%%/man/man3
+@dirrm %%INSTALL_DIR%%/man/man5
+@dirrm %%INSTALL_DIR%%/man/manl
+@dirrm %%INSTALL_DIR%%/man
+@dirrm %%INSTALL_DIR%%
diff --git a/japanese/postgresql-tcltk/pkg-plist.tcl b/japanese/postgresql-tcltk/pkg-plist.tcl
new file mode 100644
index 000000000000..4f5184ce3ec3
--- /dev/null
+++ b/japanese/postgresql-tcltk/pkg-plist.tcl
@@ -0,0 +1,216 @@
+etc/rc.d/pgsql.sh
+%%INSTALL_DIR%%/.profile
+%%INSTALL_DIR%%/bin/cleardbdir
+%%INSTALL_DIR%%/bin/createdb
+%%INSTALL_DIR%%/bin/createuser
+%%INSTALL_DIR%%/bin/destroydb
+%%INSTALL_DIR%%/bin/destroyuser
+%%INSTALL_DIR%%/bin/ecpg
+%%INSTALL_DIR%%/bin/initdb
+%%INSTALL_DIR%%/bin/initlocation
+%%INSTALL_DIR%%/bin/ipcclean
+%%INSTALL_DIR%%/bin/pg_dump
+%%INSTALL_DIR%%/bin/pg_dumpall
+%%INSTALL_DIR%%/bin/pg_id
+%%INSTALL_DIR%%/bin/pg_passwd
+%%INSTALL_DIR%%/bin/pg_version
+%%INSTALL_DIR%%/bin/pgtclsh
+%%INSTALL_DIR%%/bin/pgtksh
+%%INSTALL_DIR%%/bin/postgres
+%%INSTALL_DIR%%/bin/postmaster
+%%INSTALL_DIR%%/bin/psql
+%%INSTALL_DIR%%/data/PG_VERSION
+%%INSTALL_DIR%%/data/base/template1/PG_VERSION
+%%INSTALL_DIR%%/data/base/template1/pg_aggregate
+%%INSTALL_DIR%%/data/base/template1/pg_am
+%%INSTALL_DIR%%/data/base/template1/pg_amop
+%%INSTALL_DIR%%/data/base/template1/pg_amproc
+%%INSTALL_DIR%%/data/base/template1/pg_attrdef
+%%INSTALL_DIR%%/data/base/template1/pg_attrdef_adrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_attrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_relid_attnam_index
+%%INSTALL_DIR%%/data/base/template1/pg_attribute_relid_attnum_index
+%%INSTALL_DIR%%/data/base/template1/pg_class
+%%INSTALL_DIR%%/data/base/template1/pg_class_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_class_relname_index
+%%INSTALL_DIR%%/data/base/template1/pg_description
+%%INSTALL_DIR%%/data/base/template1/pg_description_objoid_index
+%%INSTALL_DIR%%/data/base/template1/pg_index
+%%INSTALL_DIR%%/data/base/template1/pg_inheritproc
+%%INSTALL_DIR%%/data/base/template1/pg_inherits
+%%INSTALL_DIR%%/data/base/template1/pg_internal.init
+%%INSTALL_DIR%%/data/base/template1/pg_ipl
+%%INSTALL_DIR%%/data/base/template1/pg_language
+%%INSTALL_DIR%%/data/base/template1/pg_listener
+%%INSTALL_DIR%%/data/base/template1/pg_opclass
+%%INSTALL_DIR%%/data/base/template1/pg_operator
+%%INSTALL_DIR%%/data/base/template1/pg_parg
+%%INSTALL_DIR%%/data/base/template1/pg_proc
+%%INSTALL_DIR%%/data/base/template1/pg_proc_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_proc_proname_index
+%%INSTALL_DIR%%/data/base/template1/pg_proc_prosrc_index
+%%INSTALL_DIR%%/data/base/template1/pg_relcheck
+%%INSTALL_DIR%%/data/base/template1/pg_relcheck_rcrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_rewrite
+%%INSTALL_DIR%%/data/base/template1/pg_statistic
+%%INSTALL_DIR%%/data/base/template1/pg_trigger
+%%INSTALL_DIR%%/data/base/template1/pg_trigger_tgrelid_index
+%%INSTALL_DIR%%/data/base/template1/pg_type
+%%INSTALL_DIR%%/data/base/template1/pg_type_oid_index
+%%INSTALL_DIR%%/data/base/template1/pg_type_typname_index
+%%INSTALL_DIR%%/data/base/template1/pg_user
+%%INSTALL_DIR%%/data/base/template1/pg_version
+%%INSTALL_DIR%%/data/pg_database
+%%INSTALL_DIR%%/data/pg_geqo.sample
+%%INSTALL_DIR%%/data/pg_group
+%%INSTALL_DIR%%/data/pg_hba.conf
+%%INSTALL_DIR%%/data/pg_log
+%%INSTALL_DIR%%/data/pg_pwd
+%%INSTALL_DIR%%/data/pg_shadow
+%%INSTALL_DIR%%/data/pg_variable
+%%INSTALL_DIR%%/include/access/attnum.h
+%%INSTALL_DIR%%/include/c.h
+%%INSTALL_DIR%%/include/commands/trigger.h
+%%INSTALL_DIR%%/include/config.h
+%%INSTALL_DIR%%/include/ecpglib.h
+%%INSTALL_DIR%%/include/ecpgtype.h
+%%INSTALL_DIR%%/include/executor/spi.h
+%%INSTALL_DIR%%/include/fmgr.h
+%%INSTALL_DIR%%/include/lib/dllist.h
+%%INSTALL_DIR%%/include/libpgtcl.h
+%%INSTALL_DIR%%/include/libpq-fe.h
+%%INSTALL_DIR%%/include/libpq/libpq-fs.h
+%%INSTALL_DIR%%/include/libpq/pqcomm.h
+%%INSTALL_DIR%%/include/os.h
+%%INSTALL_DIR%%/include/postgres.h
+%%INSTALL_DIR%%/include/postgres_ext.h
+%%INSTALL_DIR%%/include/sqlca.h
+%%INSTALL_DIR%%/include/utils/elog.h
+%%INSTALL_DIR%%/include/utils/geo_decls.h
+%%INSTALL_DIR%%/include/utils/palloc.h
+%%INSTALL_DIR%%/lib/global1.bki.source
+%%INSTALL_DIR%%/lib/global1.description
+%%INSTALL_DIR%%/lib/libecpg.a
+%%INSTALL_DIR%%/lib/libecpg.so
+%%INSTALL_DIR%%/lib/libecpg.so.1.1
+%%INSTALL_DIR%%/lib/libpgtcl.a
+%%INSTALL_DIR%%/lib/libpgtcl.so
+%%INSTALL_DIR%%/lib/libpgtcl.so.1.0
+%%INSTALL_DIR%%/lib/libpq.a
+%%INSTALL_DIR%%/lib/libpq.so
+%%INSTALL_DIR%%/lib/libpq.so.1.1
+%%INSTALL_DIR%%/lib/local1_template1.bki.source
+%%INSTALL_DIR%%/lib/local1_template1.description
+%%INSTALL_DIR%%/lib/pg_geqo.sample
+%%INSTALL_DIR%%/lib/pg_hba.conf.sample
+%%INSTALL_DIR%%/post-install-notes
+share/doc/%%INSTALL_DIR%%/FAQ
+share/doc/%%INSTALL_DIR%%/FAQ_FreeBSD
+share/doc/%%INSTALL_DIR%%/FAQ_Irix
+share/doc/%%INSTALL_DIR%%/FAQ_Linux
+share/doc/%%INSTALL_DIR%%/Makefile
+share/doc/%%INSTALL_DIR%%/README.GEQO
+share/doc/%%INSTALL_DIR%%/README.fsync
+share/doc/%%INSTALL_DIR%%/README.mb
+share/doc/%%INSTALL_DIR%%/README.mb.jp
+share/doc/%%INSTALL_DIR%%/README.support
+share/doc/%%INSTALL_DIR%%/TODO
+share/doc/%%INSTALL_DIR%%/TODO.GEQO
+share/doc/%%INSTALL_DIR%%/admin.ps.gz
+share/doc/%%INSTALL_DIR%%/admin.tar.gz
+share/doc/%%INSTALL_DIR%%/bug.template
+share/doc/%%INSTALL_DIR%%/postgres.tar.gz
+share/doc/%%INSTALL_DIR%%/programmer.ps.gz
+share/doc/%%INSTALL_DIR%%/programmer.tar.gz
+share/doc/%%INSTALL_DIR%%/src/Makefile
+share/doc/%%INSTALL_DIR%%/src/graphics/catalogs.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/clientserver.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/clientserver.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/connections.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/connections.gif
+share/doc/%%INSTALL_DIR%%/src/graphics/layout.ag
+share/doc/%%INSTALL_DIR%%/src/graphics/layout.gif
+share/doc/%%INSTALL_DIR%%/src/sgml/Makefile
+share/doc/%%INSTALL_DIR%%/src/sgml/admin.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/advanced.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch-dev.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch-pg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/arch.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/array.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/biblio.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/compiler.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/contacts.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/datatype.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/dfunc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/docguide.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/ecpg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/environ.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/extend.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/func-ref.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/geqo.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/gist.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/inherit.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/install.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/intro-pg.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/intro.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/jdbc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/libpgtcl.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/libpq.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/lobj.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/manage.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/odbc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/pgaccess.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/ports.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/postgres.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/programmer.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/protocol.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/psql.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/query-ug.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/query.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/recovery.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/regress.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/release.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/rules.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/spi.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/start-ag.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/start.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/storage.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/trigger.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/tutorial.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/user.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xaggr.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xfunc.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xindex.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xoper.sgml
+share/doc/%%INSTALL_DIR%%/src/sgml/xtypes.sgml
+share/doc/%%INSTALL_DIR%%/tutorial.ps.gz
+share/doc/%%INSTALL_DIR%%/tutorial.tar.gz
+share/doc/%%INSTALL_DIR%%/user.ps.gz
+share/doc/%%INSTALL_DIR%%/user.tar.gz
+share/doc/%%INSTALL_DIR%%/userguide.ps
+@dirrm share/doc/%%INSTALL_DIR%%/src/graphics
+@dirrm share/doc/%%INSTALL_DIR%%/src/sgml
+@dirrm share/doc/%%INSTALL_DIR%%/src
+@dirrm share/doc/%%INSTALL_DIR%%
+@dirrm %%INSTALL_DIR%%/bin
+@dirrm %%INSTALL_DIR%%/data/base/template1
+@dirrm %%INSTALL_DIR%%/data/base
+@dirrm %%INSTALL_DIR%%/data
+@dirrm %%INSTALL_DIR%%/include/access
+@dirrm %%INSTALL_DIR%%/include/commands
+@dirrm %%INSTALL_DIR%%/include/executor
+@dirrm %%INSTALL_DIR%%/include/include
+@dirrm %%INSTALL_DIR%%/include/lib
+@dirrm %%INSTALL_DIR%%/include/libpq
+@dirrm %%INSTALL_DIR%%/include/port/bsd
+@dirrm %%INSTALL_DIR%%/include/port
+@dirrm %%INSTALL_DIR%%/include/utils
+@dirrm %%INSTALL_DIR%%/include
+@dirrm %%INSTALL_DIR%%/lib
+@dirrm %%INSTALL_DIR%%/man/man1
+@dirrm %%INSTALL_DIR%%/man/man3
+@dirrm %%INSTALL_DIR%%/man/man5
+@dirrm %%INSTALL_DIR%%/man/manl
+@dirrm %%INSTALL_DIR%%/man
+@dirrm %%INSTALL_DIR%%