aboutsummaryrefslogtreecommitdiff
path: root/japanese/ptex/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>2003-04-14 04:18:44 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>2003-04-14 04:18:44 +0000
commit5c8b35e4e62ecb5bcc46e63e893b829638712fb4 (patch)
treea49399ba293475316998292fd4497d1442c6fe22 /japanese/ptex/Makefile
parentddb8bdf7a4d4e86f4015646c5dcc4dde815a6684 (diff)
downloadports-5c8b35e4e62ecb5bcc46e63e893b829638712fb4.tar.gz
ports-5c8b35e4e62ecb5bcc46e63e893b829638712fb4.zip
Upgrade to 3.1.2.
Now charset to be used can be specified at runtime, instead of compile time. Due to this change, charset specific ports are being removed, and pTeX now consists of two ports: ptex-base and ptex. Ptex-base is what used to be ptex-common, which installs non-Japanese portion of the system, and ptex is what used to be the charset specific portion, which installs Japanese specific files. Thus, ptex-common and ptex-euc are renamed to ptex-base and ptex respectively, and ptex-jis and ptex-sjis are being removed.
Notes
Notes: svn path=/head/; revision=78929
Diffstat (limited to 'japanese/ptex/Makefile')
-rw-r--r--japanese/ptex/Makefile40
1 files changed, 22 insertions, 18 deletions
diff --git a/japanese/ptex/Makefile b/japanese/ptex/Makefile
index 9e31b30d4831..3a4c5f7c3ba0 100644
--- a/japanese/ptex/Makefile
+++ b/japanese/ptex/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: pTeX-euc
+# New ports collection makefile for: pTeX
# Date created: 05 Oct 1997
# Whom: max
#
@@ -6,42 +6,46 @@
#
PORTNAME= ptex
-PORTVERSION= 2.1.11
+PORTVERSION= 3.1.2
CATEGORIES= japanese print
MASTER_SITES= ftp://ftp.ascii.co.jp/pub/TeX/ascii-ptex/tetex/
PKGNAMEPREFIX= ja-
-PKGNAMESUFFIX= -euc
-DISTNAME= ptex-src-2.1.10
-DIST_SUBDIR= teTeX/ptex
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+DIST_SUBDIR= teTeX
MAINTAINER= max@FreeBSD.org
-COMMENT= Japanese pTeX files to support EUC character set
+COMMENT= Japanese specific files for ASCII Japanese pTeX
-PATCH_SITES= ${MASTER_SITES}
-PATCHFILES= ptex2.1.10-11.patch
+BUILD_DEPENDS= ${PREFIX}/share/texmf/ptex/plain/base/ptex.tex:${PORTSDIR}/japanese/ptex-base
+RUN_DEPENDS= ${PREFIX}/share/texmf/ptex/plain/base/ptex.tex:${PORTSDIR}/japanese/ptex-base
-BUILD_DEPENDS= ${PREFIX}/share/texmf/ptex/plain/base/ptex.tex:${PORTSDIR}/japanese/ptex-common
-RUN_DEPENDS= ${PREFIX}/share/texmf/ptex/plain/base/ptex.tex:${PORTSDIR}/japanese/ptex-common
-
-MANUAL_PACKAGE_BUILD= incompatible with other versions of ptex-*
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= euc
-WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../ptex-common/work/teTeX-1.0/texk/web2c/${SRCDIR}
+CONFIGURE_ARGS= ${KANJICODE}
+WRKSRC= ${WRKDIRPREFIX}${.CURDIR}/../ptex-base/work/tetex-src-${TETEX_VERSION}/texk/web2c/${SRCDIR}
ALL_TARGET= default
-SRCDIR= ptex-src-2.1.10
+KANJICODE?= jis
+SRCDIR= ptex-${PORTVERSION}
+TETEX_VERSION= 2.0.1
BINARIES= ptex pdvitype jbibtex pltotf tftopl
pre-extract:
-.if !exists(${WRKDIRPREFIX}${.CURDIR}/../ptex-common/work/.build_done)
- @(cd ${.CURDIR}/../ptex-common; \
+ @${ECHO} "The default kanji code is ${KANJICODE}."
+ @${ECHO} "You can change the kanji code at ptex runtime with the -kanji option."
+ @${ECHO} "e.g. ptex -kanji=sjis"
+ @${ECHO} "If you would like to change the default kanji code, run make as follows:"
+ @${ECHO} " make KANJICODE=sjis"
+ @${ECHO} "for Shift-JIS. KANJICODE can be one of sjis, jis or euc."
+ @sleep 10
+.if !exists(${WRKDIRPREFIX}${.CURDIR}/../ptex-base/work/.build_done.ja-ptex-base-${PORTVERSION})
+ @(cd ${.CURDIR}/../ptex-base; \
${SETENV} ${MAKE_ENV} ${MAKE})
.endif
post-extract:
@${RM} -rf ${WRKSRC}
- @${MV} ${WRKDIR}/${SRCDIR} ${WRKDIRPREFIX}${.CURDIR}/../ptex-common/work/teTeX-1.0/texk/web2c
+ @${MV} ${WRKDIR}/${SRCDIR} ${WRKDIRPREFIX}${.CURDIR}/../ptex-base/work/tetex-src-${TETEX_VERSION}/texk/web2c
pre-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL