aboutsummaryrefslogtreecommitdiff
path: root/japanese/ruby-eb
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-09-05 18:26:28 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-09-05 18:26:28 +0000
commit70bc7ecc12657be05e068b2246cc76a3f92402c6 (patch)
treeffe0ab8a7bdb770ac340e06ec96bd92570ee1ca9 /japanese/ruby-eb
parent1e81cbdf79cf8bfdbfc3ec88ce10639e2c0d61e1 (diff)
downloadports-70bc7ecc12657be05e068b2246cc76a3f92402c6.tar.gz
ports-70bc7ecc12657be05e068b2246cc76a3f92402c6.zip
Add ruby-eb, Ruby bind of EB library.
Notes
Notes: svn path=/head/; revision=32319
Diffstat (limited to 'japanese/ruby-eb')
-rw-r--r--japanese/ruby-eb/Makefile46
-rw-r--r--japanese/ruby-eb/distinfo1
-rw-r--r--japanese/ruby-eb/pkg-comment1
-rw-r--r--japanese/ruby-eb/pkg-descr5
-rw-r--r--japanese/ruby-eb/pkg-plist7
5 files changed, 60 insertions, 0 deletions
diff --git a/japanese/ruby-eb/Makefile b/japanese/ruby-eb/Makefile
new file mode 100644
index 000000000000..193c2a3b4391
--- /dev/null
+++ b/japanese/ruby-eb/Makefile
@@ -0,0 +1,46 @@
+# New ports collection makefile for: Ruby EB
+# Date created: 6 Sep 2000
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= eb
+PORTVERSION= 1.4
+CATEGORIES= japanese ruby
+MASTER_SITES= http://www.osk.3web.ne.jp/~nyasu/software/
+DISTNAME= ruby-${PORTNAME}${PORTVERSION}
+DIST_SUBDIR= ruby
+
+MAINTAINER= knu@FreeBSD.org
+
+BUILD_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+LIB_DEPENDS= eb.3:${PORTSDIR}/japanese/eb
+RUN_DEPENDS= ruby:${PORTSDIR}/lang/ruby
+
+NO_WRKSUBDIR= yes
+CONFIGURE_ARGS= --with-opt-dir="${LOCALBASE}"
+INSTALL_TARGET= site-install
+PLIST_SUB= RUBY_VER="${RUBY_VER}" RUBY_ARCH="${RUBY_ARCH}"
+
+RUBY?= ${LOCALBASE}/bin/ruby
+RUBY_VER?= 1.4
+RUBY_ARCH?= ${ARCH}-freebsd${OSREL}
+
+.include <bsd.port.pre.mk>
+
+PKGNAMEPREFIX:= ${PKGNAMEPREFIX}ruby-
+
+do-configure:
+ @cd ${WRKSRC}; \
+ ${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb ${CONFIGURE_ARGS}
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/examples/ruby/eb/ja/
+ ${INSTALL_DATA} ${WRKSRC}/test.rb ${PREFIX}/share/examples/ruby/eb/ja/
+ ${MKDIR} ${PREFIX}/share/doc/ruby/eb/ja
+ ${INSTALL_DATA} ${WRKSRC}/eb.html ${PREFIX}/share/doc/ruby/eb/ja/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/japanese/ruby-eb/distinfo b/japanese/ruby-eb/distinfo
new file mode 100644
index 000000000000..32cbcd9a8a36
--- /dev/null
+++ b/japanese/ruby-eb/distinfo
@@ -0,0 +1 @@
+MD5 (ruby/ruby-eb1.4.tar.gz) = f7645b29da2c77318b2b4e20959cde2c
diff --git a/japanese/ruby-eb/pkg-comment b/japanese/ruby-eb/pkg-comment
new file mode 100644
index 000000000000..23021815984e
--- /dev/null
+++ b/japanese/ruby-eb/pkg-comment
@@ -0,0 +1 @@
+Ruby bind of EB library
diff --git a/japanese/ruby-eb/pkg-descr b/japanese/ruby-eb/pkg-descr
new file mode 100644
index 000000000000..0319eec3bebf
--- /dev/null
+++ b/japanese/ruby-eb/pkg-descr
@@ -0,0 +1,5 @@
+Ruby EB -- Ruby bind of EB library.
+
+
+Author: Nishikawa,Yasuhiro <nyasu@osk.3web.ne.jp>
+WWW: http://www.ruby-lang.org/en/raa-list.rhtml?name=RubyEB
diff --git a/japanese/ruby-eb/pkg-plist b/japanese/ruby-eb/pkg-plist
new file mode 100644
index 000000000000..399d77563d1c
--- /dev/null
+++ b/japanese/ruby-eb/pkg-plist
@@ -0,0 +1,7 @@
+lib/ruby/site_ruby/%%RUBY_VER%%/%%RUBY_ARCH%%/eb.so
+share/examples/ruby/eb/ja/test.rb
+@dirrm share/examples/ruby/eb/ja
+@dirrm share/examples/ruby/eb
+share/doc/ruby/eb/ja/eb.html
+@dirrm share/doc/ruby/eb/ja
+@dirrm share/doc/ruby/eb