aboutsummaryrefslogtreecommitdiff
path: root/japanese/rxvt
diff options
context:
space:
mode:
authorChris Piazza <cpiazza@FreeBSD.org>2000-01-14 19:39:09 +0000
committerChris Piazza <cpiazza@FreeBSD.org>2000-01-14 19:39:09 +0000
commitae0593e5404906c978155b85c3b8c26aac3f16c9 (patch)
tree270ed2fe4efb28f998b976e20486d305eedcd843 /japanese/rxvt
parenteb66565459f4f348b5bf75d9e6159b6960eab157 (diff)
downloadports-ae0593e5404906c978155b85c3b8c26aac3f16c9.tar.gz
ports-ae0593e5404906c978155b85c3b8c26aac3f16c9.zip
Update to rxvt 2.7.2
PR: 16061 Submitted by: maintainer
Notes
Notes: svn path=/head/; revision=24738
Diffstat (limited to 'japanese/rxvt')
-rw-r--r--japanese/rxvt/Makefile21
-rw-r--r--japanese/rxvt/distinfo2
-rw-r--r--japanese/rxvt/files/patch-aa8
-rw-r--r--japanese/rxvt/files/patch-ab50
-rw-r--r--japanese/rxvt/files/patch-ad8
-rw-r--r--japanese/rxvt/files/patch-aj44
-rw-r--r--japanese/rxvt/files/patch-ak36
-rw-r--r--japanese/rxvt/files/patch-al20
-rw-r--r--japanese/rxvt/files/patch-am293
-rw-r--r--japanese/rxvt/files/patch-an19
-rw-r--r--japanese/rxvt/pkg-plist2
11 files changed, 442 insertions, 61 deletions
diff --git a/japanese/rxvt/Makefile b/japanese/rxvt/Makefile
index 8fb998bc5995..ec468339eadb 100644
--- a/japanese/rxvt/Makefile
+++ b/japanese/rxvt/Makefile
@@ -1,13 +1,13 @@
# New ports collection Makefile for: ja-rxvt
-# Version required: 2.6.1
+# Version required: 2.7.2
# Date created: 11 May 1999
# Whom: HONDA Yasuhiro <honda@kashio.info.mie-u.ac.jp>
#
# $FreeBSD$
#
-DISTNAME= rxvt-2.6.1
-PKGNAME= ja-rxvt-2.6.1
+DISTNAME= rxvt-2.7.2
+PKGNAME= ja-rxvt-2.7.2
CATEGORIES= japanese x11
MASTER_SITES= ftp://ftp.rxvt.org/pub/rxvt/
@@ -18,19 +18,24 @@ LIB_DEPENDS= Xpm.4:${PORTSDIR}/graphics/xpm
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
USE_BZIP2= yes
-MAN1= rxvt.1
+MAN1= rxvt.1 rclock.1
CONFIGURE_ARGS+=--enable-xpm-background --enable-transparency \
--enable-menubar --enable-graphics --enable-xim \
- --enable-kanji --disable-backspace-key --disable-delete-key
+ --enable-languages --with-encoding=eucj \
+ --disable-backspace-key --disable-delete-key \
+ --enable-utmp --enable-wtmp
DOCDIR= ${PREFIX}/share/doc/ja/rxvt
RXVTLIB= ${PREFIX}/lib/X11/rxvt
pre-install:
@${MKDIR} ${DOCDIR}
- @${INSTALL_MAN} ${FILESDIR}/README.ja ${DOCDIR}
+ @${INSTALL_DATA} ${FILESDIR}/README.ja ${DOCDIR}
@${MKDIR} ${RXVTLIB}
- @${INSTALL_MAN} ${FILESDIR}/ja.menu ${RXVTLIB}
- @${INSTALL_MAN} ${FILESDIR}/terminal.menu ${RXVTLIB}
+ @${INSTALL_DATA} ${FILESDIR}/ja.menu ${RXVTLIB}
+ @${INSTALL_DATA} ${FILESDIR}/terminal.menu ${RXVTLIB}
+
+post-install:
+ @${CHMOD} 4711 ${PREFIX}/bin/rxvt
.include <bsd.port.mk>
diff --git a/japanese/rxvt/distinfo b/japanese/rxvt/distinfo
index f95834a81b0b..640bb453beee 100644
--- a/japanese/rxvt/distinfo
+++ b/japanese/rxvt/distinfo
@@ -1 +1 @@
-MD5 (rxvt-2.6.1.tar.bz2) = bdbda851624a74b7f223f78402e451b4
+MD5 (rxvt-2.7.2.tar.bz2) = cce181764763ceb7c1d12a8b05c3ce2e
diff --git a/japanese/rxvt/files/patch-aa b/japanese/rxvt/files/patch-aa
index 6dc91d173432..9dc3329bde60 100644
--- a/japanese/rxvt/files/patch-aa
+++ b/japanese/rxvt/files/patch-aa
@@ -1,11 +1,11 @@
-*** Makefile.in.orig Mon Mar 29 14:31:37 1999
---- Makefile.in Mon May 10 18:00:33 1999
+*** Makefile.in.orig Tue Dec 21 19:07:54 1999
+--- Makefile.in Mon Jan 10 15:29:15 2000
***************
*** 9,15 ****
first_rule: all
dummy:
-! subdirs = src doc rclock src/graphics
+! subdirs = src doc rclock src/graphics src/test
DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
@@ -13,7 +13,7 @@
first_rule: all
dummy:
-! subdirs = src doc
+! subdirs = src doc rclock
DIST = INSTALL README.configure configure Makefile Makefile.in ChangeLog
diff --git a/japanese/rxvt/files/patch-ab b/japanese/rxvt/files/patch-ab
index 501b93a715c1..8c59d733d087 100644
--- a/japanese/rxvt/files/patch-ab
+++ b/japanese/rxvt/files/patch-ab
@@ -1,24 +1,29 @@
-*** doc/Makefile.in.orig Tue Aug 17 17:16:14 1999
---- doc/Makefile.in Sat Aug 21 00:50:02 1999
+*** doc/Makefile.in.orig Tue Sep 28 16:04:39 1999
+--- doc/Makefile.in Tue Jan 11 09:24:00 2000
***************
-*** 39,45 ****
+*** 38,47 ****
#-------------------------------------------------------------------------
-! all:
- @if test x$(TBL) = x; then : ; else echo "Making rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl > rxvt.1 ; fi
+! all: rxvt.1
+
+! rxvt.1: rxvt.tbl Makefile
+! @if test x$(TBL) = x; then : ; else echo "Making rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl > rxvt.1 ; fi
SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
---- 39,45 ----
+ -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
+--- 38,46 ----
#-------------------------------------------------------------------------
-! all: alldoc
- @if test x$(TBL) = x; then : ; else echo "Making rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl > rxvt.1 ; fi
+! all: alldoc
+
+! rxvt.1:
SEDREPLACE = -e 's%@RXVT_VERSION@%$(VERSION)%g;'\
+ -e 's%@RXVT_LSMDATE@%$(LSMDATE)%g;'\
***************
-*** 55,61 ****
+*** 56,62 ****
tags allbin:
@@ -30,34 +35,29 @@
tags allbin:
-! alldoc: rxvt.1
+! alldoc: rxvt.1 rxvt.html rxvtRef.html rxvtRef.txt
yodl/versioninfo.yo: yodl/versioninfo.yo.in ../src/version.h
$(SED) $(SEDREPLACE) < $(srcdir)/yodl/versioninfo.yo.in > $@
***************
-*** 66,82 ****
+*** 67,80 ****
rxvt.tbl: yodl/rxvt.yo $(YODL_RXVT) yodl/versioninfo.yo yodl/masonyodl.yo
- yodl2man -orxvt.tbl yodl/rxvt.yo
-
-! rxvt.1: rxvt.tbl Makefile
-! @if test x$(TBL) = x; then : ; else echo "Making rxvt.1"; $(TBL) $(srcdir)/rxvt.tbl > rxvt.1 ; fi
+ (cd $(srcdir)/yodl; yodl2man -o../rxvt.tbl rxvt.yo)
! rxvt.html: yodl/rxvt.yo $(YODL_RXVT) yodl/versioninfo.yo yodl/masonyodl.yo
-! yodl2html -o$@ yodl/rxvt.yo
+! (cd $(srcdir)/yodl; yodl2html -o../rxvt.html rxvt.yo)
! rxvtRef.html: $(YODL_RREF) yodl/rxvtRef.yo yodl/masonyodl.yo
-! yodl2html -o$@ yodl/rxvtRef.yo
+! (cd $(srcdir)/yodl; yodl2html -o../rxvtRef.html rxvtRef.yo)
! rxvtRef.txt: $(YODL_RREF) yodl/rxvtRef.yo yodl/masonyodl.yo
-! yodl2txt -o$@ yodl/rxvtRef.yo
+! (cd $(srcdir)/yodl; yodl2txt -o../rxvtRef.txt rxvtRef.yo)
clean:
$(RMF) rxvt.man *~ yodl/*~
---- 66,78 ----
+--- 66,76 ----
rxvt.tbl: yodl/rxvt.yo $(YODL_RXVT) yodl/versioninfo.yo yodl/masonyodl.yo
- yodl2man -orxvt.tbl yodl/rxvt.yo
-
-! rxvt.1:
+ (cd $(srcdir)/yodl; yodl2man -o../rxvt.tbl rxvt.yo)
! rxvt.html:
@@ -68,7 +68,7 @@
clean:
$(RMF) rxvt.man *~ yodl/*~
***************
-*** 86,93 ****
+*** 84,91 ****
distclean:
@@ -77,11 +77,11 @@
uninstall:
-cd $(mandir); $(RMF) $(manprefix)rxvt.$(manext)
---- 82,92 ----
+--- 80,90 ----
distclean:
-! install: rxvt.1 rxvt.html rxvtRef.html rxvtRef.txt
+! install: rxvt.1 rxvt.html rxvtRef.html rxvtRef.txt
! $(INSTALL_DATA) rxvt.1 $(mandir)/$(manprefix)rxvt.$(manext)
! $(INSTALL_DATA) rxvt.html $(prefix)/share/doc/ja/rxvt/rxvt.html
! $(INSTALL_DATA) rxvtRef.html $(prefix)/share/doc/ja/rxvt/rxvtRef.html
diff --git a/japanese/rxvt/files/patch-ad b/japanese/rxvt/files/patch-ad
index dddac75a6d5a..cc8ba59ffdab 100644
--- a/japanese/rxvt/files/patch-ad
+++ b/japanese/rxvt/files/patch-ad
@@ -1,7 +1,7 @@
-*** src/command.c.orig Fri Aug 13 01:32:39 1999
---- src/command.c Sat Aug 21 00:51:34 1999
+*** src/command.c.orig Sun Dec 19 12:18:03 1999
+--- src/command.c Tue Jan 11 09:25:48 2000
***************
-*** 322,328 ****
+*** 436,442 ****
ttydev = tty_name;
# define PTYCHAR1 "pqrstuvwxyz"
@@ -9,7 +9,7 @@
for (c1 = PTYCHAR1; *c1; c1++) {
ptydev[len] = ttydev[len] = *c1;
for (c2 = PTYCHAR2; *c2; c2++) {
---- 322,328 ----
+--- 436,442 ----
ttydev = tty_name;
# define PTYCHAR1 "pqrstuvwxyz"
diff --git a/japanese/rxvt/files/patch-aj b/japanese/rxvt/files/patch-aj
index 805038dadcec..c3cfa5e548de 100644
--- a/japanese/rxvt/files/patch-aj
+++ b/japanese/rxvt/files/patch-aj
@@ -1,7 +1,7 @@
-*** src/feature.h.orig Tue Aug 17 16:02:45 1999
---- src/feature.h Sat Aug 21 00:52:08 1999
+*** src/feature.h.orig Tue Dec 21 19:05:42 1999
+--- src/feature.h Tue Jan 11 09:28:32 2000
***************
-*** 153,159 ****
+*** 148,154 ****
* This has been superceded and is only for you older users
*/
/* #define HOTKEY_CTRL */
@@ -9,7 +9,7 @@
/*
* To use
---- 153,159 ----
+--- 148,154 ----
* This has been superceded and is only for you older users
*/
/* #define HOTKEY_CTRL */
@@ -18,21 +18,27 @@
/*
* To use
***************
-*** 370,377 ****
- #ifdef KANJI
- # define NFONTS 5
- # define FONT0_IDX 2
-! # define MFONT_LIST "k14", "jiskan16", "jiskan18", "jiskan24", "jiskan26"
-! # define NFONT_LIST "7x14", "8x16", "9x18", "12x24", "13x26"
+*** 390,400 ****
+ * Sizes between multi-char fonts sets (MFONT_LIST) and single-char font
+ * sets (NFONT_LIST) have been matched up
+ */
+! #define NFONTS 7
+ #define FONT0_IDX 2
+! #define NFONT_LIST "7x14", "6x10", "6x13", "8x13", "8x16", "10x20", "12x24"
+ #ifdef MULTICHAR_SET /* multichar glyph language support */
+! # define MFONT_LIST NULL, NULL, NULL, NULL, NULL, NULL, NULL
+ #endif
+
#endif
- #ifdef ZH
- # define NFONTS 5
---- 370,377 ----
- #ifdef KANJI
- # define NFONTS 5
- # define FONT0_IDX 2
+--- 390,400 ----
+ * Sizes between multi-char fonts sets (MFONT_LIST) and single-char font
+ * sets (NFONT_LIST) have been matched up
+ */
+! #define NFONTS 5
+ #define FONT0_IDX 2
+! #define NFONT_LIST "7x14", "a10", "r12", "8x16", "12x24"
+ #ifdef MULTICHAR_SET /* multichar glyph language support */
! # define MFONT_LIST "k14", "k10", "k12", "kanji16", "kanji24"
-! # define NFONT_LIST "7x14", "a10", "r12", "8x16", "12x24"
#endif
- #ifdef ZH
- # define NFONTS 5
+
+ #endif
diff --git a/japanese/rxvt/files/patch-ak b/japanese/rxvt/files/patch-ak
new file mode 100644
index 000000000000..9e5ea4843136
--- /dev/null
+++ b/japanese/rxvt/files/patch-ak
@@ -0,0 +1,36 @@
+*** autoconf/config.h.in.orig Tue Aug 17 15:55:41 1999
+--- autoconf/config.h.in Fri Sep 10 21:10:39 1999
+***************
+*** 161,167 ****
+ #undef HAVE_UTMP_HOST
+
+ /* Define location of utmp */
+! #undef RXVT_UTMP_FILE
+
+ /* Define in utmpx.h has struct utmpx */
+ #undef HAVE_STRUCT_UTMPX
+--- 161,167 ----
+ #undef HAVE_UTMP_HOST
+
+ /* Define location of utmp */
+! #define RXVT_UTMP_FILE "/var/run/utmp"
+
+ /* Define in utmpx.h has struct utmpx */
+ #undef HAVE_STRUCT_UTMPX
+***************
+*** 173,179 ****
+ #undef RXVT_UTMPX_FILE
+
+ /* Define location of wtmp */
+! #undef RXVT_WTMP_FILE
+
+ /* Define location of wtmpx */
+ #undef RXVT_WTMPX_FILE
+--- 173,179 ----
+ #undef RXVT_UTMPX_FILE
+
+ /* Define location of wtmp */
+! #define RXVT_WTMP_FILE "/var/log/wtmp"
+
+ /* Define location of wtmpx */
+ #undef RXVT_WTMPX_FILE
diff --git a/japanese/rxvt/files/patch-al b/japanese/rxvt/files/patch-al
new file mode 100644
index 000000000000..1092b8becc57
--- /dev/null
+++ b/japanese/rxvt/files/patch-al
@@ -0,0 +1,20 @@
+*** rclock/Makefile.in.orig Thu Nov 26 14:28:11 1998
+--- rclock/Makefile.in Tue Jan 11 10:00:16 2000
+***************
+*** 25,32 ****
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(XINC) -I. -I$(basedir) -I$(srcdir) $(DEFS) $(CFLAGS) $<
+ #-------------------------------------------------------------------------
+! all:
+! clock: alldoc allbin
+
+ rclock: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XLIB)
+--- 25,31 ----
+ .c.o:
+ $(CC) -c $(CPPFLAGS) $(XINC) -I. -I$(basedir) -I$(srcdir) $(DEFS) $(CFLAGS) $<
+ #-------------------------------------------------------------------------
+! all: alldoc allbin
+
+ rclock: $(OBJS)
+ $(CC) $(LDFLAGS) -o $@ $(OBJS) $(LIBS) $(XLIB)
diff --git a/japanese/rxvt/files/patch-am b/japanese/rxvt/files/patch-am
new file mode 100644
index 000000000000..7c126a228e11
--- /dev/null
+++ b/japanese/rxvt/files/patch-am
@@ -0,0 +1,293 @@
+*** rclock/rclock.c.orig Mon Apr 20 16:31:04 1998
+--- rclock/rclock.c Tue Jan 11 09:50:48 2000
+***************
+*** 69,74 ****
+--- 69,89 ----
+
+ #include <X11/Intrinsic.h> /* Xlib, Xutil, Xresource, Xfuncproto */
+
++ #ifndef NO_XLOCALE
++ # if (XtSpecificationRelease < 6)
++ # define NO_XLOCALE
++ # endif
++ #endif
++
++ #ifndef NO_XSETLOCALE
++ # define X_LOCALE
++ # include <X11/Xlocale.h>
++ #else
++ # ifndef NO_SETLOCALE
++ # include <locale.h>
++ # endif
++ #endif /* NO_XLOCALE */
++
+ #define APL_CLASS "Clock"
+ #define APL_NAME "rclock"
+ #define MSG_CLASS "Appointment"
+***************
+*** 122,129 ****
+--- 137,150 ----
+ int width, height;
+ } msgButton;
+
++ #ifdef MULTICHAR_SET
++ static XFontSet Xfont;
++ static XFontSetExtents *extent;
++ #define FontHeight() ((extent->max_logical_extent.height)*4/5 + (extent->max_logical_extent.height)/5)
++ #else
+ static XFontStruct * Xfont;
+ #define FontHeight() (Xfont->ascent + Xfont->descent)
++ #endif
+ static int Msg_Mapped = 0; /* message window mapped? */
+ static int reminderTime = -1;
+ static char message [256] = "";
+***************
+*** 184,189 ****
+--- 205,216 ----
+ #define REPLACE 0
+ #define UPDATE 1
+
++ /* subroutine for MULTICHAR_SET declarations */
++ #ifdef MULTICHAR_SET
++ static XFontSet XLoadQueryFontSet(Display *, const char *);
++ #define XFreeFont XFreeFontSet
++ #define XTextWidth XmbTextEscapement
++ #endif
+ /*----------------------------------------------------------------------*/
+
+ static void
+***************
+*** 201,206 ****
+--- 228,236 ----
+ { "-fg color", "foreground color" },
+ #ifdef REMINDERS
+ { "-fn fontname", "normal font for messages" },
++ #ifdef MULTICHAR_SET
++ { "-fm fontname", "multibyte font for messages" },
++ #endif /* MULTICHAR_SET */
+ #endif
+ #ifdef ICONWIN
+ { "-iconic", "start iconic" },
+***************
+*** 277,283 ****
+--- 307,317 ----
+ XGCValues gcv;
+
+ #ifdef REMINDERS
++ #ifndef MULTICHAR_SET
+ const char * rs_font = FONT_NAME;
++ #else
++ char rs_font[BUFSIZ];
++ #endif /* MULTICHAR_SET */
+
+ /* find the ~/.rclock file */
+ if ((val = getenv ("HOME")) != NULL)
+***************
+*** 314,319 ****
+--- 348,356 ----
+ if ((display_name = getenv ("DISPLAY")) == NULL)
+ display_name = ":0";
+
++ #ifdef MULTICHAR_SET
++ rs_font[0] = '\0';
++ #endif /* MULTICHAR_SET */
+ /* parse the command line */
+ for (i = 1; i < argc; i += 2)
+ {
+***************
+*** 345,351 ****
+--- 382,401 ----
+ else if (!strcmp (opt, "fg")) rs_color [fgColor] = val;
+ else if (!strcmp (opt, "bg")) rs_color [bgColor] = val;
+ #ifdef REMINDERS
++ #ifndef MULTICHAR_SET
+ else if (!strcmp (opt, "fn")) rs_font = val;
++ #else
++ else if (!strcmp (opt, "fn"))
++ {
++ strncat(rs_font, val, BUFSIZ);
++ strncat(rs_font, ",", BUFSIZ);
++ }
++ else if (!strcmp (opt, "fm"))
++ {
++ strncat(rs_font, val, BUFSIZ);
++ strncat(rs_font, ",", BUFSIZ);
++ }
++ #endif /* MULTICHAR_SET */
+ #endif
+ else if (!strcmp (opt, "update"))
+ {
+***************
+*** 384,389 ****
+--- 434,449 ----
+ }
+ }
+
++ #ifdef MULTICHAR_SET
++ if (strlen(rs_font) > 0) rs_font[strlen(rs_font) - 1] = '\0';
++ else strncpy(rs_font, FONT_NAME, BUFSIZ);
++ #endif /* MULTICHAR_SET */
++
++ #if !defined(NO_XSETLOCALE) || !defined(NO_SETLOCALE)
++ /* set locale */
++ setlocale(LC_CTYPE, "");
++ #endif
++
+ /* open display */
+ Xdisplay = XOpenDisplay (display_name);
+ if (!Xdisplay)
+***************
+*** 418,430 ****
+--- 478,499 ----
+
+ #ifdef REMINDERS
+ /* load the font for messages */
++ #ifdef MULTICHAR_SET
++ if ((Xfont = XLoadQueryFontSet (Xdisplay, rs_font)) == NULL)
++ #else
+ if ((Xfont = XLoadQueryFont (Xdisplay, rs_font)) == NULL)
++ #endif /* MULTICHAR_SET */
+ {
+ print_error ("can't load font \"%s\"", rs_font);
+ goto Abort;
+ }
++ #ifndef MULTICHAR_SET
+ gcv.font = Xfont->fid;
++ #endif /* MULTICHAR_SET */
+ #endif
++ #ifdef MULTICHAR_SET
++ extent = XExtentsOfFontSet(Xfont);
++ #endif /* MULTICHAR_SET */
+
+ Create_Windows (argc, argv);
+ /* Create the graphics contexts */
+***************
+*** 433,439 ****
+--- 502,510 ----
+
+ Xgc = XCreateGC (Xdisplay, Clock.win,
+ #ifdef REMINDERS
++ #ifndef MULTICHAR_SET
+ GCFont |
++ #endif /* MULTICHAR_SET */
+ #endif
+ GCForeground | GCBackground, &gcv);
+
+***************
+*** 441,447 ****
+ gcv.background = PixColors [fgColor];
+ Xrvgc = XCreateGC (Xdisplay, Clock.win,
+ #ifdef REMINDERS
+! GCFont |
+ #endif
+ GCForeground | GCBackground, &gcv);
+
+--- 512,520 ----
+ gcv.background = PixColors [fgColor];
+ Xrvgc = XCreateGC (Xdisplay, Clock.win,
+ #ifdef REMINDERS
+! #ifndef MULTICHAR_SET
+! GCFont |
+! #endif /* MULTICHAR_SET */
+ #endif
+ GCForeground | GCBackground, &gcv);
+
+***************
+*** 806,836 ****
+--- 879,941 ----
+ next = end + 2;
+ }
+
++ #ifdef MULTICHAR_SET
++ XmbDrawString (Xdisplay, Msg.win, Xfont,
++ #else
+ XDrawString (Xdisplay, Msg.win,
++ #endif /* MULTICHAR_SET */
+ Xgc,
+ (Msg.width -
+ XTextWidth (Xfont, beg, (end-beg))) / 2,
++ #ifdef MULTICHAR_SET
++ 10 + extent->max_logical_extent.height*4/5 + FontHeight () * lines,
++ #else
+ 10 + Xfont->ascent + FontHeight () * lines,
++ #endif /* MULTICHAR_SET */
+ beg, (end-beg));
+ }
+
++ #ifdef MULTICHAR_SET
++ XmbDrawString (Xdisplay, msgButton.Dismiss, Xfont,
++ #else
+ XDrawString (Xdisplay, msgButton.Dismiss,
++ #endif /* MULTICHAR_SET */
+ Xrvgc,
+ (msgButton.width - XTextWidth (Xfont, "Done", 4)) / 2,
++ #ifdef MULTICHAR_SET
++ extent->max_logical_extent.height*4/5 + 2,
++ #else
+ Xfont->ascent + 2,
++ #endif /* MULTICHAR_SET */
+ "Done", 4);
+
++ #ifdef MULTICHAR_SET
++ XmbDrawString (Xdisplay, msgButton.Defer, Xfont,
++ #else
+ XDrawString (Xdisplay, msgButton.Defer,
++ #endif /* MULTICHAR_SET */
+ Xrvgc,
+ (msgButton.width - XTextWidth (Xfont, "Defer", 5)) / 2,
++ #ifdef MULTICHAR_SET
++ extent->max_logical_extent.height*4/5 + 2,
++ #else
+ Xfont->ascent + 2,
++ #endif /* MULTICHAR_SET */
+ "Defer", 5);
+
+ # ifndef NO_REMINDER_EXEC
++ #ifdef MULTICHAR_SET
++ XmbDrawString (Xdisplay, msgButton.Start, Xfont,
++ #else
+ XDrawString (Xdisplay, msgButton.Start,
++ #endif /* MULTICHAR_SET */
+ Xrvgc,
+ (msgButton.width - XTextWidth (Xfont, "Start", 5)) / 2,
++ #ifdef MULTICHAR_SET
++ extent->max_logical_extent.height*4/5 + 2,
++ #else
+ Xfont->ascent + 2,
++ #endif /* MULTICHAR_SET */
+ "Start", 5);
+
+ if (strlen (execPrgm) > 1)
+***************
+*** 1469,1472 ****
+--- 1574,1603 ----
+ fprintf (stderr,"\n");
+ va_end (arg_ptr);
+ }
++
++ #ifdef MULTICHAR_SET
++ /*
++ * XLoadQueryFontSet
++ */
++ XFontSet XLoadQueryFontSet(Display *disp, const char *fontset_name)
++ {
++ XFontSet fontset;
++ int missing_charset_count;
++ char **missing_charset_list;
++ char *def_string;
++
++ fontset = XCreateFontSet(disp, fontset_name,
++ &missing_charset_list,
++ &missing_charset_count,
++ &def_string);
++ /*
++ if (missing_charset_count) {
++ fprintf(stderr, "Missing charsets in FontSet(%s) creation.\n",
++ fontset_name);
++ XFreeStringList(missing_charset_list);
++ }
++ */
++ return fontset;
++ }
++ #endif /* MULTICHAR_SET */
+ /*----------------------- end-of-file (C source) -----------------------*/
diff --git a/japanese/rxvt/files/patch-an b/japanese/rxvt/files/patch-an
new file mode 100644
index 000000000000..99717ab6a02d
--- /dev/null
+++ b/japanese/rxvt/files/patch-an
@@ -0,0 +1,19 @@
+*** src/rxvt.h.orig Sat Dec 18 16:41:47 1999
+--- src/rxvt.h Tue Jan 11 20:59:24 2000
+***************
+*** 247,253 ****
+ # define COLORTERMENVFULL COLORTERMENV
+ #endif
+ #ifndef TERMENV
+! # ifdef KANJI
+ # define TERMENV "kterm"
+ # else
+ # define TERMENV "xterm"
+--- 247,253 ----
+ # define COLORTERMENVFULL COLORTERMENV
+ #endif
+ #ifndef TERMENV
+! # if MULTICHAR_ENCODING == EUCJ || MULTICHAR_ENCODING == SJIS
+ # define TERMENV "kterm"
+ # else
+ # define TERMENV "xterm"
diff --git a/japanese/rxvt/pkg-plist b/japanese/rxvt/pkg-plist
index 51f6f6e6cd66..cc459259e50f 100644
--- a/japanese/rxvt/pkg-plist
+++ b/japanese/rxvt/pkg-plist
@@ -1,9 +1,11 @@
bin/rxvt
+@exec chmod 4711 %D/bin/rxvt
share/doc/ja/rxvt/README.ja
share/doc/ja/rxvt/rxvt.html
share/doc/ja/rxvt/rxvtRef.html
share/doc/ja/rxvt/rxvtRef.txt
lib/X11/rxvt/ja.menu
lib/X11/rxvt/terminal.menu
+bin/rclock
@dirrm share/doc/ja/rxvt
@dirrm lib/X11/rxvt