aboutsummaryrefslogtreecommitdiff
path: root/japanese/w3/Makefile
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-01-04 13:19:40 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-01-04 13:19:40 +0000
commit7d49caae5a3ebd8bc6fc4d9fbec6e0d55161d95f (patch)
treefba913f3864edc0fb342ef497e8989528b13c2ff /japanese/w3/Makefile
parentf0bc728d03d09aadd1b727c933b058d9b0d47b4d (diff)
downloadports-7d49caae5a3ebd8bc6fc4d9fbec6e0d55161d95f.tar.gz
ports-7d49caae5a3ebd8bc6fc4d9fbec6e0d55161d95f.zip
Rename files/.{emacs,mosaic-hotlist-default} to
dot.{emacs,mosaic-hotlist-default}. Install sample files into share/examples/w3 instead of to share/doc/w3. Use PKG_PREFIX in the installation/deinstallation scripts. Some Makefile cleanup. Submitted by: (Kiriyama Kazuhiko) <kiri@kiri.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=5204
Diffstat (limited to 'japanese/w3/Makefile')
-rw-r--r--japanese/w3/Makefile18
1 files changed, 10 insertions, 8 deletions
diff --git a/japanese/w3/Makefile b/japanese/w3/Makefile
index e12ab5b29dab..43bacd12a31f 100644
--- a/japanese/w3/Makefile
+++ b/japanese/w3/Makefile
@@ -1,9 +1,9 @@
# New ports collection makefile for: w3 on Mule
# Version required: 2.2.26
-# Date created: 30 November 1996
+# Date created: 31 December 1996
# Whom: MITA Yoshio <mita@ee.t.u-tokyo.ac.jp>
#
-# $Id$
+# $Id: Makefile,v 1.2 1997/01/04 00:39:53 max Exp $
#
DISTNAME= w3-2.2.26
@@ -22,18 +22,20 @@ BUILD_DEPENDS= mule:${PORTSDIR}/editors/mule
WRKSRC= ${WRKDIR}/w3
DOCDIR= ${PREFIX}/share/doc/w3
+SAMPLEDIR= ${PREFIX}/share/examples/w3
post-install:
.if !defined(NOPORTDOCS)
- @if [ ! -d ${DOCDIR} ]; then mkdir -p ${DOCDIR}; fi
-.for f in .emacs .mosaic-hotlist-default
- @${CP} ${FILESDIR}/${f} ${DOCDIR}
+ @${MKDIR} ${DOCDIR}
+ @${MKDIR} ${SAMPLEDIR}
+.for f in dot.emacs dot.mosaic-hotlist-default
+ @${INSTALL_DATA} ${FILESDIR}/${f} ${SAMPLEDIR}
.endfor
- @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${DOCDIR}
+ @${INSTALL_SCRIPT} ${FILESDIR}/user-install ${SAMPLEDIR}
.for f in W3.ad clean-cache Makefile w3.txi
- @${CP} ${WRKSRC}/${f} ${DOCDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${f} ${DOCDIR}
.endfor
.endif
- @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+ @${SETENV} PKG_PREFIX=${PREFIX} /bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
.include <bsd.port.mk>