aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-30 20:42:44 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-11-30 20:42:44 +0000
commit9001772ee304c4fa9df002a94503953211447f6e (patch)
tree30096cdc548b995f4ed809a74c86675e21bb26b6 /japanese
parent166b72fcb42a620e31d522bf793b362e9f8ec3b6 (diff)
downloadports-9001772ee304c4fa9df002a94503953211447f6e.tar.gz
ports-9001772ee304c4fa9df002a94503953211447f6e.zip
- Fix fetch
- Fix endianes detection - Pass maintainership to submitter PR: 204801 Submitted by: CQG00620@nifty.ne.jp
Notes
Notes: svn path=/head/; revision=402698
Diffstat (limited to 'japanese')
-rw-r--r--japanese/today/Makefile7
-rw-r--r--japanese/today/files/patch-cunix.h39
2 files changed, 38 insertions, 8 deletions
diff --git a/japanese/today/Makefile b/japanese/today/Makefile
index 50995ba6f7d4..c31588e09baa 100644
--- a/japanese/today/Makefile
+++ b/japanese/today/Makefile
@@ -3,17 +3,16 @@
PORTNAME= today
PORTVERSION= 2.12
+PORTREVISION= 1
CATEGORIES= japanese games
-MASTER_SITES= http://ftp.vector.co.jp/pack/dos/personal/calendar/today/
+MASTER_SITES= http://ftp.vector.co.jp/29/42/476/
DISTNAME= ja-${PORTNAME}-${PORTVERSION}
DISTFILES= td${PORTVERSION:S/.//}s.lzh \
td${PORTVERSION:S/.//}m.lzh
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= CQG00620@nifty.ne.jp
COMMENT= Tells you what day today is
-BROKEN= unfetchable
-
EXTRACT_DEPENDS=nkf:${PORTSDIR}/japanese/nkf
NO_WRKSUBDIR= yes
diff --git a/japanese/today/files/patch-cunix.h b/japanese/today/files/patch-cunix.h
index 8bf40f51857a..fe2e4b4e48a0 100644
--- a/japanese/today/files/patch-cunix.h
+++ b/japanese/today/files/patch-cunix.h
@@ -1,6 +1,17 @@
---- cunix.h.orig 2011-04-16 21:25:44.000000000 +0900
-+++ cunix.h 2011-04-16 21:27:40.000000000 +0900
-@@ -40,7 +40,9 @@
+--- cunix.h.orig 2015-11-23 17:47:06.000000000 +0900
++++ cunix.h 2015-11-23 17:49:27.000000000 +0900
+@@ -29,6 +29,10 @@
+ #include <termcap.h>
+ #endif
+
++#if defined(__FreeBSD__)
++#include <sys/endian.h>
++#endif
++
+ #define _T_EUC /* EUC 漢字コード */
+
+ #define _T_MAXROWS 24 /* 画面行数 */
+@@ -40,7 +44,9 @@
#define _T_TMPENV "TEMP" /* temporary 環境変数名 */
#define _T_TMPENV2 "TMPDIR" /* temporary 環境変数名 */
#define _T_TMPDIR "/tmp" /* temporary directory */
@@ -10,7 +21,27 @@
/* default search path list */
#define _T_HOMEENV "HOME" /* home 環境変数 */
#define _T_PATHENV "PATH" /* path 環境変数名 */
-@@ -60,7 +62,7 @@
+@@ -50,6 +56,15 @@
+ /* path name of executed command */
+ #define _T_EXECCMDPATH "ExecCmdPath" /* $ExecCmdPath => search_cmdpath */
+ #define _T_OPENFLAG (O_RDONLY)
++#if defined(__FreeBSD__)
++#if _BYTE_ORDER == _LITTLE_ENDIAN
++#define _T_LITTLE_ENDIAN
++#define _T_LITTLE_ENDIAN_BITFIELD
++#else
++#define _T_BIG_ENDIAN
++#define _T_BIG_ENDIAN_BITFIELD
++#endif
++#else
+ #if defined(i386)
+ #define _T_LITTLE_ENDIAN
+ #define _T_LITTLE_ENDIAN_BITFIELD
+@@ -57,10 +72,11 @@
+ #define _T_BIG_ENDIAN
+ #define _T_BIG_ENDIAN_BITFIELD
+ #endif
++#endif
#define _T_OUTFILE_DEFAULT "%c%y%m%d.today"
#define _T_OUTFILE_TMPNAME "%p.today"