aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-12-27 16:15:07 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2007-12-27 16:15:07 +0000
commit6fa2ba537e1af81f081d29a076834d9e89ae649c (patch)
treed34a7c78b463b667db6089031f65e973f93c60a0 /japanese
parentdb3cdbe2da7b3fbee84903238c28a2239ae574c9 (diff)
downloadports-6fa2ba537e1af81f081d29a076834d9e89ae649c.tar.gz
ports-6fa2ba537e1af81f081d29a076834d9e89ae649c.zip
Fix build with gcc 4.2.
Notes
Notes: svn path=/head/; revision=204618
Diffstat (limited to 'japanese')
-rw-r--r--japanese/ebview/Makefile4
-rw-r--r--japanese/ebview/files/patch-src_eb.c10
-rw-r--r--japanese/ebview/files/patch-src_websearch.c10
3 files changed, 20 insertions, 4 deletions
diff --git a/japanese/ebview/Makefile b/japanese/ebview/Makefile
index 2a01cabd8b41..8d2eec087e4a 100644
--- a/japanese/ebview/Makefile
+++ b/japanese/ebview/Makefile
@@ -33,10 +33,6 @@ LDFLAGS= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 700042
-BROKEN= Broken with gcc 4.2
-.endif
-
pre-build:
.for file in src/dictheading.c
cd ${WRKSRC} && ${MV} ${file} ${file}.pre_iconv \
diff --git a/japanese/ebview/files/patch-src_eb.c b/japanese/ebview/files/patch-src_eb.c
new file mode 100644
index 000000000000..fc598b12a084
--- /dev/null
+++ b/japanese/ebview/files/patch-src_eb.c
@@ -0,0 +1,10 @@
+--- src/eb.c.orig 2007-12-28 00:09:02.000000000 +0900
++++ src/eb.c 2007-12-28 00:22:34.000000000 +0900
+@@ -48,7 +48,6 @@
+ static GtkWidget *label_match;
+ static GtkWidget *progress;
+ static pthread_t tid;
+-static gint tag_timeout;
+ static gint thread_running = 0;
+ static gint hit_count=0;
+ static gfloat search_progress;
diff --git a/japanese/ebview/files/patch-src_websearch.c b/japanese/ebview/files/patch-src_websearch.c
new file mode 100644
index 000000000000..d894a42e2889
--- /dev/null
+++ b/japanese/ebview/files/patch-src_websearch.c
@@ -0,0 +1,10 @@
+--- src/websearch.c.orig 2007-12-28 00:10:21.000000000 +0900
++++ src/websearch.c 2007-12-28 00:28:26.000000000 +0900
+@@ -33,7 +33,6 @@
+ void web_search();
+ void split_word(gchar *word, gchar **keywords);
+
+-static GtkWidget *web_tree;
+ static GtkCTreeNode *current_node;
+ static GtkItemFactory *tree_item_factory;
+ static GtkItemFactoryEntry tree_menu_items[] = {