aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2000-08-27 06:13:35 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2000-08-27 06:13:35 +0000
commit939eab9dd083f1ded04b0cee7244d050e4260d2a (patch)
tree535eb5cc0b733088584c84d1c018df3c8376f98d /japanese
parentefab284842059f46927b31ae9f4346817ec1a98d (diff)
downloadports-939eab9dd083f1ded04b0cee7244d050e4260d2a.tar.gz
ports-939eab9dd083f1ded04b0cee7244d050e4260d2a.zip
PKGNAMEPREFIX cleanup. This should allow chained PKGNAMEPREFIX'es.
No response from: ports list, PW
Notes
Notes: svn path=/head/; revision=32029
Diffstat (limited to 'japanese')
-rw-r--r--japanese/Makefile.inc6
-rw-r--r--japanese/kebook/Makefile40
-rw-r--r--japanese/p5-Jcode/Makefile7
-rw-r--r--japanese/p5-Text-Kakasi/Makefile7
-rw-r--r--japanese/p5-jcode.pl/Makefile7
-rw-r--r--japanese/p5-manual/Makefile7
-rw-r--r--japanese/p5-mkres/Makefile9
-rw-r--r--japanese/p5-nkf/Makefile9
-rw-r--r--japanese/ruby-uconv/Makefile7
9 files changed, 40 insertions, 59 deletions
diff --git a/japanese/Makefile.inc b/japanese/Makefile.inc
index 03383ebd6a28..3873da50fcb9 100644
--- a/japanese/Makefile.inc
+++ b/japanese/Makefile.inc
@@ -1,4 +1,8 @@
# $FreeBSD$
#
-PKGNAMEPREFIX?= ja-
+.if defined(PKGNAMEPREFIX)
+PKGNAMEPREFIX:= ja-${PKGNAMEPREFIX}
+.else
+PKGNAMEPREFIX= ja-
+.endif
diff --git a/japanese/kebook/Makefile b/japanese/kebook/Makefile
index eb527c31e7ab..c7bb61dab7a0 100644
--- a/japanese/kebook/Makefile
+++ b/japanese/kebook/Makefile
@@ -5,54 +5,52 @@
# $FreeBSD$
#
-PORTNAME= kebook
-PORTVERSION= 0.3.5
-CATEGORIES= japanese kde
-MASTER_SITES= http://www.os.rim.or.jp/~s_mitu/library/kebook/ \
+PORTNAME= kebook
+PORTVERSION= 0.3.5
+CATEGORIES= japanese kde
+MASTER_SITES= http://www.os.rim.or.jp/~s_mitu/library/kebook/ \
ftp://ftp.kde.gr.jp/pub/kde/unstable/contrib/
-PKGNAMEPREFIX= ja-
-PKGNAMESUFFIX= -i18n
+PKGNAMESUFFIX= -i18n
-MAINTAINER= hige@higesoft.os.rim.or.jp
+MAINTAINER= hige@higesoft.os.rim.or.jp
-LIB_DEPENDS= qti18n.3:${PORTSDIR}/x11-toolkits/qt-i18n \
+LIB_DEPENDS= qti18n.3:${PORTSDIR}/x11-toolkits/qt-i18n \
kdecore.2:${PORTSDIR}/x11/kdelibs11-i18n \
kfm.2:${PORTSDIR}/x11/kdebase11-i18n \
eb.3:${PORTSDIR}/japanese/eb
+BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
-BUILD_DEPENDS= msgfmt:${PORTSDIR}/devel/gettext
+USE_BZIP2= yes
+USE_GMAKE= yes
+USE_NEWGCC= yes
+USE_LIBTOOL= yes
-USE_BZIP2= yes
-USE_GMAKE= yes
-USE_NEWGCC= yes
-USE_LIBTOOL= yes
-
-CONFIGURE_ARGS= "--with-qt-dir=${QTDIR}" \
+CONFIGURE_ARGS= "--with-qt-dir=${QTDIR}" \
"--with-qt-includes=${QTDIR}/include/X11/qt" \
"--with-qt-libraries=${QTDIR}/lib" \
"--with-eb-includes=${LOCALBASE}/include" \
"--with-eb-libraries=${LOCALBASE}/lib" \
"--with-extra-includes=${LOCALBASE}/include" \
"--with-extra-libs=${LOCALBASE}/lib"
-CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include \
LDFLAGS=-L${LOCALBASE}/lib \
QTDIR=${QTDIR}
-CXXFLAGS?= ${CFLAGS}
+CXXFLAGS?= ${CFLAGS}
-DOCDIR= share/apps/kebook/doc
+DOCDIR= share/apps/kebook/doc
PLIST_SUB= DOCDIR=${DOCDIR}
.if defined(PREFIX)
-QTDIR?= ${PREFIX}
+QTDIR?= ${PREFIX}
.else
-QTDIR?= ${X11BASE}
+QTDIR?= ${X11BASE}
.endif
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 400020 || ( ${OSVERSION} >= 500000 && ${OSVERSION} < 500005 )
-CONFIGURE_ENV+= X_EXTRA_LIBS="-lxpg4"
+CONFIGURE_ENV+= X_EXTRA_LIBS="-lxpg4"
.endif
post-install:
diff --git a/japanese/p5-Jcode/Makefile b/japanese/p5-Jcode/Makefile
index b8b9a3862ede..3e8f0df05a7c 100644
--- a/japanese/p5-Jcode/Makefile
+++ b/japanese/p5-Jcode/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 0.60
CATEGORIES= japanese perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= ../../authors/id/D/DA/DANKOGAI
+PKGNAMEPREFIX= p5-
MAINTAINER= kuriyama@FreeBSD.org
@@ -23,10 +24,6 @@ MAN3= Jcode.3 Jcode::Unicode.3 Jcode::Unicode::Constants.3 \
Jcode::Unicode::NoXS.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
CC="${CC}" CCFLAGS="${CFLAGS}"
@@ -35,4 +32,4 @@ do-configure:
${PERL} -pi -e "s:CC = cc:CC = ${CC}:g" ${WRKSRC}/${DIR}/Makefile
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/p5-Text-Kakasi/Makefile b/japanese/p5-Text-Kakasi/Makefile
index e3c701b83fb9..2dc0b10ae4a3 100644
--- a/japanese/p5-Text-Kakasi/Makefile
+++ b/japanese/p5-Text-Kakasi/Makefile
@@ -9,6 +9,7 @@ PORTNAME= Text-Kakasi
PORTVERSION= 1.04
CATEGORIES= japanese perl5
MASTER_SITES= http://www.daionet.gr.jp/~knok/kakasi/
+PKGNAMEPREFIX= p5-
MAINTAINER= knu@FreeBSD.org
@@ -19,12 +20,8 @@ USE_PERL5= yes
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Text::Kakasi.3
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
CC="${CC}" CCFLAGS="${CFLAGS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/p5-jcode.pl/Makefile b/japanese/p5-jcode.pl/Makefile
index 469d61a1d8b4..a59dd669e487 100644
--- a/japanese/p5-jcode.pl/Makefile
+++ b/japanese/p5-jcode.pl/Makefile
@@ -10,6 +10,7 @@ PORTVERSION= 2.11
CATEGORIES= japanese perl5
MASTER_SITES= ftp://ftp.iij.ad.jp/pub/IIJ/dist/utashiro/perl/ \
ftp://ftp.sra.co.jp/pub/lang/perl/sra-scripts/
+PKGNAMEPREFIX= p5-
EXTRACT_SUFX= # none
MAINTAINER= sada@FreeBSD.org
@@ -25,12 +26,8 @@ PLIST_SUB= INSTALL_BASE=${INSTALL_BASE}
INSTALL_BASE= lib/perl5/site_perl/${PERL_VER}
INSTALL_DIR= ${PREFIX}/${INSTALL_BASE}
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
do-install:
${MKDIR} ${INSTALL_DIR}
${INSTALL_DATA} ${WRKDIR}/${DISTNAME} ${INSTALL_DIR}/jcode.pl
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/p5-manual/Makefile b/japanese/p5-manual/Makefile
index 4a57ade2665d..4b5943cfa320 100644
--- a/japanese/p5-manual/Makefile
+++ b/japanese/p5-manual/Makefile
@@ -9,6 +9,7 @@ PORTNAME= man
PORTVERSION= 5.000
CATEGORIES= japanese perl5
MASTER_SITES= ftp://ftp.sra.co.jp/pub/lang/perl/
+PKGNAMEPREFIX= p5-
DISTNAME= perl${PORTVERSION}${PORTNAME}-j
MAINTAINER= sada@FreeBSD.org
@@ -29,10 +30,6 @@ CAT3= Abbrev.3pm AnyDBMFile.3pm AutoLoader.3pm AutoSplit.3pm \
Open2.3pm Open3.3pm POSIX.3pm Ping.3pm Socket.3pm \
integer.3pm less.3pm sigtrap.3pm strict.3pm subs.3pm
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
post-extract:
@cd ${WRKDIR} && ${EXTRACT_CMD} ${EXTRACT_BEFORE_ARGS} \
perl5man.tgz ${EXTRACT_AFTER_ARGS}
@@ -49,7 +46,7 @@ do-install:
.endfor
.endfor
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
plist:
@${ECHO} -n >${PLIST}
diff --git a/japanese/p5-mkres/Makefile b/japanese/p5-mkres/Makefile
index 25f08e3351ee..e027722fb1fd 100644
--- a/japanese/p5-mkres/Makefile
+++ b/japanese/p5-mkres/Makefile
@@ -9,8 +9,9 @@ PORTNAME= mkres
PORTVERSION= 1.4
CATEGORIES= japanese perl5
MASTER_SITES= http://ftp.infonets.hiroshima-u.ac.jp/~taoka/FreeBSD/tt/
-EXTRACT_SUFX= # none
+PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}.pl-${PORTVERSION}
+EXTRACT_SUFX= # none
MAINTAINER= taoka@FreeBSD.org
@@ -19,10 +20,6 @@ RUN_DEPENDS= mkttfdir:${PORTSDIR}/print/perlftlib
USE_PERL5= yes
NO_WRKSUBDIR= yes
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
do-extract:
@${RM} -rf ${WRKDIR}
@${MKDIR} ${WRKDIR}
@@ -39,4 +36,4 @@ do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME} \
${PREFIX}/bin/mkres.pl
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/p5-nkf/Makefile b/japanese/p5-nkf/Makefile
index a1c5e6fb82ad..4dbbe86515e4 100644
--- a/japanese/p5-nkf/Makefile
+++ b/japanese/p5-nkf/Makefile
@@ -11,8 +11,9 @@ CATEGORIES= japanese perl5
MASTER_SITES= ftp://ftp.ie.u-ryukyu.ac.jp/pub/software/kono/ \
ftp://ftp.win.ne.jp/pub/misc/ \
ftp://ftp.eos.hokudai.ac.jp/pub/tools/code-conv/nkf/
-EXTRACT_SUFX= .shar
+PKGNAMEPREFIX= p5-
DISTNAME= ${PORTNAME}171
+EXTRACT_SUFX= .shar
MAINTAINER= max@FreeBSD.org
@@ -25,12 +26,8 @@ WRKSRC= ${WRKDIR}/NKF
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= NKF.3
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}p5-
-
do-configure:
@cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
CC="${CC}" CCFLAGS="${CFLAGS}"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/japanese/ruby-uconv/Makefile b/japanese/ruby-uconv/Makefile
index c9a9cf73b538..451990937b84 100644
--- a/japanese/ruby-uconv/Makefile
+++ b/japanese/ruby-uconv/Makefile
@@ -11,6 +11,7 @@ CATEGORIES= japanese converters ruby
MASTER_SITES= ${MASTER_SITE_LOCAL} \
http://www.bekkoame.ne.jp/~yoshidam/
MASTER_SITE_SUBDIR= knu
+PKGNAMEPREFIX= ruby-
DIST_SUBDIR= ruby
MAINTAINER= knu@FreeBSD.org
@@ -30,10 +31,6 @@ RUBY_ARCH= ${ARCH}-freebsd${OSREL}
EXAMPLES= euc2unicode.rb test_euc.txt test_euc.xml \
trilang.xml unicode2euc.rb xmlconv.rb
-.include <bsd.port.pre.mk>
-
-PKGNAMEPREFIX:= ${PKGNAMEPREFIX}ruby-
-
do-configure:
@cd ${WRKSRC}; \
${SETENV} ${CONFIGURE_ENV} ${RUBY} extconf.rb
@@ -49,4 +46,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/README.ja ${PREFIX}/share/doc/ruby/uconv/ja/
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>