aboutsummaryrefslogtreecommitdiff
path: root/japanese
diff options
context:
space:
mode:
authorSatoshi Asami <asami@FreeBSD.org>1996-12-12 08:36:15 +0000
committerSatoshi Asami <asami@FreeBSD.org>1996-12-12 08:36:15 +0000
commitaf38939c17267a3a8b213aabeb4eefd78c4ac1b7 (patch)
tree24b0a09b48f4331ba8e704b09d6149d01ad4b1dd /japanese
parent1f6da1ca4a18626ba25f0bb42e3bce26a50d85bb (diff)
downloadports-af38939c17267a3a8b213aabeb4eefd78c4ac1b7.tar.gz
ports-af38939c17267a3a8b213aabeb4eefd78c4ac1b7.zip
Upgrade, 1.0 -> 1.1. Many bugs fixed in jcatman, etc.
Original by: KUMANO Tadashi <kumano@strl.nhk.or.jp> Submitted by: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
Notes
Notes: svn path=/head/; revision=4963
Diffstat (limited to 'japanese')
-rw-r--r--japanese/man/Makefile6
-rw-r--r--japanese/man/distinfo2
-rw-r--r--japanese/man/files/patch-aa211
3 files changed, 4 insertions, 215 deletions
diff --git a/japanese/man/Makefile b/japanese/man/Makefile
index 1ac20be0a61a..15dcd58d8af2 100644
--- a/japanese/man/Makefile
+++ b/japanese/man/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: jman - japanese man with EUC
-# Version required: 1.0
+# Version required: 1.1
# Date created: 4 December 1996
# Whom: Kiriyama Kazuhiko <kiri@kiri.toba-cmt.ac.jp>
#
-# $Id: Makefile,v 1.1.1.1 1996/12/07 13:24:00 asami Exp $
+# $Id: Makefile,v 1.2 1996/12/07 23:15:48 asami Exp $
#
-DISTNAME= jp-man-1.0
+DISTNAME= jp-man-1.1
CATEGORIES= japanese
MASTER_SITES= ftp://ftp.noc.titech.ac.jp/pub/tmp/aki/in.coming/PORTS/
diff --git a/japanese/man/distinfo b/japanese/man/distinfo
index b795161beede..406c3aebe13c 100644
--- a/japanese/man/distinfo
+++ b/japanese/man/distinfo
@@ -1 +1 @@
-MD5 (jp-man-1.0.tar.gz) = 14fbdb302d5586dbafe8959448d9dcf2
+MD5 (jp-man-1.1.tar.gz) = 4ec5c236767b3d2117bb4ccd5e76f8ed
diff --git a/japanese/man/files/patch-aa b/japanese/man/files/patch-aa
deleted file mode 100644
index 078e1e57c518..000000000000
--- a/japanese/man/files/patch-aa
+++ /dev/null
@@ -1,211 +0,0 @@
-*** man/man.c.orig Tue May 30 14:02:00 1995
---- man/man.c Sun Dec 8 03:33:04 1996
-***************
-*** 12,17 ****
---- 12,19 ----
- * Department of Chemical Engineering
- * The University of Texas at Austin
- * Austin, Texas 78712
-+ *
-+ * (LOCALE enhancement by kumano@strl.nhk.or.jp, 1996)
- */
-
- #define MAN_MAIN
-***************
-*** 22,27 ****
---- 24,32 ----
- #include <string.h>
- #include <sys/file.h>
- #include <signal.h>
-+ #ifdef LOCALE
-+ # include <locale.h>
-+ #endif
- #include "config.h"
- #include "gripes.h"
- #include "version.h"
-***************
-*** 112,117 ****
---- 117,126 ----
- uid_t egid;
- #endif
-
-+ #ifdef LOCALE
-+ static char current_locale[20];
-+ #endif
-+
- int
- main (argc, argv)
- int argc;
-***************
-*** 129,134 ****
---- 138,148 ----
- void do_whatis ();
- int man ();
-
-+ #ifdef LOCALE
-+ (void)setlocale(LC_CTYPE, "");
-+ strcpy(current_locale, setlocale(LC_CTYPE, NULL));
-+ #endif
-+
- prognam = mkprogname (argv[0]);
-
- man_getopt (argc, argv);
-***************
-*** 261,288 ****
---- 275,345 ----
- }
-
- char **
-+ #ifdef LOCALE
-+ add_dir_to_mpath_list (mp, p, locale)
-+ #else
- add_dir_to_mpath_list (mp, p)
-+ #endif
- char **mp;
- char *p;
-+ #ifdef LOCALE
-+ int locale;
-+ #endif
- {
- int status;
-+ char *pp;
-+
-+ #ifdef LOCALE
-+ if (locale)
-+ {
-+ char buf[FILENAME_MAX];
-+
-+ strcpy (buf, p);
-+ strcat (buf, "/");
-+ strcat (buf, current_locale);
-+
-+ pp = buf;
-+ }
-+ else
-+ {
-+ pp = p;
-+ }
-
-+ status = is_directory (pp);
-+ #else
- status = is_directory (p);
-+ #endif
-
- if (status < 0 && debug)
- {
-+ #ifdef LOCALE
-+ fprintf (stderr, "Warning: couldn't stat file %s!\n", pp);
-+ #else
- fprintf (stderr, "Warning: couldn't stat file %s!\n", p);
-+ #endif
- }
- else if (status == 0 && debug)
- {
-+ #ifdef LOCALE
-+ fprintf (stderr, "Warning: %s isn't a directory!\n", pp);
-+ #else
- fprintf (stderr, "Warning: %s isn't a directory!\n", p);
-+ #endif
- }
- else if (status == 1)
- {
- if (debug)
-+ #ifdef LOCALE
-+ fprintf (stderr, "adding %s to manpathlist\n", pp);
-+ #else
- fprintf (stderr, "adding %s to manpathlist\n", p);
-+ #endif
-
-+ #ifdef LOCALE
-+ *mp++ = strdup (pp);
-+ #else
- *mp++ = strdup (p);
-+ #endif
- }
- return mp;
- }
-***************
-*** 299,304 ****
---- 356,364 ----
- register char *p;
- register char *end;
- register char **mp;
-+ #ifdef LOCALE
-+ register int locale;
-+ #endif
- extern char *optarg;
- extern int getopt ();
- extern void downcase ();
-***************
-*** 409,414 ****
---- 469,478 ----
- * Expand the manpath into a list for easier handling.
- */
- mp = manpathlist;
-+ #ifdef LOCALE
-+ for (locale = 1; locale >= 0; locale--)
-+ {
-+ #endif
- for (p = manp; ; p = end+1)
- {
- if ((end = strchr (p, ':')) != NULL)
-***************
-*** 427,446 ****
---- 491,525 ----
- strcat (buf, "/");
- strcat (buf, alt_system_name);
-
-+ # ifdef LOCALE
-+ mp = add_dir_to_mpath_list (mp, buf, locale);
-+ # else
- mp = add_dir_to_mpath_list (mp, buf);
-+ # endif
- }
- else
- {
-+ # ifdef LOCALE
-+ mp = add_dir_to_mpath_list (mp, p, locale);
-+ # else
- mp = add_dir_to_mpath_list (mp, p);
-+ # endif
- }
- #else
-+ # ifdef LOCALE
-+ mp = add_dir_to_mpath_list (mp, p, locale);
-+ # else
- mp = add_dir_to_mpath_list (mp, p);
-+ # endif
- #endif
- if (end == NULL)
- break;
-
- *end = ':';
- }
-+ #ifdef LOCALE
-+ }
-+ #endif
- *mp = NULL;
- }
-
-*** man/Makefile.orig Wed Dec 4 11:11:09 1996
---- man/Makefile Sun Dec 8 03:26:31 1996
-***************
-*** 9,14 ****
---- 9,15 ----
- .else
- LDADD= -L${.CURDIR}/../lib/ -lman
- .endif
-+ LDADD+= -lxpg4
-
- .if exists(${.CURDIR}/obj)
- MAN1= ${.CURDIR}/obj/jman.1
-***************
-*** 19,24 ****
---- 20,26 ----
- DPADD+= ${MAN1}
- CFLAGS+= -I${.CURDIR}/../lib -DSTDC_HEADERS -DPOSIX -DHAS_TROFF
- CFLAGS+= -DDO_COMPRESS -DALT_SYSTEMS -DSETREUID -DCATMODE=0664
-+ CFLAGS+= -DLOCALE
- CLEANFILES+= ${MAN1}
-
- ${MAN1}: ${.CURDIR}/man.man