aboutsummaryrefslogtreecommitdiff
path: root/java/commonclipse/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-12-21 11:16:49 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-12-21 11:16:49 +0000
commita4dbef3e90f881a6145b535176dbf9435cfbe8ee (patch)
treec77965059d084d38c7c8ea80096e38caf2a8733f /java/commonclipse/Makefile
parent10ce372492fcf31bb065f7b5a8f4328dcbaac9cb (diff)
downloadports-a4dbef3e90f881a6145b535176dbf9435cfbe8ee.tar.gz
ports-a4dbef3e90f881a6145b535176dbf9435cfbe8ee.zip
Commonclipse is an eclipse plugin for jakarta commons-lang users.
It features automatic generation of the following methods using commons-lang builders: toString(), hashCode(), equals(Object), compareTo(Object). WWW: http://sourceforge.net/projects/commonclipse/ PR: ports/118890 Submitted by: Sutra Zhou <zhoushuqun at gmail.com>
Notes
Notes: svn path=/head/; revision=204252
Diffstat (limited to 'java/commonclipse/Makefile')
-rw-r--r--java/commonclipse/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/java/commonclipse/Makefile b/java/commonclipse/Makefile
new file mode 100644
index 000000000000..1ef199dccb2a
--- /dev/null
+++ b/java/commonclipse/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: commonclipse
+# Date created: 20 December 2007
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= commonclipse
+PORTVERSION= 1.3.0
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= commonclipse
+DISTNAME= net.sf.commonclipse_${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= Commonclipse is an eclipse plugin for jakarta commons-lang users
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+PLIST_SUB= DISTNAME=${DISTNAME}
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
+
+.include <bsd.port.mk>