aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-ecj
diff options
context:
space:
mode:
authorJason Helfman <jgh@FreeBSD.org>2012-03-24 23:21:33 +0000
committerJason Helfman <jgh@FreeBSD.org>2012-03-24 23:21:33 +0000
commita729825c44e3ea9cbeec129487377fc0f2608c89 (patch)
tree29ebd1682dbdcbda83d61be90567b15059766c51 /java/eclipse-ecj
parent96a8c0c1a24384ad117ae8b8ac9e85df81563795 (diff)
downloadports-a729825c44e3ea9cbeec129487377fc0f2608c89.tar.gz
ports-a729825c44e3ea9cbeec129487377fc0f2608c89.zip
- java 1.6+ is required
- bump PORTREVISION Submitted by: glewis@ (via email) Feature safe: yes
Notes
Notes: svn path=/head/; revision=293776
Diffstat (limited to 'java/eclipse-ecj')
-rw-r--r--java/eclipse-ecj/Makefile3
-rw-r--r--java/eclipse-ecj/files/ecj.sh.in2
2 files changed, 3 insertions, 2 deletions
diff --git a/java/eclipse-ecj/Makefile b/java/eclipse-ecj/Makefile
index 8104e3d31d5a..70ad55620c3c 100644
--- a/java/eclipse-ecj/Makefile
+++ b/java/eclipse-ecj/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ecj
PORTVERSION= 3.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MASTER_SITES= ECLIPSE
MASTER_SITE_SUBDIR= R-${PORTVERSION}-${DROPDATE}
@@ -25,6 +25,7 @@ EXTRACT_AFTER_ARGS= -C ${WRKDIR}
USE_ANT= yes
USE_JAVA= yes
+JAVA_VERSION= 1.6+
SUB_FILES= ecj.sh
SUB_LIST= PORTVERSION=${PORTVERSION}
NO_WRKSUBDIR= yes
diff --git a/java/eclipse-ecj/files/ecj.sh.in b/java/eclipse-ecj/files/ecj.sh.in
index 825e0a840bb8..bfbba17fc3d2 100644
--- a/java/eclipse-ecj/files/ecj.sh.in
+++ b/java/eclipse-ecj/files/ecj.sh.in
@@ -1,3 +1,3 @@
#!/bin/sh
-%%LOCALBASE%%/bin/java -classpath %%JAVAJARDIR%%/ecj-%%PORTVERSION%%.jar org.eclipse.jdt.internal.compiler.batch.Main ${@:--help}
+JAVA_VERSION="%%JAVA_VERSION%%" "%%LOCALBASE%%/bin/java" -classpath "%%JAVAJARDIR%%/ecj-%%PORTVERSION%%.jar" org.eclipse.jdt.internal.compiler.batch.Main "${@:--help}"