aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-findbugs
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-04-02 10:52:55 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2007-04-02 10:52:55 +0000
commit34333fee303ea6fe6701f2afa66a37ee704053b2 (patch)
tree139b94231ae1730fd9e389cab24fd3f26b5865cb /java/eclipse-findbugs
parent5ee77451ca99640d41c77158cb4610cdf3f34c78 (diff)
downloadports-34333fee303ea6fe6701f2afa66a37ee704053b2.tar.gz
ports-34333fee303ea6fe6701f2afa66a37ee704053b2.zip
New port eclipse-findbugs version 1.2.0.20070317: An Eclipse plug-in
that provides FindBugs support
Notes
Notes: svn path=/head/; revision=188996
Diffstat (limited to 'java/eclipse-findbugs')
-rw-r--r--java/eclipse-findbugs/Makefile36
-rw-r--r--java/eclipse-findbugs/distinfo3
-rw-r--r--java/eclipse-findbugs/pkg-descr19
3 files changed, 58 insertions, 0 deletions
diff --git a/java/eclipse-findbugs/Makefile b/java/eclipse-findbugs/Makefile
new file mode 100644
index 000000000000..7579a490d36a
--- /dev/null
+++ b/java/eclipse-findbugs/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: findbugs eclipse plugin
+# Date created: Dom 1 Abr 2007 22:42:25 UTC
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= findbugs
+DISTVERSION= 1.2.0.20070317
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= eclipse-
+DISTNAME= edu.umd.cs.findbugs.plugin.eclipse_${DISTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= An Eclipse plug-in that provides FindBugs support
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse/plugins
+ @${CP} -r ${WRKSRC} ${PREFIX}/eclipse/plugins
+ @(cd ${WRKDIR}; ${FIND} -s $$(${BASENAME} ${WRKSRC}) -not -type d) \
+ | ${SED} -ne 's,^,eclipse/plugins/,p' > ${TMPPLIST}
+ @(cd ${WRKDIR}; ${FIND} -s -d $$(${BASENAME} ${WRKSRC}) -type d) \
+ | ${SED} -ne 's,^,@dirrm eclipse/plugins/,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-findbugs/distinfo b/java/eclipse-findbugs/distinfo
new file mode 100644
index 000000000000..f580afcd985b
--- /dev/null
+++ b/java/eclipse-findbugs/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/edu.umd.cs.findbugs.plugin.eclipse_1.2.0.20070317.zip) = 8bfe3990a8433c8e39be51a277c5ca93
+SHA256 (eclipse/edu.umd.cs.findbugs.plugin.eclipse_1.2.0.20070317.zip) = 2c8ec2011db0cea026ea094a5d9c003635863ba86142eff066f348c5df188254
+SIZE (eclipse/edu.umd.cs.findbugs.plugin.eclipse_1.2.0.20070317.zip) = 3140540
diff --git a/java/eclipse-findbugs/pkg-descr b/java/eclipse-findbugs/pkg-descr
new file mode 100644
index 000000000000..d8c42630fc3b
--- /dev/null
+++ b/java/eclipse-findbugs/pkg-descr
@@ -0,0 +1,19 @@
+The Subversive project is a brand new Eclipse plug-in that provides
+Subversion support. From a user point of view, Subversive provides
+Subversion support similar to CVS support, which is already part of
+the standard Eclipse platform.
+
+The main use cases, which are familiar to CVS users, are:
+ * Connection to the repository using different connection types
+ * Repository browsing
+ * Check-out
+ * Synchronization
+ * Commiting
+ * Update
+ * Resolving conflicts
+ * Adding to the list of ignored resources
+
+WWW: http://www.polarion.org/index.php?page=overview&project=subversive
+
+- Alex Dupre
+ale@FreeBSD.org