aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-lomboz/Makefile
diff options
context:
space:
mode:
authorVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 10:10:38 +0000
committerVanilla I. Shu <vanilla@FreeBSD.org>2014-06-17 10:10:38 +0000
commit8f20178892dc2cfb0fd39e96be63b5a04758cbf0 (patch)
tree7a506efbf1092411eea297d944c631f271775dd3 /java/eclipse-lomboz/Makefile
parent9eead0ee346fb8ea8eaeb55c75b4c1d609e12f01 (diff)
downloadports-8f20178892dc2cfb0fd39e96be63b5a04758cbf0.tar.gz
ports-8f20178892dc2cfb0fd39e96be63b5a04758cbf0.zip
Stagify.
Notes
Notes: svn path=/head/; revision=358089
Diffstat (limited to 'java/eclipse-lomboz/Makefile')
-rw-r--r--java/eclipse-lomboz/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/java/eclipse-lomboz/Makefile b/java/eclipse-lomboz/Makefile
index 3dde3511f6f0..55e247961425 100644
--- a/java/eclipse-lomboz/Makefile
+++ b/java/eclipse-lomboz/Makefile
@@ -26,14 +26,13 @@ USE_JAVA= yes
JAVA_VERSION= 1.6+
JAVA_OS= native
-NO_STAGE= yes
do-install:
- @${MKDIR} ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/lib/eclipse
- @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/lib/eclipse
- @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
- @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
- | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
- | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${STAGEDIR}${PREFIX}/lib/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${STAGEDIR}${PREFIX}/lib/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) | ${SED} -e 's,^eclipse,lib/eclipse,' >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm lib/,p' >> ${TMPPLIST}
.include <bsd.port.mk>