aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-ocl
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-09-23 17:27:22 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-09-23 17:27:22 +0000
commit18eeac8f54a11ea58c02010ad6221bf53e3cab30 (patch)
tree5864e94b3044e7363df7c33748293699caa28633 /java/eclipse-ocl
parentecd6b30dd32ad47e13c8689d66fd8bfb9d2971f9 (diff)
downloadports-18eeac8f54a11ea58c02010ad6221bf53e3cab30.tar.gz
ports-18eeac8f54a11ea58c02010ad6221bf53e3cab30.zip
Implementaion of the OMG OCL for EMF-based models.
WWW: http://www.eclipse.org/modeling/mdt/?project=ocl#ocl PR: ports/115825 Submitted by: Veit Jahns <vj562001 at yahoo.de>
Notes
Notes: svn path=/head/; revision=200001
Diffstat (limited to 'java/eclipse-ocl')
-rw-r--r--java/eclipse-ocl/Makefile39
-rw-r--r--java/eclipse-ocl/distinfo3
-rw-r--r--java/eclipse-ocl/pkg-descr3
3 files changed, 45 insertions, 0 deletions
diff --git a/java/eclipse-ocl/Makefile b/java/eclipse-ocl/Makefile
new file mode 100644
index 000000000000..5fd321e78673
--- /dev/null
+++ b/java/eclipse-ocl/Makefile
@@ -0,0 +1,39 @@
+# New ports collection makefile for: eclipse-ocl
+# Date created: August, 25 2007
+# Whom: vj562001@yahoo.de
+#
+# $FreeBSD$
+#
+
+PORTNAME= ocl
+DISTVERSION= 1.1
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_ECLIPSE:S,/eclipse/downloads/drops/,/modeling/mdt/ocl/downloads/drops/,}
+MASTER_SITE_SUBDIR=${DISTVERSION}.0/R200706201142
+PKGNAMEPREFIX= eclipse-
+DISTNAME= mdt-ocl-SDK-${DISTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= vj562001@yahoo.de
+COMMENT= Implementation of the OCL OMG standard for EMF-based models
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse \
+ ${LOCALBASE}/eclipse/features/org.eclipse.emf_2.2.1.v200609210005/feature.xml:${PORTSDIR}/java/eclipse-emf
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-ocl/distinfo b/java/eclipse-ocl/distinfo
new file mode 100644
index 000000000000..fd21331cec19
--- /dev/null
+++ b/java/eclipse-ocl/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/mdt-ocl-SDK-1.1.zip) = 4ff2622f07a3a6d2c6a145bf27e48a1e
+SHA256 (eclipse/mdt-ocl-SDK-1.1.zip) = 49743525e6cb2a2f8b438d65d227b1539409bc3d322e104d94fe887196c00376
+SIZE (eclipse/mdt-ocl-SDK-1.1.zip) = 9740533
diff --git a/java/eclipse-ocl/pkg-descr b/java/eclipse-ocl/pkg-descr
new file mode 100644
index 000000000000..fd787dd9990f
--- /dev/null
+++ b/java/eclipse-ocl/pkg-descr
@@ -0,0 +1,3 @@
+Implementaion of the OMG OCL for EMF-based models.
+
+WWW: http://www.eclipse.org/modeling/mdt/?project=ocl#ocl