aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-quantum/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-10-21 22:32:08 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-10-21 22:32:08 +0000
commit9845c7d608e001ed8abc6eba376b149632542d08 (patch)
tree623ce827f002408b3de268e0f60f547797a8bd55 /java/eclipse-quantum/Makefile
parent62b84a88aa0cab64fc3b127a6a65ad6ebceeb789 (diff)
downloadports-9845c7d608e001ed8abc6eba376b149632542d08.tar.gz
ports-9845c7d608e001ed8abc6eba376b149632542d08.zip
. Update to 3.0.0.
. Try to make the packing list more future proof. PR: 87672 Submitted by: Andreas Kohn <andreas@syndrom23.de>
Notes
Notes: svn path=/head/; revision=146078
Diffstat (limited to 'java/eclipse-quantum/Makefile')
-rw-r--r--java/eclipse-quantum/Makefile12
1 files changed, 9 insertions, 3 deletions
diff --git a/java/eclipse-quantum/Makefile b/java/eclipse-quantum/Makefile
index 2ce91c83ee96..ee63977aa91b 100644
--- a/java/eclipse-quantum/Makefile
+++ b/java/eclipse-quantum/Makefile
@@ -6,13 +6,12 @@
#
PORTNAME= quantum
-PORTVERSION= 2.4.1
-PORTREVISION= 2
+PORTVERSION= 3.0.0
CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= quantum
PKGNAMEPREFIX= eclipse-
-DISTNAME= quantum${PORTVERSION}_e3.0
+DISTNAME= com.quantum.feature_${PORTVERSION}.bin.dist
DIST_SUBDIR= eclipse
MAINTAINER= freebsd-eclipse@FreeBSD.org
@@ -26,9 +25,16 @@ NO_EXTRACT= yes
USE_JAVA= yes
JAVA_VERSION= 1.4+
USE_ZIP= yes
+PLIST_SUB+= VERSION=${PORTVERSION}
+
+post-extract:
+ @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/Thumbs.db
+ @${RM} ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/unused/Thumbs.db
+ @${RM} -rf ${WRKSRC}/plugins/com.quantum.Quantum_${PORTVERSION}/icons/.xvpics
do-install:
@${MKDIR} ${PREFIX}/eclipse
@${CP} -r ${WRKSRC}/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/features ${PREFIX}/eclipse
.include <bsd.port.mk>