aboutsummaryrefslogtreecommitdiff
path: root/java/eclipse-uml/Makefile
diff options
context:
space:
mode:
authorNorikatsu Shigemura <nork@FreeBSD.org>2004-10-28 15:21:04 +0000
committerNorikatsu Shigemura <nork@FreeBSD.org>2004-10-28 15:21:04 +0000
commitc7d81b3b6e7c1ebe1cac19ea6f7d6b4c88be458e (patch)
tree1c7f62af17b1841727be7d525c486d2c6347eb51 /java/eclipse-uml/Makefile
parentae9ce0df2f74d6c7c18a2775581dc4380a3fe740 (diff)
downloadports-c7d81b3b6e7c1ebe1cac19ea6f7d6b4c88be458e.tar.gz
ports-c7d81b3b6e7c1ebe1cac19ea6f7d6b4c88be458e.zip
Add eclipse-uml 1.0.1, a framework creating UML
diagrams in Eclipse. PR: ports/73227 Submitted by: gldisater@gldis.ca
Notes
Notes: svn path=/head/; revision=120395
Diffstat (limited to 'java/eclipse-uml/Makefile')
-rw-r--r--java/eclipse-uml/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/java/eclipse-uml/Makefile b/java/eclipse-uml/Makefile
new file mode 100644
index 000000000000..91fe3c9a9e23
--- /dev/null
+++ b/java/eclipse-uml/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: eclipse-uml
+# Date created: October 20, 2004
+# Whom: gldisater@gldis.ca
+#
+# $FreeBSD$
+#
+
+PORTNAME= uml
+PORTVERSION= 1.0.1
+CATEGORIES= java devel
+MASTER_SITES= http://download1.eclipse.org/tools/uml2/downloads/drops/1.0.1/R200409171820/
+PKGNAMEPREFIX= eclipse-
+DISTNAME= uml2-SDK-${PORTVERSION}
+DIST_SUBDIR= eclipse
+
+MAINTAINER= gldisater@gldis.ca
+COMMENT= A framework creating UML diagrams in Eclipse
+
+RUN_DEPENDS+= ${LOCALBASE}/eclipse/features/org.eclipse.emf_2.0.1/feature.xml:${PORTSDIR}/java/eclipse-emf
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+PLIST_SUB= RELEASEVERSION=${PORTVERSION}
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+
+.include <bsd.port.mk>