aboutsummaryrefslogtreecommitdiff
path: root/java/jakarta-commons-logging
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2005-05-23 14:18:12 +0000
committerHerve Quiroz <hq@FreeBSD.org>2005-05-23 14:18:12 +0000
commitf7753b6ade42ca6c10c1a79d9559b0cb3febda8d (patch)
tree2758c1e7b7b666cfb25aaa38f61ba8eccbdd3e15 /java/jakarta-commons-logging
parent295eae89ac140855a80093a64dab02d42b9e1be8 (diff)
downloadports-f7753b6ade42ca6c10c1a79d9559b0cb3febda8d.tar.gz
ports-f7753b6ade42ca6c10c1a79d9559b0cb3febda8d.zip
- Install commons-logging-api.jar
- Add 'devel' category to calm portlint Submitted by: thierry
Notes
Notes: svn path=/head/; revision=135963
Diffstat (limited to 'java/jakarta-commons-logging')
-rw-r--r--java/jakarta-commons-logging/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/java/jakarta-commons-logging/Makefile b/java/jakarta-commons-logging/Makefile
index 61810521edf7..b48fb07807f2 100644
--- a/java/jakarta-commons-logging/Makefile
+++ b/java/jakarta-commons-logging/Makefile
@@ -7,7 +7,8 @@
PORTNAME= commons-logging
PORTVERSION= 1.0.4
-CATEGORIES= java
+PORTREVISION= 1
+CATEGORIES= java devel
MASTER_SITES= ${MASTER_SITE_APACHE_JAKARTA}
MASTER_SITE_SUBDIR= ${PORTNAME:S,-,/,}/source
PKGNAMEPREFIX= jakarta-
@@ -46,12 +47,12 @@ ALL_TARGET+= javadoc
OTHERDOCS= LICENSE.txt NOTICE.txt RELEASE-NOTES.txt
PORTDOCS= api ${OTHERDOCS}
.endif
-JARFILE= ${PORTNAME}.jar
-PLIST_FILES= %%JAVAJARDIR%%/${JARFILE}
+JARFILE= ${PORTNAME}.jar ${PORTNAME}-api.jar
+PLIST_FILES= ${JARFILE:S|^|%%JAVAJARDIR%%/|}
do-install:
- @${ECHO_MSG} -n ">> Installing JAR as ${JAVAJARDIR}/${JARFILE}..."
- @${INSTALL_DATA} ${WRKSRC}/target/${JARFILE} ${JAVAJARDIR}/${JARFILE}
+ @${ECHO_MSG} -n ">> Installing JAR as ${JARFILE:S|^|${JAVAJARDIR}/|}..."
+ @${INSTALL_DATA} ${JARFILE:S|^|${WRKSRC}/target/|} ${JAVAJARDIR}
@${ECHO_MSG} " [ DONE ]"
.if !defined(NOPORTDOCS)