aboutsummaryrefslogtreecommitdiff
path: root/java/jamvm
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2014-04-10 06:41:21 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2014-04-10 06:41:21 +0000
commit036cbe3e12bcd81ba0689c19e546eae310e0371a (patch)
tree399b11954cbdfbaf84139ceed4db82dedbaf8ce6 /java/jamvm
parentfa29a2f8f76d8008812d910edb8386e8504a1cce (diff)
downloadports-036cbe3e12bcd81ba0689c19e546eae310e0371a.tar.gz
ports-036cbe3e12bcd81ba0689c19e546eae310e0371a.zip
support stage
Notes
Notes: svn path=/head/; revision=350778
Diffstat (limited to 'java/jamvm')
-rw-r--r--java/jamvm/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/java/jamvm/Makefile b/java/jamvm/Makefile
index 400c6c4f8c9e..47e2445e9147 100644
--- a/java/jamvm/Makefile
+++ b/java/jamvm/Makefile
@@ -7,7 +7,7 @@ CATEGORIES= java devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/JamVM%20${PORTVERSION}
MAINTAINER= java@FreeBSD.org
-COMMENT= A compact Java virtual machine
+COMMENT= Compact Java virtual machine
LICENSE= GPLv2
@@ -15,19 +15,17 @@ RUN_DEPENDS= ${LOCALBASE}/share/classpath/glibj.zip:${PORTSDIR}/java/classpath
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-classpath-install-dir=${LOCALBASE}
-USE_GMAKE= yes
-USES= pkgconfig
+USES= gmake pkgconfig
OPTIONS_DEFINE= FFI ZIP
OPTIONS_DEFAULT=FFI ZIP
FFI_DESC= use libffi to call native methods
ZIP_DESC= turn-on zip support in the bootstrap loader
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MFFI}
-LIB_DEPENDS+= ffi:${PORTSDIR}/devel/libffi
+LIB_DEPENDS+= libffi.so:${PORTSDIR}/devel/libffi
CONFIGURE_ARGS+= --enable-ffi
.elif ${ARCH} == "sparc64"
IGNORE= for ${ARCH} requires libffi
@@ -41,9 +39,7 @@ CONFIGURE_ARGS+= --disable-zip
PLIST_SUB+= WITH_ZIP="@comment " WITHOUT_ZIP=""
.endif
-.include <bsd.port.pre.mk>
-
post-extract:
@${REINPLACE_CMD} -e "s,\(^include_HEADERS = .*\)jni.h\(.*\),\1\2," ${WRKSRC}/src/Makefile.in
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>