aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-03-30 16:51:59 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-03-30 16:51:59 +0000
commit4d4b949e11e2b62114541d27cfc2a05ca5fa65ee (patch)
tree145420e2ad262a40333331570acf83c570911722 /java/jdk15/Makefile
parent9606aa53d08b407e9827601411893791e8a6af7b (diff)
downloadports-4d4b949e11e2b62114541d27cfc2a05ca5fa65ee.tar.gz
ports-4d4b949e11e2b62114541d27cfc2a05ca5fa65ee.zip
. Unbreak the packing list by adding explicit PLIST_FILES/PLIST_DIRS for
files that are generated by the post-install script (which runs after the dynamic packing list has been generated). Approved by: portmgr (krion), phantom (maintainer)
Notes
Notes: svn path=/head/; revision=132124
Diffstat (limited to 'java/jdk15/Makefile')
-rw-r--r--java/jdk15/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 70168c904c34..ad0b6d1a873f 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -98,6 +98,10 @@ MAKE_ENV+= DONT_ENABLE_IPV6="YES"
ALL_TARGET= all
+PLIST_FILES= jdk${JDK_VERSION}/jre/.systemPrefs/.system.lock \
+ jdk${JDK_VERSION}/jre/.systemPrefs/.systemRootModFile
+PLIST_DIRS= jdk${JDK_VERSION}/jre/.systemPrefs
+
.if (${ARCH} == amd64)
HOTSPOTARCH=amd64
.else