aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-07-15 07:17:24 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-07-15 07:17:24 +0000
commit7b57f8493501189c1a04a01803fc2c6c7426114f (patch)
tree0053287c0b68c2a79d2cfb97df2fb5a58f267940 /java/jdk15/Makefile
parent245d2fb7d21f1e780defd265393128ab6e825d99 (diff)
downloadports-7b57f8493501189c1a04a01803fc2c6c7426114f.tar.gz
ports-7b57f8493501189c1a04a01803fc2c6c7426114f.zip
Remove unintentional dependency on readlink by replacing the call to it
with a piece of sh+awk based on a recent post to freebsd-arch by Cyrille Lefevre <cyrille.lefevre@laposte.net>.
Notes
Notes: svn path=/head/; revision=62964
Diffstat (limited to 'java/jdk15/Makefile')
-rw-r--r--java/jdk15/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index a6c683ac8c20..1c74eb0f8619 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -123,7 +123,7 @@ pre-patch:
pre-build:
@if [ "$${WRKDIRPREFIX}" -a \
-L "/compat/linux/$${WRKDIRPREFIX}" -a \
- x`readlink "/compat/linux/$${WRKDIRPREFIX}"` = x"$${WRKDIRPREFIX}" ]; \
+ x`ls -ld "/compat/linux/$${WRKDIRPREFIX}" 2>/dev/null | awk '/->/{print $$NF;exit 0}END{exit 1}'` = x"$${WRKDIRPREFIX}" ]; \
then \
echo "Please set WRKDIRPREFIX to something which doesn't"; \
echo "have a matching symbolic link in /compat/linux."; \