aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15/Makefile
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2002-10-29 05:17:59 +0000
committerGreg Lewis <glewis@FreeBSD.org>2002-10-29 05:17:59 +0000
commit9f087781c0249cd12644a0856f20cecca7dedf3e (patch)
treee6e6ddfb7da9846da5e8549518479b1bbf958cfc /java/jdk15/Makefile
parent339790fd2dd5ded7c55d87af4375eaa2ebe16eb9 (diff)
downloadports-9f087781c0249cd12644a0856f20cecca7dedf3e.tar.gz
ports-9f087781c0249cd12644a0856f20cecca7dedf3e.zip
. Check for open-motif with libXm.so, which we actually use, instead of
libMrm.a, which isn't.
Notes
Notes: svn path=/head/; revision=69076
Diffstat (limited to 'java/jdk15/Makefile')
-rw-r--r--java/jdk15/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index a3bea3815735..797c966b8d94 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= glewis@FreeBSD.org
BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
zip:${PORTSDIR}/archivers/zip \
- ${X11BASE}/lib/libMrm.a:${PORTSDIR}/x11-toolkits/open-motif
+ ${X11BASE}/lib/libXm.so:${PORTSDIR}/x11-toolkits/open-motif
.if !defined(NATIVE_BOOTSTRAP)
BUILD_DEPENDS+= ${JDK13DIR}/bin/javac:${PORTSDIR}/java/linux-sun-jdk13
.endif
@@ -30,7 +30,7 @@ LIB_DEPENDS= glib12.3:$(PORTSDIR)/devel/glib12 \
nspr4.1:$(PORTSDIR)/devel/nspr
.endif
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${X11BASE}/lib/libMrm.a:${PORTSDIR}/x11-toolkits/open-motif \
+ ${X11BASE}/lib/libXm.so:${PORTSDIR}/x11-toolkits/open-motif \
${X11BASE}/lib/X11/fonts/URW/fonts.dir:${PORTSDIR}/x11-fonts/urwfonts
WRKSRC= ${WRKDIR}/j2sdk1.3.1/make