aboutsummaryrefslogtreecommitdiff
path: root/java/jdk15
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2006-08-01 18:30:37 +0000
committerGreg Lewis <glewis@FreeBSD.org>2006-08-01 18:30:37 +0000
commit2f9818eb94b97abae76286ca4fdd78514cc84ad4 (patch)
treec4d57eb42ee450aa2cc799af32fa687bb53c2b4f /java/jdk15
parentd3beccfcf2e04c7be8a725a98f53106493b5a435 (diff)
downloadports-2f9818eb94b97abae76286ca4fdd78514cc84ad4.tar.gz
ports-2f9818eb94b97abae76286ca4fdd78514cc84ad4.zip
. Space out the arguments to OPTIONS with tabs rather than spaces.
. Add a JAIL which allows the port to be built in a jail. [1] Submitted by: anders@ [1]
Notes
Notes: svn path=/head/; revision=169374
Diffstat (limited to 'java/jdk15')
-rw-r--r--java/jdk15/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/java/jdk15/Makefile b/java/jdk15/Makefile
index 02583ae49adf..3c128298688c 100644
--- a/java/jdk15/Makefile
+++ b/java/jdk15/Makefile
@@ -23,14 +23,15 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
${X11BASE}/lib/libXm.so:${PORTSDIR}/x11-toolkits/open-motif
RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
-OPTIONS= DEBUG "Enable debugging support" off \
- IPV6 "Enable IPv6 support" off
+OPTIONS= DEBUG "Enable debugging support" off \
+ IPV6 "Enable IPv6 support" off
.if ${MACHINE_ARCH} == "amd64"
WITHOUT_WEB= yes
.else
-OPTIONS+= WEB "Enable the browser plugin and Java Web Start" on
+OPTIONS+= WEB "Enable the browser plugin and Java Web Start" on
.endif
-OPTIONS+= POLICY "Install the Unlimited Strength Policy Files" off
+OPTIONS+= POLICY "Install the Unlimited Strength Policy Files" off \
+ JAIL "Port is being built within a jail" off
WANT_GNOME= yes
PKGINSTALL= ${WRKDIR}/pkg-install
@@ -264,6 +265,7 @@ pre-build:
${ECHO_MSG} "is known to cause problems during bootstrapping."; \
exit 1; \
fi
+.if defined(WITH_JAIL)#{
@if [ "`/sbin/mount | grep ^linprocfs`" = "" ]; \
then \
${ECHO_MSG} "ERROR: You must have LINPROCFS mounted before" ; \
@@ -279,6 +281,7 @@ pre-build:
${ECHO_MSG} "" ; \
exit 1 ; \
fi
+.endif#}
.endif
do-build: