aboutsummaryrefslogtreecommitdiff
path: root/java/jikes
diff options
context:
space:
mode:
authorMatthew Dillon <dillon@FreeBSD.org>1998-12-10 18:02:53 +0000
committerMatthew Dillon <dillon@FreeBSD.org>1998-12-10 18:02:53 +0000
commitcd86dc5296b2f66ea8d9bb27c32e78c6aca8991e (patch)
tree8ce9ab9dd166698537de16ec7bb228b60b33636f /java/jikes
parentd17c12dd8dd8d0cf5eca3b1e74242dc69bb3ba1b (diff)
downloadports-cd86dc5296b2f66ea8d9bb27c32e78c6aca8991e.tar.gz
ports-cd86dc5296b2f66ea8d9bb27c32e78c6aca8991e.zip
Add IBM's open-source jikes package to the ports collection
Notes
Notes: svn path=/head/; revision=15257
Diffstat (limited to 'java/jikes')
-rw-r--r--java/jikes/Makefile32
-rw-r--r--java/jikes/distinfo1
-rw-r--r--java/jikes/files/patch-aa27
-rw-r--r--java/jikes/pkg-comment1
-rw-r--r--java/jikes/pkg-descr19
-rw-r--r--java/jikes/pkg-message8
-rw-r--r--java/jikes/pkg-plist1
7 files changed, 89 insertions, 0 deletions
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
new file mode 100644
index 000000000000..e798bc15c52d
--- /dev/null
+++ b/java/jikes/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: jikes
+# Version required: 0.41
+# Date created: 09 December 1998
+# Whom: Matthew Dillon <dillon@backplane.com>
+#
+# $Id: exp $
+#
+
+DISTNAME= jikes-0.41
+CATEGORIES= lang
+MASTER_SITES= http://www.backplane.com/FreeBSDPorts/
+DISTFILES= ${DISTNAME}.tar.gz
+WRKSRC= ${WRKDIR}/jikesos
+MAN1= jikes.1
+
+MAINTAINER= dillon@backplane.com
+
+# (sufficiently handled by pkg/MESSAGE, but if IBM has an issue then
+# uncomment this section)
+#
+#fetch-depends:
+#
+#.if !defined(READ_IBM_LICENSE)
+# @echo ""
+# @echo "You must read the IBM license prior to using this software,"
+# @echo "then set READ_IBM_LICENSE=YES in /etc/make.conf.local"
+# @echo ""
+# @echo "The license is available at http://www.ibm.com/research/jikes"
+# @false
+#.endif
+
+.include <bsd.port.mk>
diff --git a/java/jikes/distinfo b/java/jikes/distinfo
new file mode 100644
index 000000000000..7a1ad93f57a7
--- /dev/null
+++ b/java/jikes/distinfo
@@ -0,0 +1 @@
+MD5 (jikes-0.41.tar.gz) = 95467d78436f6f2fa19cbe10e628117e
diff --git a/java/jikes/files/patch-aa b/java/jikes/files/patch-aa
new file mode 100644
index 000000000000..6713c7bb4f28
--- /dev/null
+++ b/java/jikes/files/patch-aa
@@ -0,0 +1,27 @@
+*** jikes/src/Makefile.orig Wed Dec 9 21:59:34 1998
+--- jikes/src/Makefile Wed Dec 9 22:02:10 1998
+***************
+*** 131,136 ****
+--- 131,152 ----
+ O=o
+ SYSOBJECTS=
+
++ # g++ definitions (FreeBSD)
++ CC=g++
++ # use -W to see warnings (should review from time to time)
++ CCREQUIREDFLAGS=-DGNU_LIBC5 -DUNIX -funsigned-char -c -DTYPE_bool -ansi -I.
++ CCDEBUGFLAGS=-DTEST -g
++ CCOPTFLAGS=-O2
++ CCFLAGS=$(CCREQUIREDFLAGS) $(CCDEBUGFLAGS)
++ CCFLAGS=$(CCREQUIREDFLAGS) $(CCOPTFLAGS)
++ ERASE=rm -f
++ EXECUTABLE=jikes
++ LD=g++
++ LDDEBUGFLAGS=-g
++ LDFLAGS=-L. -o$(EXECUTABLE)
++ O=o
++ SYSOBJECTS=
++
+
+ OBJECTS=jikes.$(O) scanner.$(O) code.$(O) zip.$(O) unzip.$(O) ast.$(O) diagnose.$(O) \
+ parser.$(O) lpginput.$(O) lcase.$(O) javaact.$(O) error.$(O) set.$(O) symbol.$(O) \
diff --git a/java/jikes/pkg-comment b/java/jikes/pkg-comment
new file mode 100644
index 000000000000..9dccfeeac82c
--- /dev/null
+++ b/java/jikes/pkg-comment
@@ -0,0 +1 @@
+A Java source to byte-code compiler made available by IBM
diff --git a/java/jikes/pkg-descr b/java/jikes/pkg-descr
new file mode 100644
index 000000000000..e51348df2baa
--- /dev/null
+++ b/java/jikes/pkg-descr
@@ -0,0 +1,19 @@
+This is jikes, a java source to byte-code compiler. The compiler has been
+made available by IBM under their open-source license, please see:
+
+ http://www.ibm.com/research/jikes
+
+for details. To operate, the CLASSPATH environment variable must typically
+be set to a colon-delimited list of source directories, class directories,
+or zip files. Note that jikes will complain if a non-existant directory or
+file is specified in CLASSPATH.
+
+===============
+
+// This software is subject to the terms of the IBM Jikes Compiler Open"
+// Source License Agreement available at the following URL:"
+// http://www.ibm.com/research/jikes."
+// Copyright (C) 1996, 1998, International Business Machines Corporation"
+// and others. All Rights Reserved."
+// You must accept the terms of that agreement to use this software."
+
diff --git a/java/jikes/pkg-message b/java/jikes/pkg-message
new file mode 100644
index 000000000000..7b032b38e155
--- /dev/null
+++ b/java/jikes/pkg-message
@@ -0,0 +1,8 @@
+
+This software is subject to the terms of the IBM Jikes Compiler Open"
+Source License Agreement available at the following URL:"
+http://www.ibm.com/research/jikes."
+Copyright (C) 1996, 1998, International Business Machines Corporation"
+and others. All Rights Reserved."
+You must accept the terms of that agreement to use this software."
+
diff --git a/java/jikes/pkg-plist b/java/jikes/pkg-plist
new file mode 100644
index 000000000000..654b2b1d4d23
--- /dev/null
+++ b/java/jikes/pkg-plist
@@ -0,0 +1 @@
+bin/jikes