aboutsummaryrefslogtreecommitdiff
path: root/java/linux-blackdown-jdk12
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /java/linux-blackdown-jdk12
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'java/linux-blackdown-jdk12')
-rw-r--r--java/linux-blackdown-jdk12/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/java/linux-blackdown-jdk12/Makefile b/java/linux-blackdown-jdk12/Makefile
index 6c0c7e7ae315..68a241f49a86 100644
--- a/java/linux-blackdown-jdk12/Makefile
+++ b/java/linux-blackdown-jdk12/Makefile
@@ -7,7 +7,7 @@
PORTNAME= jdk
PORTVERSION= 1.2.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= java devel
MASTER_SITES= ftp://ftp.tux.org/pub/java/JDK-${PORTVERSION}/${ARCH}/FCS/ \
${MASTER_SITE_LOCAL}
@@ -18,8 +18,7 @@ DISTNAME= j2sdk-${PORTVERSION}-FCS-linux-${ARCH}-glibc-2.1.3
MAINTAINER= java@FreeBSD.org
COMMENT= Blackdown Java Development Kit 1.2 for Linux
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
NO_CDROM= "License doesn\'t allow distribution with fee"
NO_PACKAGE= "License doesn\'t allow binary distributions"
@@ -28,6 +27,8 @@ LATEST_LINK= linux-blackdown-jdk12
ONLY_FOR_ARCHS= i386 amd64
USE_BZIP2= YES
+USE_LINUX= yes
+USE_XLIB= yes
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
NO_BUILD= YES
APP_HOME?= ${PREFIX}/${PKGBASE}${PORTVERSION}
@@ -37,6 +38,8 @@ post-patch:
${FIND} ${WRKSRC} \( -name '*.orig' -o -name '.*.orig' \) -print \
| ${XARGS} ${RM} -f
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
+
do-install:
${MKDIR} ${APP_HOME}
cd ${WRKSRC} && ${FIND} . -print \