aboutsummaryrefslogtreecommitdiff
path: root/java/linux-sun-jdk14
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-05-29 12:33:01 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-05-29 12:33:01 +0000
commit12878ec3ce68bc886a5f1906638c2c47244e8c75 (patch)
treeb0fb0400ae8179d26c017a65176b6ca97b4c5038 /java/linux-sun-jdk14
parent1c5ea6d6a5b000eebaa7437f91802986489e7172 (diff)
downloadports-12878ec3ce68bc886a5f1906638c2c47244e8c75.tar.gz
ports-12878ec3ce68bc886a5f1906638c2c47244e8c75.zip
- Properly define DISTFILES, so the port doesn't fail miserably if it is not
present; - deregister VM on uninstall. PR: 27718 Submitted by: Andreas Schulz <ats@first.gmd.de> Reviewed by: maintainer Approved by: maintainer
Notes
Notes: svn path=/head/; revision=43241
Diffstat (limited to 'java/linux-sun-jdk14')
-rw-r--r--java/linux-sun-jdk14/Makefile7
-rw-r--r--java/linux-sun-jdk14/pkg-plist1
2 files changed, 4 insertions, 4 deletions
diff --git a/java/linux-sun-jdk14/Makefile b/java/linux-sun-jdk14/Makefile
index 51721394137a..410517ef23d0 100644
--- a/java/linux-sun-jdk14/Makefile
+++ b/java/linux-sun-jdk14/Makefile
@@ -10,8 +10,7 @@ PORTVERSION= ${JDK_VERSION:S/-//g}
CATEGORIES= java devel
MASTER_SITES= #
PKGNAMEPREFIX= linux-
-DISTNAME= j2sdk-${JDK_VERSION:S/./_/g}-linux-i386
-EXTRACT_SUFX= .bin
+DISTFILES= j2sdk-${JDK_VERSION:S/./_/g}-linux-i386.bin
MAINTAINER= ernst@jollem.com
@@ -21,7 +20,7 @@ NO_CDROM= "License doesn\'t allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
.if defined(BATCH) || defined(PACKAGE_BUILDING)
-IGNORE= "You can not legally distribute binaries"
+IGNORE="You can not legally distribute binaries"
.endif
EXTRACT_CMD= # empty
@@ -41,7 +40,7 @@ TARGET_PREFIX?= ${PREFIX}/${PKGBASE}${PORTVERSION}
.for file in ${DISTFILES}
.if !exists(${DISTDIR}/${file})
-IGNORE=You must manually fetch the Java 2 Development Kit ${JDK_VERSION} for Linux archive (${DISTFILES}) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again.
+IGNORE=You must manually fetch the Java 2 Development Kit ${JDK_VERSION} for Linux archive (${DISTFILES}) from http://java.sun.com/j2se/1.3/download-linux.html, place it in ${DISTDIR} and then run make again
.endif
.endfor
diff --git a/java/linux-sun-jdk14/pkg-plist b/java/linux-sun-jdk14/pkg-plist
index defd5d256401..b701c032e57a 100644
--- a/java/linux-sun-jdk14/pkg-plist
+++ b/java/linux-sun-jdk14/pkg-plist
@@ -1165,3 +1165,4 @@
@dirrm %%TARGET_PREFIX%%/man/ja_JP.eucJP
@dirrm %%TARGET_PREFIX%%/man
@dirrm %%TARGET_PREFIX%%
+@unexec %%LOCALBASE%%/bin/unregistervm "%D/%%TARGET_PREFIX%%/bin/java"