aboutsummaryrefslogtreecommitdiff
path: root/java/linux-sun-jdk16
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2005-06-17 22:59:29 +0000
commit23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d (patch)
treefa03305e656151ebe33c7e94eacc947b13d1c273 /java/linux-sun-jdk16
parentb347391f9ad81dd1ebc74b80d713888404b304bd (diff)
downloadports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.tar.gz
ports-23b3bc4b0d01608d37199d39bb546c6c9d6a8b1d.zip
Mega-patch to cleanup the ports infrastructure regarding our linux bits:
- USE_LINUX now implies NO_FILTER_SHLIBS=yes. It also doesn't use FreeBSD tools to strip binaries anymore, so it's not neccesary anymore to override STRIP and STRIP_CMD. - USE_LINUX_PREFIX implies NO_MTREE now. - In the USE_LINUX case, USE_XLIB now depends upon the linux X11 libraries instead upon the native FreeBSD libraries. - The variable LINUX_BASE_PORT contains a string which is suitable as an item in *_DEPENDS, so if a port BATCH_DEPENDS or FETCH_DEPENDS upon the default (or overriden) linux base, ${LINUX_BASE_PORT} should be used instead of a hardcoded reference. - Change all ports to comply to the "new world order". - The Ports Collection now allows to override the default linux_base port. Specify e.g. OVERRIDE_LINUX_BASE_PORT=rh-9 in /etc/make.conf to use ${PORTSDIR}/emulators/linux_base-rh-9 (the logic is to use ${PORTSDIR}/emulators/linux_base-${OVERRIDE_LINUX_BASE_PORT}). - If USE_LINUX or OVERRIDE_LINUX_BASE doesn't point to an existing linux_base port and if USE_LINUX isn't set to "yes" (case insensitive), the port will be marked as IGNORE. [1] - Readd USE_LINUX knobs into several ports and make several uses of a conditional dependency ("USE_LINUX?=") into an unconditional one ("USE_LINUX=") which where removed/changed by Trevor to allow the use of alternative linux_base ports. While this is a nice goal, the implementation resulted in missing dependencies. The OVERRIDE_LINUX_BASE_PORT knob in this commit is supposed to fix the problem while keeping the feature. Basicaly this includes a backout of Trevor's commit, to prevent confusion I mention it here explicitely. - Use the correct prefix (X11- instead of LOCAL- or LINUX-) for some ports. Chase dependencies for this. - Changes to make linux_devtools installable on amd64, remove some stray device nodes (they don't work on recent OS versions and aren't really needed). - Make linux_base-8 PREFIX clean and remove some stray device nodes. Additionally tell a little bit more about how to setup NIS/YP [2]. - Update the PGSQL dependency in the linux-opengroupware port to a recent version (the old one isn't available anymore), I don't know if this works (at least it isn't more broken than before). - Use PREFIX/usr/share/doc instead of PREFIX/usr/doc in the divx4linux ports, the former path exists already and gets populated by other packages too (PREFIX=LINUXPREFIX!). - Fix some obvious (non-linuxolator) bugs in some linux ports while being there. - Bump PORTREVISION where neccesary. Requested by: portmgr (linimon) [1] Submittted by: Gerrit Kuehn <gerrit_huehn@gruft.fido.de [2] Approved by: portmgr (kris, linimon), maintainers (or maintainer timeout) Tested on: ports cluster (kris) Reviewed by: silence on emulation@ Superseedes PR: 69997 Maintainer approval from: chris@chrisburkert.de cracauer@cons.org des girgen jamie@bishopston.net mezz mi nivit@users.sf.net pat simond@irrelevant.org riggs@rrr.de Udo.Schweigert@Siemens.com
Notes
Notes: svn path=/head/; revision=137660
Diffstat (limited to 'java/linux-sun-jdk16')
-rw-r--r--java/linux-sun-jdk16/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index cee762130cd5..3d6e42457341 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -7,6 +7,7 @@
PORTNAME= jdk
PORTVERSION= ${DL_JDK_VERSION:S/_/./g}
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= java devel
MASTER_SITES= #
@@ -17,9 +18,8 @@ EXTRACT_SUFX= .bin
MAINTAINER= java@FreeBSD.org
COMMENT= Sun Java Development Kit 1.5 for Linux
-EXTRACT_DEPENDS=${LINUXBASE}/lib/libc.so.6:${PORTSDIR}/emulators/linux_base-8
-RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper \
- ${LINUXBASE}/usr/X11R6/lib/libXrender.so.1:${PORTSDIR}/x11/linux-XFree86-libs
+EXTRACT_DEPENDS=${LINUX_BASE_PORT}
+RUN_DEPENDS= javavm:${PORTSDIR}/java/javavmwrapper
NO_CDROM= "License does not allow distribution with fee"
RESTRICTED= "Redistribution of repackaged binaries not permitted"
@@ -30,6 +30,8 @@ PLIST_SUB+= T=${APP_HOME:S/^${PREFIX}\///} PORTVERSION=${PORTVERSION}
PKGINSTALL= ${WRKDIR}/pkg-install
NO_BUILD= yes
+USE_LINUX= yes
+USE_XLIB= yes
JDK_VERSION= 1.5.0
JDK_REVISION= 03
DL_JDK_VERSION= ${JDK_VERSION}_${JDK_REVISION}
@@ -63,6 +65,8 @@ do-extract:
post-patch:
@${FIND} ${WRKSRC} -name '*.orig' -print | ${XARGS} ${RM} -f
+# XXX: This is missing a "${BRANDELF} -t Linux <executables>".
+
do-install:
${MKDIR} ${APP_HOME}
cd ${WRKSRC} && ${FIND} . -print \