aboutsummaryrefslogtreecommitdiff
path: root/java/linux-sun-jdk16
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2005-05-17 20:57:51 +0000
committerGreg Lewis <glewis@FreeBSD.org>2005-05-17 20:57:51 +0000
commit4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa (patch)
tree5738239e53b3172af9619702865bbe6eefec3079 /java/linux-sun-jdk16
parent72c3c7ee152996a12b85aedb1ab38cac8493a789 (diff)
downloadports-4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa.tar.gz
ports-4348e7f10f77ed610d2a6fc9ae27f3b77a7993aa.zip
. This port is working well enough for me under 5.4 that I can run
graphical applications with it, so restrict the IGNORE setting regarding bad system calls to earlier versions of FreeBSD. One suspects that the actual change to fix things happened sometime earlier in 5.x, but until we figure out exactly what change enabled it or have empirical evidence regarding this 5.4 is a good cutoff.
Notes
Notes: svn path=/head/; revision=135521
Diffstat (limited to 'java/linux-sun-jdk16')
-rw-r--r--java/linux-sun-jdk16/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/java/linux-sun-jdk16/Makefile b/java/linux-sun-jdk16/Makefile
index 830e17fd6995..cee762130cd5 100644
--- a/java/linux-sun-jdk16/Makefile
+++ b/java/linux-sun-jdk16/Makefile
@@ -40,10 +40,12 @@ APP_HOME= ${PREFIX}/${PKGNAMEPREFIX}${PORTNAME}${JDK_VERSION}
PACKED_JARS= lib/tools.jar jre/lib/rt.jar jre/lib/jsse.jar jre/lib/charsets.jar jre/lib/ext/localedata.jar jre/lib/plugin.jar jre/javaws/javaws.jar
UNPACK_CMD= ${APP_HOME}/bin/unpack200
-IGNORE= does not run (core dumps: Bad System Call)
-
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 504000
+IGNORE= does not run (core dumps: Bad System Call)
+.endif
+
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}) && !defined(PACKAGE_BUILDING)
IGNORE?=You must manually fetch the J2SE SDK self-extracting file for the Linux platform (${DISTNAME}${EXTRACT_SUFX}) from ${DOWNLOAD_URL}, place it in ${DISTDIR} and then run make again
.endif