aboutsummaryrefslogtreecommitdiff
path: root/java/shujit
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 17:29:54 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-04-26 17:29:54 +0000
commit81b63669b1b8f7f2d174ffa488191a3b76357843 (patch)
tree905b526fbcacfd50601689b7ba00590e5d6fcd7e /java/shujit
parent261a9ec095544fecbc515a5d9d3bea159edd3027 (diff)
downloadports-81b63669b1b8f7f2d174ffa488191a3b76357843.tar.gz
ports-81b63669b1b8f7f2d174ffa488191a3b76357843.zip
Update to 0.7.12.
Notes
Notes: svn path=/head/; revision=58182
Diffstat (limited to 'java/shujit')
-rw-r--r--java/shujit/Makefile2
-rw-r--r--java/shujit/distinfo2
-rw-r--r--java/shujit/files/patch-compiler.h30
3 files changed, 32 insertions, 2 deletions
diff --git a/java/shujit/Makefile b/java/shujit/Makefile
index 1648e735e153..3f42e5677573 100644
--- a/java/shujit/Makefile
+++ b/java/shujit/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= shujit
-PORTVERSION= 0.7.10
+PORTVERSION= 0.7.12
CATEGORIES= java
MASTER_SITES= http://www.shudo.net/jit/dist/
diff --git a/java/shujit/distinfo b/java/shujit/distinfo
index 4a7418a6c210..a911fb53e2a5 100644
--- a/java/shujit/distinfo
+++ b/java/shujit/distinfo
@@ -1 +1 @@
-MD5 (shujit-0.7.10.tar.gz) = 3f1554ea96739bbb4c0b37024e773b8f
+MD5 (shujit-0.7.12.tar.gz) = ed40428c442770dc33d5d23218d1505c
diff --git a/java/shujit/files/patch-compiler.h b/java/shujit/files/patch-compiler.h
new file mode 100644
index 000000000000..18a07c2daa6b
--- /dev/null
+++ b/java/shujit/files/patch-compiler.h
@@ -0,0 +1,30 @@
+
+$FreeBSD$
+
+--- compiler.h 2002/04/26 17:13:45 1.1
++++ compiler.h 2002/04/26 17:17:19
+@@ -18,7 +18,7 @@
+ along with this program; if not, write to the Free Software
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+
+- $Id: compiler.h,v 1.1 2002/04/26 17:13:45 root Exp root $
++ $Id: compiler.h,v 1.1 2002/04/26 17:13:45 root Exp $
+ */
+
+ #ifndef _COMPILER_H_
+@@ -61,13 +61,13 @@
+ // Additional type definition
+
+ #if !(defined(_ILP32) || defined(_LP64))
+-# ifndef _UINT16_T
++# if !defined(_UINT16_T) && !defined(_UINT16_T_DECLARED)
+ # define _UINT16_T
+ typedef unsigned short uint16_t;
+ # endif // _UINT16_T
+
+ # ifndef __BIT_TYPES_DEFINED__
+-# ifndef _INT16_T
++# if !defined(_INT16_T) && !defined(_INT16_T_DECLARED)
+ # define _INT16_T
+ typedef short int16_t;
+ # endif // _INT16_T