aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2018-06-22 22:18:53 +0000
committerRene Ladan <rene@FreeBSD.org>2018-06-22 22:18:53 +0000
commitab24c7a4d6c1354edbc217cf0acaabcc69657a43 (patch)
tree0f399b7aedff3fefaaf200403e58488de64ebdfd /java
parentd383023967423d59f403d10e317727c8e4d08769 (diff)
downloadports-ab24c7a4d6c1354edbc217cf0acaabcc69657a43.tar.gz
ports-ab24c7a4d6c1354edbc217cf0acaabcc69657a43.zip
java/icedtea-web: remove optional support for expired www/libxul.
This means the PLUGIN option is removed. Bump PORTREVISION
Notes
Notes: svn path=/head/; revision=473090
Diffstat (limited to 'java')
-rw-r--r--java/icedtea-web/Makefile15
-rw-r--r--java/icedtea-web/pkg-plist2
2 files changed, 2 insertions, 15 deletions
diff --git a/java/icedtea-web/Makefile b/java/icedtea-web/Makefile
index 1f1d5279ded6..c0df106507a3 100644
--- a/java/icedtea-web/Makefile
+++ b/java/icedtea-web/Makefile
@@ -2,7 +2,7 @@
PORTNAME= icedtea-web
PORTVERSION= 1.6.2
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java www
MASTER_SITES= http://icedtea.wildebeest.org/download/source/ \
http://icedtea.classpath.org/download/source/
@@ -42,11 +42,9 @@ CONFIGURE_SHELL= ${bash_CMD}
TEST_TARGET= check
-OPTIONS_DEFINE= DOCS PLUGIN RHINO TAGSOUP
-OPTIONS_DEFAULT=PLUGIN
+OPTIONS_DEFINE= DOCS RHINO TAGSOUP
OPTIONS_SUB= yes
-PLUGIN_DESC= Enable the browser plug-in
RHINO_DESC= Add support for Proxy Auto Config files
TAGSOUP_DESC= Enable cleaning up of malformed JNLP files
@@ -63,15 +61,6 @@ TAGSOUP_RUN_DEPENDS= ${TAGSOUP_BUILD_DEPENDS}
TAGSOUP_VARS= TAGSOUP_JAR="${JAVALIBDIR}/tagsoup.jar"
TAGSOUP_VARS_OFF= TAGSOUP_JAR=no
-PLUGIN_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libxul.pc:www/libxul
-PLUGIN_CONFIGURE_ENABLE=plugin
-PLUGIN_PORTDOCS= plugin
-PLUGIN_TEST_TARGET= plugin-tests
-PLUGIN_USE= GNOME=glib20
-PLUGIN_USES= webplugin:native
-PLUGIN_VARS= WEBPLUGIN_DIR=${PREFIX}/lib
-PLUGIN_VARS+= WEBPLUGIN_FILES=IcedTeaPlugin.so
-
HAMCREST_JAR= ${JAVALIBDIR}/hamcrest.jar
JUNIT_JAR= ${JAVALIBDIR}/junit.jar
diff --git a/java/icedtea-web/pkg-plist b/java/icedtea-web/pkg-plist
index 7a8f05ab770a..972cc445ebfa 100644
--- a/java/icedtea-web/pkg-plist
+++ b/java/icedtea-web/pkg-plist
@@ -1,7 +1,6 @@
bin/itweb-javaws
bin/itweb-policyeditor
bin/itweb-settings
-%%PLUGIN%%%%WEBPLUGIN_DIR%%/IcedTeaPlugin.so
man/cs/man1/icedtea-web-plugin.1.gz
man/cs/man1/icedtea-web.1.gz
man/cs/man1/itweb-javaws.1.gz
@@ -27,5 +26,4 @@ share/applications/itweb-policyeditor.desktop
share/applications/itweb-settings.desktop
%%DATADIR%%/javaws_splash.png
%%DATADIR%%/netx.jar
-%%PLUGIN%%%%DATADIR%%/plugin.jar
share/pixmaps/itweb-javaws.png