aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-04-02 09:08:47 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-04-02 09:08:47 +0000
commit119dc1bbcaa43c8423905d3858b07ada8fe3ea7e (patch)
tree64c6f8487a027029437c0c0be5a4e28eca1d94af /java
parentb2da9f023f29f22b7a2e41728331845856e1a483 (diff)
downloadports-119dc1bbcaa43c8423905d3858b07ada8fe3ea7e.tar.gz
ports-119dc1bbcaa43c8423905d3858b07ada8fe3ea7e.zip
MFH: r437435 r437437 r437439 r437475 by gerald
Remove files/patch-armv6-hf-support since armv6hf no longer exists as an arch. Reported by: andreast Update lang/gcc and hence the default version of GCC in the Ports Collection (requested by USE_GCC=yes and various USES=compiler invocations) from GCC 4.9.4 to GCC 5.4. files/patch-arm-support and files/patch-gcc_system.h have become obsolete. New patches files/patch-arm-unwind-cxx-support and files/patch-libc++ help support arm targets and new libc++ in base. ONLY_FOR_ARCHS now also includes arm. A new option GRAPHITE_DESC, off by default for now, adds support for Graphite loop optimizations. Finally, conflicts with other lang/gcc* ports are adjusted suitably. In terms of changes for users, this upgrade brings the following: The default mode for C is now -std=gnu11 instead of -std=gnu89. New warning options -Wc90-c99-compat and -Wc99-c11-compat may prove useful on that front. The C++ front end now has full C++14 language support including C++14 variable templates, C++14 aggregates with non-static data member initializers, C++14 extended constexpr, and more. The Standard C++ Library (libstdc++) has full C++11 support and experimental full C++14 support. It uses a new ABI by default. There have been significant improvements to inter-procedural optimizations and link-time optimization such as One Definition Rule based merging of C++ types as well as register allocation. OpenMP 4.0 specification offloading features are now supported by the C, C++, and Fortran compilers. Cilk Plus, an extension to the C and C++ languages to support data and task parallelism, has been added as well. New warning options -Wswitch-bool, -Wlogical-not-parentheses, -Wbool-compare and -Wsizeof-array-argument may prove useful as may new preprocessor directives __has_include, __has_include_next, and __has_attribute. GCC can now be built as a shared library for embedding in other processes (such as interpreters), suitable for Just-In-Time compilation to machine code. This provides a C API and a C++ wrapper API. Many code generation improvements for AArch64, ARM, support for AVX-512{BW,DQ,VL,IFMA,VBMI} and Intel MPX on x86-64, and generally improvements on many targets. The Local Register Allocator (LRA) now contains a rematerialization subpass and is able to reuse the PIC hard register on x86/x86-64 to improve performance of position independent code. https://gcc.gnu.org/gcc-5/changes.html has a more extensive set of changes and https://gcc.gnu.org/gcc-5/porting_to.html has a solid overview of issue you may encountering porting to this new version. PR: 216707, 218125 Tested by: antoine (-exp runs) Supported by: jbeich, tcberner, and others Bump PORTREVISIONs for ports depending on the canonical version of GCC and lang/gcc which have moved from GCC 4.9.4 to GCC 5.4 (at least under some circumstances such as versions of FreeBSD or platforms). This includes ports - with USE_GCC=yes or USE_GCC=any, - with USES=fortran, - using using Mk/bsd.octave.mk which in turn has USES=fortran, and - with USES=compiler specifying openmp, nestedfct, c++11-lib, c++14-lang, c++11-lang, c++0x, c11, or gcc-c++11-lib. PR: 216707 Add support for aarch64. Submitted by: andreast Approved by: ports-secteam (junovitch)
Notes
Notes: svn path=/branches/2017Q2/; revision=437538
Diffstat (limited to 'java')
-rw-r--r--java/classpath/Makefile2
-rw-r--r--java/intellij-fsnotifier/Makefile2
-rw-r--r--java/sigar/Makefile2
3 files changed, 3 insertions, 3 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index 60a6e7fbaf57..76a6cc5668de 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -3,7 +3,7 @@
PORTNAME= classpath
PORTVERSION= 0.99
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= java devel
MASTER_SITES= GNU \
SAVANNAH
diff --git a/java/intellij-fsnotifier/Makefile b/java/intellij-fsnotifier/Makefile
index e4ec16a122e1..1a831b854a87 100644
--- a/java/intellij-fsnotifier/Makefile
+++ b/java/intellij-fsnotifier/Makefile
@@ -3,7 +3,7 @@
PORTNAME= intellij-fsnotifier
PORTVERSION= 20160221
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= java devel
MAINTAINER= tobik@FreeBSD.org
diff --git a/java/sigar/Makefile b/java/sigar/Makefile
index b7e435ae2086..44f160e4659d 100644
--- a/java/sigar/Makefile
+++ b/java/sigar/Makefile
@@ -3,7 +3,7 @@
PORTNAME= sigar
PORTVERSION= 1.7.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= java devel
PKGNAMEPREFIX= java-