aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2013-04-27 11:59:28 +0000
committerMarcus von Appen <mva@FreeBSD.org>2013-04-27 11:59:28 +0000
commita3a0715f38d5f411396a809915aa2fc5c204bc16 (patch)
treee580bb4c66185f6741df23146d4617f207efeeef /java
parent3d733a71dc5d9ecc73e88a75de9cb8a6400329cd (diff)
downloadports-a3a0715f38d5f411396a809915aa2fc5c204bc16.tar.gz
ports-a3a0715f38d5f411396a809915aa2fc5c204bc16.zip
- Convert USE_ICONV=yes to USES=iconv
- Change USE_GNOME=pkgconfig|gnomehack to USES=pathfix|pkgconfig while here Reviewed by: zeising
Notes
Notes: svn path=/head/; revision=316662
Diffstat (limited to 'java')
-rw-r--r--java/classpath/Makefile3
-rw-r--r--java/jikes/Makefile2
-rw-r--r--java/openjdk7/Makefile2
-rw-r--r--java/sablevm/Makefile3
4 files changed, 4 insertions, 6 deletions
diff --git a/java/classpath/Makefile b/java/classpath/Makefile
index fb7310e5fd9e..054db015678f 100644
--- a/java/classpath/Makefile
+++ b/java/classpath/Makefile
@@ -17,9 +17,8 @@ COMMENT= A GNU project to create a free Java class library
LICENSE= GPLv2
GNU_CONFIGURE= yes
-USES= pkgconfig
+USES= pkgconfig iconv
USE_GMAKE= yes
-USE_ICONV= yes
USE_LDCONFIG= yes
USE_PERL5_BUILD=yes
USE_XORG= x11 ice xtst xaw xproto xext
diff --git a/java/jikes/Makefile b/java/jikes/Makefile
index 1077e5d6e819..73a1c9ed21de 100644
--- a/java/jikes/Makefile
+++ b/java/jikes/Makefile
@@ -19,7 +19,7 @@ MAN1= jikes.1
PLIST_SUB= PORTVERSION=${PORTVERSION}
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_BZIP2= yes
CONFIGURE_ARGS= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index a516d5ba2da8..1cfabbaed0c6 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -31,7 +31,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
USE_ZIP= yes
USE_GMAKE= yes
-USE_ICONV= yes
+USES= iconv
USE_XORG+= x11 xext xi xrender xt xtst
MAKE_JOBS_UNSAFE= yes
diff --git a/java/sablevm/Makefile b/java/sablevm/Makefile
index b56b2398c3cf..fa94faa79783 100644
--- a/java/sablevm/Makefile
+++ b/java/sablevm/Makefile
@@ -19,9 +19,8 @@ RUN_DEPENDS= fastjar:${PORTSDIR}/archivers/fastjar
GNU_CONFIGURE= yes
USE_AUTOTOOLS= libltdl
USE_GMAKE= yes
-USE_ICONV= yes
USE_LDCONFIG= yes
-USES= pkgconfig gettext
+USES= pkgconfig gettext iconv
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib