aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2006-12-11 18:34:59 +0000
committerMikhail Teterin <mi@FreeBSD.org>2006-12-11 18:34:59 +0000
commit31efa2ae0d880bd31fffde0f4e77ed2405540427 (patch)
tree4b6e762af259f0fd7692f3bef1fc268a397fad27 /java
parentf408694b2f9faba932b1750d739b1734d113fcef (diff)
downloadports-31efa2ae0d880bd31fffde0f4e77ed2405540427.tar.gz
ports-31efa2ae0d880bd31fffde0f4e77ed2405540427.zip
Update from 3.1.0 to 3.2.13. This should fix all of the self-test failures
observed so far (spurious and real). Update WWW. Although supposedly a minor bug-fix release, this one still comes with a file-format change, unfortunately. See vendor's announcement at: http://forums.oracle.com/forums/ann.jspa?annID=372
Notes
Notes: svn path=/head/; revision=179513
Diffstat (limited to 'java')
-rw-r--r--java/berkeley-db/Makefile2
-rw-r--r--java/berkeley-db/distinfo6
-rw-r--r--java/berkeley-db/files/patch-test-failure170
-rw-r--r--java/berkeley-db/pkg-descr3
4 files changed, 5 insertions, 176 deletions
diff --git a/java/berkeley-db/Makefile b/java/berkeley-db/Makefile
index a59a70229af9..e5d1908fa09e 100644
--- a/java/berkeley-db/Makefile
+++ b/java/berkeley-db/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= je
-PORTVERSION= 3.1.0
+PORTVERSION= 3.2.13
CATEGORIES= java databases
MASTER_SITES= http://download.oracle.com/berkeley-db/ \
http://download-east.oracle.com/berkeley-db/ \
diff --git a/java/berkeley-db/distinfo b/java/berkeley-db/distinfo
index 5e7be5dd0137..90f1c6d4f1dd 100644
--- a/java/berkeley-db/distinfo
+++ b/java/berkeley-db/distinfo
@@ -1,3 +1,3 @@
-MD5 (je-3.1.0.tar.gz) = 51f334898d2a7b0e263da31e7603987d
-SHA256 (je-3.1.0.tar.gz) = d056deadfc1eaea8f7a78049a62b3306b915806c0c92acef20d7a84a6122bba7
-SIZE (je-3.1.0.tar.gz) = 4703334
+MD5 (je-3.2.13.tar.gz) = 0a15a6fa390a02120197a6f1dbc2114e
+SHA256 (je-3.2.13.tar.gz) = b08288461464940a3009ed49b9a4094267fa852a288db956b2064627e6fb1e76
+SIZE (je-3.2.13.tar.gz) = 4787860
diff --git a/java/berkeley-db/files/patch-test-failure b/java/berkeley-db/files/patch-test-failure
deleted file mode 100644
index b700a7edef5d..000000000000
--- a/java/berkeley-db/files/patch-test-failure
+++ /dev/null
@@ -1,170 +0,0 @@
-This are temporary work-arounds for spurious test failures. See the discussions at
-
- http://forums.oracle.com/forums/thread.jspa?threadID=431242
- http://forums.oracle.com/forums/thread.jspa?threadID=431549
- http://forums.oracle.com/forums/thread.jspa?threadID=446837
-
-The last one appears somewhat scary, but SleepyCat/Oracle's support assures me, the problem
-can be ignored as it has to do with the test framework and not the software itself.
-
- -mi
-
---- test/com/sleepycat/je/recovery/CheckpointActivationTest.java Tue Sep 12 15:17:22 2006
-+++ test/com/sleepycat/je/recovery/CheckpointActivationTest.java Fri Oct 6 23:42:55 2006
-@@ -51,5 +51,5 @@
- * checkpoints ran.
- */
-- public void testLogSizeBasedCheckpoints()
-+ public void meowLogSizeBasedCheckpoints()
- throws Exception {
-
---- test/com/sleepycat/je/test/DeferredWriteTest.java Tue Sep 12 15:17:24 2006
-+++ test/com/sleepycat/je/test/DeferredWriteTest.java Tue Oct 10 17:22:34 2006
-@@ -524,5 +524,5 @@
- }
-
-- public void testCleaning5000()
-+ public void meowCleaning5000()
- throws Throwable {
-
-@@ -530,5 +530,5 @@
- }
-
-- public void testCleaning2000()
-+ public void meowCleaning2000()
- throws Throwable {
-
-Index: test/com/sleepycat/je/cleaner/ReadOnlyLockingTest.java
-===================================================================
-diff -c -r1.7 ReadOnlyLockingTest.java
-*** test/com/sleepycat/je/cleaner/ReadOnlyLockingTest.java 12 Sep 2006 19:17:14 -0000 1.7
---- test/com/sleepycat/je/cleaner/ReadOnlyLockingTest.java 23 Nov 2006 00:07:40 -0000
-***************
-*** 36,41 ****
---- 35,41 ----
- public class ReadOnlyLockingTest extends TestCase {
-
- private static final int FILE_SIZE = 4096;
-+ private static final int READER_STARTUP_SECS = 30;
-
- private static final CheckpointConfig forceConfig = new CheckpointConfig();
- static {
-***************
-*** 48,53 ****
---- 48,72 ----
- private Database db;
- private Process readerProcess;
-
-+ private static File getProcessFile() {
-+ return new File(System.getProperty(TestUtils.DEST_DIR),
-+ "ReadOnlyProcessFile");
-+ }
-+
-+ private static void deleteProcessFile() {
-+ File file = getProcessFile();
-+ file.delete();
-+ TestCase.assertTrue(!file.exists());
-+ }
-+
-+ static void createProcessFile()
-+ throws IOException {
-+
-+ File file = getProcessFile();
-+ TestCase.assertTrue(file.createNewFile());
-+ TestCase.assertTrue(file.exists());
-+ }
-+
- public ReadOnlyLockingTest() {
- envHome = new File(System.getProperty(TestUtils.DEST_DIR));
- }
-***************
-*** 55,60 ****
---- 74,81 ----
- public void setUp()
- throws IOException, DatabaseException {
-
-+ deleteProcessFile();
-+
- TestUtils.removeLogFiles("Setup", envHome, false);
- TestUtils.removeFiles("Setup", envHome, FileManager.DEL_SUFFIX);
- }
-***************
-*** 62,67 ****
---- 83,90 ----
- public void tearDown()
- throws IOException, DatabaseException {
-
-+ deleteProcessFile();
-+
- try {
- stopReaderProcess();
- } catch (Throwable e) {
-***************
-*** 219,228 ****
- ReadOnlyProcess.class.getName(),
- };
-
-! /* Start it and give it a chance to open the environment. */
- readerProcess = Runtime.getRuntime().exec(cmd);
-! Thread.sleep(2000);
- //printReaderStatus();
- }
-
- private void stopReaderProcess()
---- 242,264 ----
- ReadOnlyProcess.class.getName(),
- };
-
-! /* Start it and wait for it to open the environment. */
- readerProcess = Runtime.getRuntime().exec(cmd);
-! long startTime = System.currentTimeMillis();
-! boolean running = false;
-! while (!running &&
-! ((System.currentTimeMillis() - startTime) <
-! (READER_STARTUP_SECS * 1000))) {
-! if (getProcessFile().exists()) {
-! running = true;
-! } else {
-! Thread.sleep(10);
-! }
-! }
- //printReaderStatus();
-+ assertTrue("ReadOnlyProcess did not start after " +
-+ READER_STARTUP_SECS + " + secs",
-+ running);
- }
-
- private void stopReaderProcess()
-Index: test/com/sleepycat/je/cleaner/ReadOnlyProcess.java
-===================================================================
-*** test/com/sleepycat/je/cleaner/ReadOnlyProcess.java 12 Sep 2006 19:17:14 -0000 1.5
---- test/com/sleepycat/je/cleaner/ReadOnlyProcess.java 23 Nov 2006 00:07:40 -0000
-***************
-*** 16,22 ****
- import com.sleepycat.je.util.TestUtils;
-
- /**
-! * @see ReadOnlyLockerTest
- */
- public class ReadOnlyProcess {
-
---- 15,21 ----
- import com.sleepycat.je.util.TestUtils;
-
- /**
-! * @see ReadOnlyLockingTest
- */
- public class ReadOnlyProcess {
-
-***************
-*** 36,41 ****
---- 35,43 ----
-
- //System.err.println("Opened read-only: " + envHome);
- //System.err.println(System.getProperty("java.class.path"));
-+
-+ /* Notify the test that this process has opened the environment. */
-+ ReadOnlyLockingTest.createProcessFile();
-
- /* Sleep until the parent process kills me. */
- Thread.sleep(Long.MAX_VALUE);
diff --git a/java/berkeley-db/pkg-descr b/java/berkeley-db/pkg-descr
index ae8b50f35e5e..715cfeafe69f 100644
--- a/java/berkeley-db/pkg-descr
+++ b/java/berkeley-db/pkg-descr
@@ -2,8 +2,7 @@ This is a pure-Java implementation of Berkeley DB by SleepyCat (now
Oracle). Java-1.5 is required for building, although the result should
be usable with 1.4 too. From the
-WWW: http://www.sleepycat.com/products/je.shtml
-WWW: http://www.oracle.com/technology/products/berkeley-db/je/
+WWW: http://www.oracle.com/database/berkeley-db/index.html
"Berkeley DB JE was designed from the ground up in Java. It takes full
advantage of the Java environment. The Berkeley DB JE API provides a