aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2008-08-29 05:27:16 +0000
committerGreg Lewis <glewis@FreeBSD.org>2008-08-29 05:27:16 +0000
commitbfd6dd958479dd8f2d37354bddc135f04cd2d8c8 (patch)
treec8de53965f12047e4b610f40ee9edc6b8c727715 /java
parentd7889f872f74b6b62ad7da9e743ce5eb22a974fd (diff)
downloadports-bfd6dd958479dd8f2d37354bddc135f04cd2d8c8.tar.gz
ports-bfd6dd958479dd8f2d37354bddc135f04cd2d8c8.zip
. Enforce JAVA_VERSION of 1.6 on FreeBSD 7.x and better. While jdk15 will
work, diablo-jdk15 won't, so the safest way to do this is to just enforce jdk16 or diablo-jdk16. . Enforce using something that was compiled on FreeBSD 8.x since the binary packages are likely to cause problems.
Notes
Notes: svn path=/head/; revision=219401
Diffstat (limited to 'java')
-rw-r--r--java/eclipse/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index f7400294d0e8..89633d194385 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -61,6 +61,10 @@ MAKE_CAIRO= make_cairo
.include <bsd.port.pre.mk>
.if ${OSVERSION} >= 700000
+JAVA_VERSION= 1.6
+.endif
+
+.if ${OSVERSION} >= 800000
JAVA_VENDOR= bsdjava
.endif