aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-04-13 15:51:45 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-04-13 15:51:45 +0000
commit09c199f0f728a6889c2263825c8ba6a0840786b0 (patch)
treecd6d6c6a8dafbe492b386e0ff380b0519c50414a /java
parentfe6c10e9aa45705d55b76bb0f5472bc52299bc5b (diff)
downloadports-09c199f0f728a6889c2263825c8ba6a0840786b0.tar.gz
ports-09c199f0f728a6889c2263825c8ba6a0840786b0.zip
DbVisualizer is a feature rich, intuitive and cross platform database tool
for developers and DBA's providing a single powerful interface for a variety of databases. DbVisualizer supports simultaneous database connections, it lets you explore and manage database objects, execute SQL queries, visualize information and a lot more. WWW: http://www.dbvis.com/products/dbvis/ PR: ports/111380 Submitted by: Anton Yudin (<contact at toha.org.ua>)
Notes
Notes: svn path=/head/; revision=189906
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/dbvis/Makefile39
-rw-r--r--java/dbvis/distinfo3
-rw-r--r--java/dbvis/pkg-descr7
4 files changed, 50 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index ae53bcec7bb4..c2f39d23a641 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -14,6 +14,7 @@
SUBDIR += collections
SUBDIR += cos
SUBDIR += cryptix-jce
+ SUBDIR += dbvis
SUBDIR += diablo-jdk15
SUBDIR += diablo-jre15
SUBDIR += drexelsnmp
diff --git a/java/dbvis/Makefile b/java/dbvis/Makefile
new file mode 100644
index 000000000000..2b515540161a
--- /dev/null
+++ b/java/dbvis/Makefile
@@ -0,0 +1,39 @@
+# Ports collection makefile for: DbVisualizer
+# Date created: April 08, 2007
+# Whom: Anton Yudin (<contact@toha.org.ua>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= dbvis
+PORTVERSION= 5.1.1
+CATEGORIES= java devel
+MASTER_SITES= http://www.dbvis.com/product_download/dbvis/media/
+DISTNAME= dbvis_unix_5_1_1
+
+MAINTAINER= contact@toha.org.ua
+COMMENT= DbVisualizer database tool
+
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+NO_BUILD= yes
+RESTRICTED= Redistribution is not permitted
+
+PLIST_FILES= bin/dbvis
+WRKSRC= DbVisualizer-5.1.1
+
+do-install:
+ cd ${WRKDIR}/${WRKSRC} \
+ && ${FIND} . -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \; \
+ && ${LN} -s ${DATADIR}/dbvis ${PREFIX}/bin/dbvis \
+ && ${CHMOD} a+x ${DATADIR}/dbvis
+
+post-install:
+ cd ${WRKDIR}/${WRKSRC} && \
+ ${FIND} ${DATADIR} -not -type d \
+ | ${SED} -ne 's,^${PREFIX}/,,p' >> ${TMPPLIST}
+ ${FIND} -d ${DATADIR} -type d \
+ | ${SED} -ne 's,^${PREFIX},@dirrm ,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/java/dbvis/distinfo b/java/dbvis/distinfo
new file mode 100644
index 000000000000..2724a48ceac8
--- /dev/null
+++ b/java/dbvis/distinfo
@@ -0,0 +1,3 @@
+MD5 (dbvis_unix_5_1_1.tar.gz) = 334650d7d5e7d85127d6f330fee9f516
+SHA256 (dbvis_unix_5_1_1.tar.gz) = 9422a49a1e77babd937934465a9c1adad6d740209d963ab08520e21b0edbd13c
+SIZE (dbvis_unix_5_1_1.tar.gz) = 9951514
diff --git a/java/dbvis/pkg-descr b/java/dbvis/pkg-descr
new file mode 100644
index 000000000000..e6c5dc415a22
--- /dev/null
+++ b/java/dbvis/pkg-descr
@@ -0,0 +1,7 @@
+DbVisualizer is a feature rich, intuitive and cross platform database tool
+for developers and DBA's providing a single powerful interface for a variety
+of databases. DbVisualizer supports simultaneous database connections, it
+lets you explore and manage database objects, execute SQL queries,
+visualize information and a lot more.
+
+WWW: http://www.dbvis.com/products/dbvis/