aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGreg Lewis <glewis@FreeBSD.org>2010-01-21 15:47:16 +0000
committerGreg Lewis <glewis@FreeBSD.org>2010-01-21 15:47:16 +0000
commitaa02145d8819b6892ff1e92a8310e94108e5f6ee (patch)
treeb164484442206455143a7438f06ee6cd18c23e17 /java
parent79534bfe7b2f1dfbfe116be3aab0eb48e3f2f545 (diff)
downloadports-aa02145d8819b6892ff1e92a8310e94108e5f6ee.tar.gz
ports-aa02145d8819b6892ff1e92a8310e94108e5f6ee.zip
. Install the unlimited strength crypto policy JARs rather than the
limited strength ones. Since unlike many other JDK ports this doesn't require an extra download its currently done for all installs rather than being an option. Note that unlike the officially downloaded policy JARs the ones this installs are not signed. This may mean we revisit it once there is an official JDK7 release. . Bump PORTREVISION for this change. Submitted by: ale@
Notes
Notes: svn path=/head/; revision=248275
Diffstat (limited to 'java')
-rw-r--r--java/openjdk7/Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/java/openjdk7/Makefile b/java/openjdk7/Makefile
index bc052268fb63..2f58bc89cd47 100644
--- a/java/openjdk7/Makefile
+++ b/java/openjdk7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= openjdk
PORTVERSION= ${JDK_MAJOR_VERSION}.${JDK_MINOR_VERSION}.${JDK_BUILD_NUMBER}
+PORTREVISION= 1
CATEGORIES= java devel
MASTER_SITES= http://download.java.net/openjdk/jdk7/promoted/b${JDK_BUILD_NUMBER}/ \
${MASTER_SITE_APACHE:S,%SUBDIR%/,ant/binaries/:ant,}
@@ -111,6 +112,10 @@ post-extract:
${SED} -e 's/linux/bsd/g' -e 's/Linux/Bsd/g' -e 's/LINUX/BSD/g' $$file > $$newfile; \
done
+post-patch:
+ @${REINPLACE_CMD} 's|build-policy install-limited|build-policy install-unlimited|' \
+ ${WRKSRC}/jdk/make/javax/crypto/Makefile
+
do-install:
@${MKDIR} ${INSTALLDIR}
@cd ${WRKSRC}/build/${OPENJDK_OSARCH}/j2sdk-image && \