aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-10-05 21:15:33 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-10-05 21:15:33 +0000
commite42ae23d49d27f78e7f22cf8f1bf0a7586483dfd (patch)
tree8df2963e66ca3ab1a1be8cbaab9a2bf0868d4e49 /java
parentb46d46983ccebe7ad6c3f505a9c818d4c4d5389a (diff)
downloadports-e42ae23d49d27f78e7f22cf8f1bf0a7586483dfd.tar.gz
ports-e42ae23d49d27f78e7f22cf8f1bf0a7586483dfd.zip
Development using the properties file is performed by Java by the setting
file of J2EE application, internationalization correspondence with desktop application, etc. being sufficient. However, you have to change the multi-byte character in a file into Unicode with the native2ascii tool of attachment in J2SDK on the character platform un-depending. This editor can directly edit property files written in Unicode reference characters, and saves the time and effort of converting into Unicode through native2ascii. In addition to the usual functions of an editor, the plugin is integrated with Eclipse and JBuilder. Files can be opened in the IDE and saved in Unicode. It can use by intuitive and simple operation. WWW: http://propedit.sourceforge.jp/index_en.html PR: ports/116871 Submitted by: Sutra Zhou <zhoushuqun at gmail.com>
Notes
Notes: svn path=/head/; revision=200933
Diffstat (limited to 'java')
-rw-r--r--java/Makefile1
-rw-r--r--java/eclipse-propedit/Makefile38
-rw-r--r--java/eclipse-propedit/distinfo3
-rw-r--r--java/eclipse-propedit/pkg-descr12
-rw-r--r--java/eclipse-propedit/pr-patch84
5 files changed, 138 insertions, 0 deletions
diff --git a/java/Makefile b/java/Makefile
index b5f7b4705033..3da72317aed1 100644
--- a/java/Makefile
+++ b/java/Makefile
@@ -38,6 +38,7 @@
SUBDIR += eclipse-lomboz
SUBDIR += eclipse-ocl
SUBDIR += eclipse-pmd
+ SUBDIR += eclipse-propedit
SUBDIR += eclipse-quantum
SUBDIR += eclipse-sqlexplorer
SUBDIR += eclipse-sysdeo-tomcat
diff --git a/java/eclipse-propedit/Makefile b/java/eclipse-propedit/Makefile
new file mode 100644
index 000000000000..cb30746c9020
--- /dev/null
+++ b/java/eclipse-propedit/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: eclipse-propedit
+# Date created: 3 October 2007
+# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= PropertiesEditor
+PORTVERSION= 4.8.2
+CATEGORIES= java devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+MASTER_SITE_SUBDIR= propedit/17247
+PKGNAMEPREFIX= eclipse-
+DISTNAME= jp.gr.java_conf.ussiy.app.propedit_${PORTVERSION}_for_eclipse3.0
+DIST_SUBDIR= eclipse
+
+MAINTAINER= zhoushuqun@gmail.com
+COMMENT= Properties editor for eclipse
+
+RUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+USE_ZIP= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.4+
+JAVA_OS= native
+
+do-install:
+ @${MKDIR} ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+ @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+ @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+ @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+ | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+ | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+
+.include <bsd.port.mk>
diff --git a/java/eclipse-propedit/distinfo b/java/eclipse-propedit/distinfo
new file mode 100644
index 000000000000..30f3f38ac53d
--- /dev/null
+++ b/java/eclipse-propedit/distinfo
@@ -0,0 +1,3 @@
+MD5 (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = c056713f81ef44ddd0e5b49b3120baca
+SHA256 (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = 0f5c3b82d7922e55bd171d853aa9443bb26c189fbcc1dd9129edb08a4b19a3f6
+SIZE (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = 145214
diff --git a/java/eclipse-propedit/pkg-descr b/java/eclipse-propedit/pkg-descr
new file mode 100644
index 000000000000..4208159dbff5
--- /dev/null
+++ b/java/eclipse-propedit/pkg-descr
@@ -0,0 +1,12 @@
+Development using the properties file is performed by Java by the setting
+file of J2EE application, internationalization correspondence with desktop
+application, etc. being sufficient. However, you have to change the multi-byte
+character in a file into Unicode with the native2ascii tool of attachment in
+J2SDK on the character platform un-depending.
+This editor can directly edit property files written in Unicode reference
+characters, and saves the time and effort of converting into Unicode through
+native2ascii. In addition to the usual functions of an editor, the plugin is
+integrated with Eclipse and JBuilder. Files can be opened in the IDE and saved
+in Unicode. It can use by intuitive and simple operation.
+
+WWW: http://propedit.sourceforge.jp/index_en.html
diff --git a/java/eclipse-propedit/pr-patch b/java/eclipse-propedit/pr-patch
new file mode 100644
index 000000000000..016fcf5ad52b
--- /dev/null
+++ b/java/eclipse-propedit/pr-patch
@@ -0,0 +1,84 @@
+
+
+Patch attached with submission follows:
+
+# This is a shell archive. Save it in a file, remove anything before
+# this line, and then unpack it by entering "sh file". Note, it may
+# create directories; files and directories will be owned by you and
+# have default permissions.
+#
+# This archive contains:
+#
+# .
+# ./Makefile
+# ./distinfo
+# ./pkg-descr
+#
+echo c - .
+mkdir -p . > /dev/null 2>&1
+echo x - ./Makefile
+sed 's/^X//' >./Makefile << 'END-of-./Makefile'
+X# New ports collection makefile for: eclipse-propedit
+X# Date created: 3 October 2007
+X# Whom: Sutra Zhou <zhoushuqun@gmail.com>
+X#
+X# $FreeBSD$
+X#
+X
+XPORTNAME= PropertiesEditor
+XPORTVERSION= 4.8.2
+XCATEGORIES= java devel
+XMASTER_SITES= ${MASTER_SITE_SOURCEFORGE_JP}
+XMASTER_SITE_SUBDIR= propedit/17247
+XPKGNAMEPREFIX= eclipse-
+XDISTNAME= jp.gr.java_conf.ussiy.app.propedit_${PORTVERSION}_for_eclipse3.0
+XDIST_SUBDIR= eclipse
+X
+XMAINTAINER= zhoushuqun@gmail.com
+XCOMMENT= Properties editor for eclipse
+X
+XRUN_DEPENDS= eclipse:${PORTSDIR}/java/eclipse
+X
+XNO_BUILD= yes
+XNO_WRKSUBDIR= yes
+XUSE_ZIP= yes
+XUSE_JAVA= yes
+XJAVA_VERSION= 1.4+
+XJAVA_OS= native
+X
+Xdo-install:
+X @${MKDIR} ${PREFIX}/eclipse
+X @${CP} -r ${WRKSRC}/eclipse/plugins ${PREFIX}/eclipse
+X @${CP} -r ${WRKSRC}/eclipse/features ${PREFIX}/eclipse
+X @(cd ${WRKSRC}; ${FIND} -s eclipse/features eclipse/plugins -not -type d) >> ${TMPPLIST}
+X @(cd ${WRKSRC}; ${FIND} -s -d eclipse/features eclipse/plugins -type d) \
+X | ${GREP} -vE 'eclipse/plugins$$|eclipse/features$$' \
+X | ${SED} -ne 's,^,@dirrm ,p' >> ${TMPPLIST}
+X
+X.include <bsd.port.mk>
+END-of-./Makefile
+echo x - ./distinfo
+sed 's/^X//' >./distinfo << 'END-of-./distinfo'
+XMD5 (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = c056713f81ef44ddd0e5b49b3120baca
+XSHA256 (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = 0f5c3b82d7922e55bd171d853aa9443bb26c189fbcc1dd9129edb08a4b19a3f6
+XSIZE (eclipse/jp.gr.java_conf.ussiy.app.propedit_4.8.2_for_eclipse3.0.zip) = 145214
+END-of-./distinfo
+echo x - ./pkg-descr
+sed 's/^X//' >./pkg-descr << 'END-of-./pkg-descr'
+XDevelopment using the properties file is performed by Java by the setting
+Xfile of J2EE application, internationalization correspondence with desktop
+Xapplication, etc. being sufficient. However, you have to change the multi-byte
+Xcharacter in a file into Unicode with the native2ascii tool of attachment in
+XJ2SDK on the character platform un-depending.
+XThis editor can directly edit property files written in Unicode reference
+Xcharacters, and saves the time and effort of converting into Unicode through
+Xnative2ascii. In addition to the usual functions of an editor, the plugin is
+Xintegrated with Eclipse and JBuilder. Files can be opened in the IDE and saved
+Xin Unicode. It can use by intuitive and simple operation.
+X
+XWWW: http://propedit.sourceforge.jp/index_en.html
+END-of-./pkg-descr
+exit
+
+
+