aboutsummaryrefslogtreecommitdiff
path: root/java
diff options
context:
space:
mode:
authorGary Palmer <gpalmer@FreeBSD.org>1996-07-04 01:23:31 +0000
committerGary Palmer <gpalmer@FreeBSD.org>1996-07-04 01:23:31 +0000
commit8ece2cdaccd619dffdab10250742136c111dcc82 (patch)
treebd09a29af3bdfa159a83078e1ca6a918a9f3765e /java
parentc82c1a62312927fd7633a4369da04bdcd13a5b94 (diff)
downloadports-8ece2cdaccd619dffdab10250742136c111dcc82.tar.gz
ports-8ece2cdaccd619dffdab10250742136c111dcc82.zip
Update so that classes.zip is taken from the JDK, not included in
this port. Slight rephrasing of the error message to make it more informative. Submitted by: Chuck Robey <chuckr@glue.umd.edu>
Notes
Notes: svn path=/head/; revision=3298
Diffstat (limited to 'java')
-rw-r--r--java/kaffe/Makefile16
-rw-r--r--java/kaffe/distinfo2
-rw-r--r--java/kaffe/pkg-plist19
3 files changed, 20 insertions, 17 deletions
diff --git a/java/kaffe/Makefile b/java/kaffe/Makefile
index b4163a2e12cc..83e67c40cbb1 100644
--- a/java/kaffe/Makefile
+++ b/java/kaffe/Makefile
@@ -1,12 +1,12 @@
# New ports collection makefile for: kaffe
-# Version required: 0.3
+# Version required: 0.4
# Date created: 20 February 1995
# Whom: Tim Wilkinson <tim@sarc.city.ac.uk>
#
-# $Id: Makefile,v 1.1.1.1 1996/03/07 03:53:56 asami Exp $
+# $Id: Makefile,v 1.2 1996/04/04 01:07:43 scrappy Exp $
#
-DISTNAME= kaffe-0.3
+DISTNAME= kaffe-0.4p2
CATEGORIES+= www
MASTER_SITES= ftp://ftp.sarc.city.ac.uk/pub/kaffe/
EXTRACT_SUFX= .tgz
@@ -15,12 +15,18 @@ MAINTAINER= tim@sarc.city.ac.uk
GNU_CONFIGURE= yes
+pre-extract:
+ @( if test "`${MD5} ${PREFIX}/share/java/classes.zip | ${AWK} '{print $$4}'`" != "`cat ${FILESDIR}/classes.zip.1.02.md5`" ; then \
+ echo "kaffe REQUIRES the classes.zip file from ports/www/jdk, version 1.02"; \
+ exit 1 ; \
+ fi)
+
do-configure:
@(cd ${WRKSRC}; ${CONFIGURE_ENV} ./${CONFIGURE_SCRIPT} ${CONFIGURE_ARGS})
post-install:
- cp ${WRKSRC}/sun/COPYRIGHT ${PREFIX}/share/kaffe
- cp ${WRKSRC}/license.terms ${PREFIX}/share/kaffe
+ test -d ${PREFIX}/share/kaffe || mkdir -p ${PREFIX}/share/kaffe
+ install -c -m 644 ${WRKSRC}/license.terms ${PREFIX}/share/kaffe
/sbin/ldconfig -m ${PREFIX}/lib
.include <bsd.port.mk>
diff --git a/java/kaffe/distinfo b/java/kaffe/distinfo
index 975bbaf55014..ea6deafe5417 100644
--- a/java/kaffe/distinfo
+++ b/java/kaffe/distinfo
@@ -1 +1 @@
-MD5 (kaffe-0.3.tgz) = 969bd3e49b2eb302e01c0b8dbf21bc49
+MD5 (kaffe-0.4p2.tgz) = ee62dcb04192be3f493c241b7f215eb2
diff --git a/java/kaffe/pkg-plist b/java/kaffe/pkg-plist
index b94f620eabb2..c8c1c3d0c93f 100644
--- a/java/kaffe/pkg-plist
+++ b/java/kaffe/pkg-plist
@@ -1,18 +1,15 @@
+@name kaffe
+@owner bin
+@group bin
bin/javac
bin/javadoc
bin/kaffe
bin/kaffeh
include/kaffe/native.h
include/kaffe/stubPreamble.h
-lib/libkaffe_agent.so.0.3
-lib/libkaffe_mmedia.so.0.3
-lib/libkaffe_vm.so.0.3
-lib/libkaffe_awt.so.0.3
-lib/libkaffe_native.so.0.3
-lib/libkaffe_jpeg.so.0.3
-lib/libkaffe_net.so.0.3
-@exec /sbin/ldconfig -m %B
-share/kaffe/classes.zip
-share/kaffe/lib/javac.properties
-share/kaffe/COPYRIGHT
+include/kaffe/jtypes.h
+lib/libkaffe_vm.so.0.4
+lib/libkaffe_native.so.0.4
+lib/libkaffe_net.so.0.4
share/kaffe/license.terms
+@exec /sbin/ldconfig -m %B